Playbar Sound Quality using Sky Q

  • 14 February 2017
  • 8 replies

I have my Sky Q connected to my Playbar using HDMI in and Optical out through my Samsung Smart TV. The sound quality is poor, very tinny. I find if I set Sky Q to Dolby some channels have no sound at all, so I have to set it to Normal. My TV audio is set to PCM. I don't have a Sonos sub, and I am finding I have to set the bass to maximum to get any depth at all to the sound. I also have two Play 1s set up for surround sound but when using Sky Q I hardly hear anything through them, just the occasional almost undetectable sound.

Playing music through the system is fine, and playing Netflix on my TV through the Sonos system is fine as well. it's just Sky Q. When I switch to Spotify or Netfix from my Smart TV the volume blasts out all of a sudden, the Sky output volume is extremely low.

I don't want to connect Sky Q audio optical out directly to the Playbar as then the playbar won't receive any other audio source from the Smart TV, e.g. Netflix, Amazon Video, Spotify etc. and I don't think it improves the sound anyway.

I would go so far as to say the sound quality from the TV speakers is better than my Sonos setup when using Sky Q.

Anyone got any suggestions?



This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Hi, David.

I'm not a Sky Q user myself, being in the states, but I can suggest a couple of things to you.

First, change your TV's audio from PCM to Dolby Digital. Right now, you're restricting everything that is playing to just stereo, Your TV being set to PCM is forcing everything coming out of the optical port down to stereo, and then the Playbar is interpolating data to fill the surround channels. It does an OK job, but not nearly as good as if you feed the Playbar a full Dolby Digital signal.

This is why playing music works well, it's just the TV sound that's tinny. I'd also double check the audio settings on your Sky Q box, and ensure that it's also set to Dolby Digital. I have the feeling it's set to something else, which is why on some channels, you're not getting sound. Basically, you need the input on the HDMI to be locked to Dolby Digital, and the output from the TV locked to the same thing.

That being said, testing by connecting the Playbar to the Sky Q box isn't a bad thing, just as a temporary test to make sure it's working properly. I understand (and concur) as to why you wouldn't want that to be a permanent situation.

While you're in the Sky Q box audio settings, you may want to check to see if you can set the output sound to "Fixed" rather than "Variable", it may be that the volume you're sending through the HDMI is not sufficient, which would cause that lack of bass and audio levels to be different when using different inputs.

Hope this helps!
Hi Bruce,

I have the Sky Q box set to Dolby for both HDMI and Optical outputs. I can't find a fixed volume setting in the menu.

I have tried setting the TV external speaker output to both PCM and Dolby.

The optical output from the tv is silent for any channel broadcasting Dolby 5.1, but live for channels broadcasting stereo 2.0.

I have spoken to Samsung on twitter and they say my TV should allow 5.1 pass through from HDMI to Optical, so I'm waiting for a callback from them. The software is up to date.

If the TV isn't doing what it should after that, I believe my options are to spend about £30 on an ARC converter, and plug that into the ARC HDMI port on the TV. Or else buy a new TV for about £700.



Huh. Well, you've covered all the bases that I can think of (hmmm, maybe I shouldn't use a US baseball reference....)

Sounds like you're taking the correct steps. I'd also be talking to Samsung at this point, and I'd also have checked to see if the firmware on the TV was current, so I guess we need to wait for Samsung to get back to you. Just as a random thought, have you tried putting the HDMI cable into a different input? I seem to dimly recall somebody at some point had a TV that had an issue where one HDMI input wouldn't do 5.1, but another would. I could never figure that one out, in my mind, but it's worth the minute it would take to test it.

And yep, if it were me, I'd spend the $50 on the ARC, rather than $1000 on a new TV. Seems more prudent, if that ends up being the only option.
Further to this, I have now noticed when sky is set to Dolby digital sound won't come out of the TV speakers either. It looks to me like it's not possible for this TV to pass through Dolby Digital via HDMI at all. I believe this means an ARC won't help, as 5.1 isn't coming into the TV except for internal services like Netflix etc. Looks like I need a new TV. Only had this one 2 or 3 years.
I bought a new TV and now it works fine.
Glad to hear it's been resolved. Sorry to hear that it required a TV replacement, which may have been expensive.
Hi guys,
This may seem overly simple, and it's not a long term strategy......but I have the same setup and the lip sync was driving me mad.
I have Sky Q going to the TV via HDMI ARC. When I switch everything on the lip sync is terrible.
If I then pull the HDMI cable out of the TV for a few seconds and then plug it back in then the lip sync is sorted.
As I said, this is more of a workaround other than a fix, but would be interested to hear of this improves things for others? Would clearly put the fault with the TV audio pass through to the optical output, and all lip sync settings (Sky Q and Sonos) are set to minimum/none).
Userlevel 7
Badge +17
I think SkyQ is still problematic.
I have had lip syn issues twice when playing recorded stuff and switching back to live tv, then playing recording again sorted things out.