Question

One Sonos product connects to wrong wifi

  • 30 August 2020
  • 4 replies
  • 259 views

Badge

I’m in the process of moving to a new broadband provider and so have two WiFi networks in my house.

3 of my Sonos devices are on the new network (after I changed the Ethernet connection to one of the devices to the new network).  But one stands alone on the old network.  As i couldn’t choose the WiFi network (only the old network was listed in settings network and if I connect an Ethernet cable per support instructions it doesn’t let me change networks) So I reset the device, and with my phone on the new network I added the Sonos.  For one album playing the device was on the new network.  When I went to choose the next album the device (room) had disappeared from the list of rooms and durecenough when I switch my phone back to the old network, the device is connected back there again.

how can I get it to forget the old network and stay on the new one?


4 replies

  1. Wire a Sonos device. 
  2. Get all units showing WM:0 in Settings/System/About. If necessary power cycle or even reset/re-add any recalcitrant devices.
  3. Go to Settings/Network and remove the WiFi details you don’t want.
Userlevel 6
Badge +16

Hi @Tim_40.

Welcome to the Sonos community and thanks for reaching out to us.

I totally agree with @ratty. Just an additional on the instruction provided.

  1. Connect 1 Sonos device to the router via ethernet cable. (ethernet cable first before power) to make sure the device connects via a wired connection.
  2. Once the Sonos device connected to the router have a solid white light, reboot the nearest Sonos device (unplug from power and plug it back after 10-15 seconds). until all Sonso devices are rebooted. This step is necessary to make sure all Sonos devices transition to Sonos Net (Sonos WiFi).
  3. Open the Sonos app and go to Settings » system » network » wireless setup and then follow the prompts.
  4. Once wireless set up is complete, (before unplugging the ethernet cable from the Sonos device connected to the router, go to Settings » system » network » network and remove the unwanted Wifi name listed. 
  5. Once step 4 is done, you can now disconnect the ethernet cable from the Sonos device connected to the router.

I hope we helped.

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Badge

Als this does not work.  I’ve tried it several times and always the same result - some decided connect to the new network (the one one device has an Ethernet connection too) and some “go solo” and connect to the old network.

the only way round this I found is to rename the old network so Sonora destiny have cached credentials to connect to it.  A nuisance in my setup but at least I get Sonos working again.

Userlevel 6
Badge +16

Hi @Tim_40.

Thanks for the update and immediate response. I’m glad that everything is back and working again. I do hope you continue to love and enjoy your Sonos. I would like to recommend contacting our technical support team so they can run some tests and perform more in-depth troubleshooting steps to know what is causing Sonos to fail if you decide not to keep the current running status and want to stick with the changes applied. 

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Reply