Answered

New Battery Saver Mode Not Working?

  • 16 November 2021
  • 14 replies
  • 163 views

Userlevel 5
Badge +9

Anyone else get this to work?  It is part of today’s 13.4 update.   But when I try to toggle battery saver mode to the On setting -- it immediately toggles back to “off” on its own.   I can’t get it to turn on.  Am I doing something wrong -- or is anyone else seeing this? 

I’m using an iPhone X -- latest iOS updates applied.   I have a Roam I’m trying to apply this to.

Here’s what it says to do -- and I’m doing it (trying to):

Enable Battery Saver on portable Sonos products | Sonos

 

icon

Best answer by AjTrek1 17 November 2021, 03:16

View original

14 replies

Have you tried a simple reboot (power off, power back on) of the Roam? 

Userlevel 5
Badge +9

Have you tried a simple reboot (power off, power back on) of the Roam? 

Yep -- no dice.   As a further data point, the app on my iPad displays the same behavior.   So it is not just the app on my iPhone.  

Just double checked on my iPhone 13, running iOS 15.1, and it works properly on my Roam. 

 

So if a reboot of the Roam doesn’t work, it might be worth a reboot of the iPhone, just in case. 

 

Beyond that, I’d suggest a diagnostic submission, and a call to Sonos directly. 

Well, that certainly suggests the issue is on the Roam. Is the Roam your only speaker? Your profile suggests you have other speakers, so I’d also be tempted also to try a factory reset of the Roam itself, and re-adding it to your system.

It’s working fine here - iPad controller (latest S2 App) - two Sonos Roams and the feature switched ‘ON’ and stays ‘ON’ .. I switched the Battery Saving ‘OFF’ on the one Roam and then went to my iPhone XR controller App and enabled it on that device and again it has stayed switched ‘ON’ (screenshot attached taken from iPad App).

Userlevel 5
Badge +9

Well, that certainly suggests the issue is on the Roam. Is the Roam your only speaker? Your profile suggests you have other speakers, so I’d also be tempted also to try a factory reset of the Roam itself, and re-adding it to your system.

I’ll try that.   I have a fair number of other speakers -   4 Ones and a Port.    So I’ll reset only the Roam.

I’d be interested in how that works. With the software just being released today. there’s alway the potential, even though they beta stuff (I think) of it not working. But as both Ken and I have experienced, it is working for us. Which does suggest a local, rather than endemic issue. 

Userlevel 5
Badge +9

I’d be interested in how that works. With the software just being released today. there’s alway the potential, even though they beta stuff (I think) of it not working. But as both Ken and I have experienced, it is working for us. Which does suggest a local, rather than endemic issue. 

Reset worked!   Thanks.   Interestingly, as part of the reset, the Roam went through what looked like a firmware update, then another software update.   Maybe I don’t keep it on enough, and it missed an update, which caused the issue?   

Oh, yes, that’s certainly a possibility. I ran the update this morning from my bedroom, and my Roam was powered down. When I came downstairs, I powered the Roam on, and ran the update again, which then caught the Roam as well. 

That’s actually not something I’d thought about. That the interface would be there before the Roam was updated. Will have to remember that as a potential issue should someone else bring it up. In any case, I’m happy it’s working for you now!

Userlevel 7

@Airgetlam@Ken_Griffiths@caesar327 

I can confirm the issue @caesar327 was experiencing. Just updating the Sonos App (via download) does not auto activate the Battery Saver Mode for Roam and Move. After downloading the App the Battery Saver Mode button would go to “on’ and jump back to “off”. 

The second step appears to be forcing the “check for updates” which will update the Sonos firmware in the hardware. After the firmware is updated the Sonos App (download) on other devices (like my iPad) recognized that the hardware had already been updated and therefore brought back “no update required” when I forced the update check via my iPad. The Battery Saver Button was already turned on.

 

@Airgetlam@Ken_Griffiths@caesar327 

I can confirm the issue @caesar327 was experiencing. Just updating the Sonos App (via download) does not auto activate the Battery Saver Mode for Roam and Move. After downloading the App the Battery Saver Mode button would go to “on’ and jump back to “off”. 

The second step appears to be forcing the “check for updates” which will update the Sonos firmware in the hardware. After the firmware is updated the Sonos App (download) on other devices (like my iPad) recognized that the hardware had already been updated and therefore brought back “no update required” when I forced the update check via my iPad. The Battery Saver Button was already turned on.

Thanks @AjTrek1, so just to clarify was this after you had installed the App software, but before updating the device firmware, or was it after doing both those things? I just had to do the App install and then the firmware install once only and all seemed good, no further prompts for updates after that in my case.

Admittedly, I did not try to switch on the battery saving feature in between the ‘App software update’ and the ‘Device firmware update’, but after doing both those things, it then all worked ok here. I was able to toggle ‘on’ the feature and it stayed ‘on’. I just assumec it needed both the software and firmware fully updated for the new feature(s) to work. 

Userlevel 7

@Ken_Griffiths

@Airgetlam@Ken_Griffiths@caesar327 

I can confirm the issue @caesar327 was experiencing. Just updating the Sonos App (via download) does not auto activate the Battery Saver Mode for Roam and Move. After downloading the App the Battery Saver Mode button would go to “on’ and jump back to “off”. 

The second step appears to be forcing the “check for updates” which will update the Sonos firmware in the hardware. After the firmware is updated the Sonos App (download) on other devices (like my iPad) recognized that the hardware had already been updated and therefore brought back “no update required” when I forced the update check via my iPad. The Battery Saver Button was already turned on.

Thanks @AjTrek1, so just to clarify was this after you had installed the App software, but before updating the device firmware,

Yes. I figured that downloading the App software would have auto triggered the firmware update. Obviously not. I was doing two things at once and just went to check the Battery Saving Feature without forcing the firmware update. I guess the auto update feature (that I like) has spoiled me LOL. Just goes to show that one should never forget the basics.

Next I’m going to check out DTS. I have a few discs that are encoded as such. Alien 40 Anniversary set. 

 

Userlevel 2
Badge +3

Any idea if this actually fixes the self-discharge issue?  I really hope it does.  From my own testing when I first got a Move it was 5-6% a night when supposedly completely off.  Just enabled Power Saver and am taking my Move off the stand and hard powering down at 100% battery.  My Battery is no longer new compared to when I did the test close to a  year and a half ago but lets see if this fixes it.

 

 

Hi there,

This feature is a great usability enhancement however I’ve not left my speaker (Roam) on for 30 minutes to test it out but am sure it does work as described. It just seems like a waste of battery power to leave it idling for that long.  I always turn it off by holding down the power button for 5 seconds, however it always feels like that you have to apply a lot of pressure to turn it off and over time I am concerned that the button will fail to function.

My request would be to be able to actually specify how long in minutes after it is idle that the speaker will go into sleep mode.  I realise that this feature has only been introduced and am not complaining over a clearly improved feature, but at the moment there is no value in me using this.

My use case is like a bunch of others it is a speaker in the bathroom that gets 15 minutes usage every day.

Reply