Cannot play music on Roam

  • 24 December 2021
  • 13 replies
  • 230 views

Just bought a Roam for Christmas.  Connected it to my existing Sonos system but it would not play music from Spotify, Sonos app or bluetooth.  Tried several different iPhones but none would connect.  I eventually got it it to play by a hard reset but if I stop playing and re-start playback the Roam it makes a strange clicking noise and the volume resets to 15 and there is no music played.  Tried resetting again to factory setting and re-did the set up and the then the same thing happened.  Not too impressed with this device compared to all my other Sonos kit. Any suggestions welcome as so far this is a dead speaker in my Sonos system.


13 replies

Userlevel 7

It sounds like you have a defective Roam. Contact Sonos Support:

https://support.sonos.com/s/contact?language=en_US

Thanks!

Same thing is happening to mine - how did the defective process go?

The Roam arrived in the afternoon on Christmas Eve and the Sonos Help  site said they were on holiday. So far the Roam is a dead device unless I keep moving to factory settings and then it only plays a few tracks…...so annoying.  I afraid I need to get my money back…..so sad.  I like my other Sonos kit but this one is a mega dog a device.

M.

Having the exact same issue with a Roam I got yesterday. I’ve factory reset it and connected it to my system maybe a dozen times and it continues to flash orange and white when I play a song. I can slide the volume up, but then it goes right back to 15. It makes a sound for a split second, then nothing. I’ve never had an issue getting setup with a Sonos product like this.

Sadly I have exactly the same issues. The sound resets to 15 and the device makes a quiet electric blip kind of sound instead of playing music. I also get the orange and white flashing lights. The setup is very laboured as the NFC would will not work and the speaker cannot make the required tone to help identify it. I’m returning the Roam after the holidays. Pity as I really like my other Sonos kit. My kids think I should take a replacement device but I’ve lost confidence in the device.  I have an old UE Boom that I was replacing with the Roam. Although a more basic speaker it connects instantly and happily plays music, sadly it’s way better!

I just received mine and am having same issue. Very disappointed especially since I have two play ones a sound bar and a sub now I’m gonna have to change brands which is not what I want to do! Is there a fix?

What did Sonos support say when you contacted them?

They haven’t answered yet

You’re still on the phone with them?

I just received mine and am having same issue. Very disappointed especially since I have two play ones a sound bar and a sub now I’m gonna have to change brands which is not what I want to do! Is there a fix?

 

Why would you conclude you need to change brands?  The Roam has been out for some time now, so this issue is clearly the exception rather than the rule.  If you have a defective unit, then Sonos will surely replace it.  If there’s some other issue, why not at least wait until you’ve talked with Sonos?

Sent a online ticket 

The Roam arrived in the afternoon on Christmas Eve and the Sonos Help  site said they were on holiday. So far the Roam is a dead device unless I keep moving to factory settings and then it only plays a few tracks…...so annoying.  I afraid I need to get my money back…..so sad.  I like my other Sonos kit but this one is a mega dog a device.

M.

Thank you for the response! Good to know it’s not operator-error. I am sad as well, because when it works it sounds great. I will be returning as well. Thank you Sonos community for your feedback!

Reply