Answered

WAP problems

  • 17 July 2021
  • 7 replies
  • 62 views

I have several wired Sonos products + few not wired and a Roam. I have a main router and 2 WAPs - in lounge (netgear) and bedroom (ubiquity). The iOS app does not connect to the Sonos system when wifi connected near the main router but ok when connecting to wifi near 2 WAPs. All 3 use same SSID. Roam struggles to connect back via wifi after it’s been used from Bluetooth or randomly disappears from iOS controller. When this happens, on Spotify connect can see roam but on iOS controller  it’s not there. 

I am not a network expert - suspect it’s something to do with WAPs and DHCP settings. Netgear has option to set up or let router set it - not sure which one to use? Any help appreciated !

icon

Best answer by Ken_Griffiths 17 July 2021, 17:09

Not only do the AP’s need the same SSID/Credentials, but they ideally need to be set to the same WiFi channels too for both bands… If possible, I would set all AP’s, including your router, to use a channel-width of 20MHz just on the 2.4Ghz band aswell. 

I think with the Ubiquity AP, you have to go one step further by enabling ‘multicasting’ on that device - if you search the forum here for ‘iGMP snooping’ you should see the steps for that in some earlier posts from users.

HTH

View original

7 replies

Not only do the AP’s need the same SSID/Credentials, but they ideally need to be set to the same WiFi channels too for both bands… If possible, I would set all AP’s, including your router, to use a channel-width of 20MHz just on the 2.4Ghz band aswell. 

I think with the Ubiquity AP, you have to go one step further by enabling ‘multicasting’ on that device - if you search the forum here for ‘iGMP snooping’ you should see the steps for that in some earlier posts from users.

HTH

Are the two AP’s simple AP’s wired back to the router or are they dumbed down routers? If they are routers, make sure that they are in bridged mode or their DHCP servers are disabled.

Thanks both. Yes they are true APs not dumb routers. Would having router and APs all on the same wifi channel not cause interference?

It’s not interference you’d be worried about (as much), it’s different subnets. Sonos requires all speakers to be on a single subnet so that they can communicate with each other. That’s why the two APs have to be set up in bridge mode. 

Great thanks - changing the channel and DHCP to disabled seems to have done the trick

Which DHCP server have you disabled? Each system needs one and only one DHCP server. If you now have none, the system will gradually collapse over the next hours/days.

In the end I turned the wifi off completely on my Netgear WAP as the router signal was strong enough in the lounge where the Netgear was. I disabled the DHCP on the Netgear but presumably that’s irrelevant with wifi off. The odd thing is that I can still log into the Netgear via my IPhone which shouldn’t be possible I’d the wifi is off? The wifi led is off.

 

The Sonos roam was ok but keeps disappearing in iOS controller - I keep needing to add it back in.

Reply