Answered

Very old Connect performs poorly, cuts out

  • 22 April 2021
  • 2 replies
  • 21 views

My Connect is hardwired into my router, yet is very flaky: it cuts out and takes a long time to start playing after other devices are going strong. It seems to work fine when ungrouped and playing on its own, but this is not a tenable solution. 
 

I am happy to upgrade the device if its age is the problem. 
 

My mesh WiFi is amazing. Is Sonos using its own WiFi network because the Connect is plugged into the router? My 10 Sonos devices are spread out over a considerable space (big house).

 

Please help! Thanks…...

icon

Best answer by Stanley_4 22 April 2021, 04:42

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7

Because the Connect is wired to the router, the Connect is broadcasting a dedicated wireless network (SonosNet) that your other Sonos products are using.

Have you tried disconnecting the Connect from the router and trying a wireless setup? Can you connect any other Sonos speaker directly to the router?

It might be time to upgrade to a Port.

Userlevel 7
Badge +21

Get it to misbehave, submit a diagnostic to Sonos and contact them with the number it provides, here or by phone and let them look at the internals.

You could check to make sure it is in wired mode, WM 0 in the system info and if it is then make sure you have removed the wireless credentials from your system.