Using Roam for ThinkPad speaker

  • 1 September 2021
  • 8 replies
  • 77 views

I recently switched from using a Move for my external laptop speaker to a Roam to save space on my desktop.

The Move always connected seamlessly and automatically with my laptop as the default audio regardless of whether the laptop had gone to sleep or was shut down and restarted. As long as the Move was on and in Bluetooth mode, it connected automatically.

On the other hand, the Roam disconnects every time the laptop goes into standby, so I have to manually re-connect through the Windows 10 settings interface several times a day.

I haven’t found settings I can tweak to fix the issue either in Windows or the Roam….

I’d appreciate any thoughts on solutions to get the Roam to connect automatically via bluetooth as the default speaker just as the Move would. Thanks!


8 replies

Userlevel 7
Badge +17

Hi @phairphair 

Welcome to the Sonos Community!

Once already paired with a device, the best way to reconnect Roam is to use that device’s Bluetooth settings.

Given that the main issue seems to be with Bluetooth being turned off during sleep on your laptop, I recommend you see if you can prevent this from happening. To do this, I presume you would have to go into Window’s Device Manager (right-click what used to be called the Start button, select Device Manager) and change the power settings for the Bluetooth adaptor device so that it does not get turned off (right click Bluetooth device under Network Adaptors and choose Properties, then Power Management). I also presume this would reduce your laptop’s available battery sleep time, though it shouldn’t be by much.

The Move has a Bluetooth mode, unlike the Roam which is always available - this is why there’s a difference in operation between the two.

I hope this helps.

Thanks Corry. I checked the power settings for the Bluetooth adaptor, and that didn’t seem to be the issue. 

After I read your response I paid closer attention to when the Roam disconnects and goes back to WiFi mode, and it’s seems like the Roam itself is just timing out. If it’s not receiving a signal for a certain amount of time (Zoom call, music streaming, etc) it’s switching away from Bluetooth mode.

is this an intended function of the device, and can it be changed? I didn’t see a way to do this. If it’s hard-coded I’d say this pretty dramatically reduces it’s functionality as an external laptop speaker. I have to think this would be a popular use for the speaker given how common WFH is now….

Userlevel 7
Badge +17

Hi @phairphair 

Not that I am aware of, though it is possible. More likely, the Roam might be going to sleep - try keeping it on charge while using it as a laptop speaker. Does the Roam maintain/reconnect the Bluetooth connection after the laptop wakes up when the Roam is on charge?

So, I used the Roam as my laptop speaker for a few more weeks, always plugged into the charger, and watched how it behaves. What’s happening is that it times-out after about 20 minutes of not receiving active output from my laptop’s bluetooth and switches back to wifi mode.

The effect of this is that the next Zoom or Teams meeting I sign into delivers the audio through my laptop speakers. Should be easy enough to switch back to Bluetooth in theory, but it’s very clunky in practice.

I need to open my laptop settings, bluetooth, and select the Roam speaker. Once it connects I’ll get no audio at all for about another 20 seconds or so. Sometime, randomly, it will never deliver audio so I need to switch back to laptop audio since I can’t troubleshoot in the middle of a call. So bottom line is it’s a pain in the a** to use as a desktop speaker.

I think this is a miss on Sonos’ part. it would be good to see a firmware update that would allow it to be used primarily as a desktop speaker and then easily unplugged to go mobile and travel as needed. I have to imagine that with so many remote workers that this will be a common intended use.

Userlevel 7
Badge +17

Hi @phairphair 

It sounds like the Roam is attempting to save power by ending a connection that’s been unused for 20 minutes. Considering your usage case, this is obviously annoying. Considering our intended use for the Bluetooth functionality of the speaker - which is not for it to be used as a PC speaker, but as a speaker to listen to music with from a phone - this is a sensible action to take to preserve battery life.

To be honest with you, I doubt this will change. If we get a lot of feedback that mirrors yours, however, I’m sure we’ll take steps. Having said that, we are still working out some Bluetooth connectivity issues and things may change for you soon, hopefully in a beneficial way.

Hi,
I just bought the roam last weekend and are currently experiencing the same problem with loosing the bluetooth connection to my Windows 10 PC after a certain time of inactivity. I also bought this speaker for using it as a notebook speaker in my home office for teams calls and from time to time for playing music in other rooms.

I really would appreciate a solution or feasible workaround for this. Otherwise I might return the speaker.
Best regards
 

Hi @phairphair ,

I found for me a workaround to maintain the bluetooth connection for the roam.

The basic idea is, that I need to put a sound to the speaker at least every 15 minutes in order to avoid to loose the bluetooth connection from the roam.

I used the following instructions to automatically play a small, almost silent mp3 sound file every 15 minutes. This maintains the bluetooth connection all day even if the lock screen is running for 2 hours.

How To Play a Sound Every Few Minutes on Windows 10

I would prefer a SONOS solution for the roam. But as long as this is not available this solution works for me.

Best regards

 

@Schmuttergold - great creative solution! Thanks very much for sharing.

 

Reply