Troubleshooting Sonos on WiFi

Troubleshooting Sonos on WiFi
Userlevel 7
Badge +17

Hi Folks, 

I’ll share some general advice about how Sonos products connect to your network, and the kind of network problems that can result in dropping rooms, to help you understand and solve some challenges with your Sonos system.


5GHz band

Most older Sonos devices will only connect to the 2.4GHz band, whereas some newer ones will connect to the 5GHz band broadcasted from your router. A full list of which devices will connect to 5GHz can be found here on our Sonos system requirements page, under “Products that support 802.11a/b/g/n”.

It’s important to note that all (apart from early Connect, Connect:Amp or ZP models) Sonos products have 5GHz radios, but typically reserve them for talking to each other. Home Theatre products will not connect to 5GHz, as the 5GHz radio is often busy with talking to two surrounds and a Sub. Sonos prefers to use 2.4GHz as it fundamentally has a better range and a stronger solid-matter penetration ability (it gets through walls, ceilings and furniture easier).

The problems arise when a router mistakenly identifies a Sonos product as one willing to connect to 5GHz, when it isn’t. A router feature called ‘band steering’ tries to get your Sonos speaker to connect to 5GHz as that band is typically subject to less congestion from for instance mobile phones, tablets, laptops, baby alarms, temperature controllers etc. Separating your 2.4 and 5GHz bands so they have different WiFi network names resolves this, if it’s an option (mesh systems generally don’t allow this). If in doubt, get in touch with our technical support team.


Mesh Networks

If you have a mesh WiFi system to extend the range of your WiFi, and your original router is still present, you must either:

  • Configure your router to act as a modem only. Some have a specific option for this (like Virgin Media in the UK), but on most router’s you’d need to disable the DHCP server. If you still need to use the WiFi coming from your router, or if you connect devices via ethernet to it, this is not an option. Doing this will allow you to use the usually more advanced routing features on your mesh (as compared to those on a free, ISP-provided router).

  • Configure your mesh system to be in ‘Bridge/AP mode’ - otherwise it acts as a router and you now have two logical networks running on one hardware layer (this is commonly referred to as Dual DHCP). To find out how to do this, perform an internet search for “[name of your mesh system] mesh bridge mode”. I’ve listed a few common ones here:


Netgear Orbi mesh: https://kb.netgear.com/31218/How-do-I-configure-my-Orbi-router-to-act-as-an-access-point

Linksys Velop mesh: https://www.linksys.com/us/support-article?articleNum=243548

Tenda mesh: https://www.tendacn.com/faq/3123.html

Eero mesh: https://support.eero.com/hc/en-us/articles/208276903-How-do-I-bridge-my-eeros-

Google mesh: https://support.google.com/wifi/answer/6240987

In my experience Google meshes can be difficult about going into Bridge mode. Please contact Google if you have trouble with this. If you’re thinking of buying a mesh system, I personally advise avoiding Google Mesh for this reason.


Extenders / Boosters / Powerline adapters / Sky Q

Another challenge, with networking and Sonos, is WiFi boosters and extenders. Sonos does not support these as they halve your available bandwidth (due to being half-duplex) and often block multicast transmissions which gets in the way of the Sonos system from operating smoothly. 

Powerline line adaptors can also induce additional issues as they are subject to noise present on your mains power supply (‘noise’ is created by some LED dimmers, for example).

In the UK, Sky Q boxes can be a challenge with Sonos, as they repeat the WiFi from a Sky router (not from other routers). If a speaker connects to one of these (common with Sonos Home Theatre products) it can result in the speaker being missing from the Sonos app. To get the speaker to show in the Sonos app, you need to disable the 2.4 GHz broadcast of WiFi from the Sky Q box(es). You can go into the Sky Q’s engineer’s menu (highlight Settings, press 0,0,1, then select Settings), go to Network and toggle 2.4 GHz wireless to OFF then click Confirm. If you do this make sure you leave the 5 GHz on so that the boxes can connect to each other. As with above (in 5 GHz section), you’ll need to split the bands to differently named WiFis in the router’s settings. If you have Sonos devices that are willing to use 5GHz (see above, under 5GHz band), you may not be able to bypass this issue without using SonosNet.


Sonos and Ethernet

To bypass most WiFi configuration issues, you can connect any one (or more) Sonos devices to the network with an ethernet cable (Sonos Move & Roam excluded). Wired Sonos products will transmit a ‘Sonos only WiFi’ for use by your other Sonos devices (Sonos Move & Roam excluded). This all happens automatically, but sometimes your speakers need a power cycle (unplug them from the wall socket, and plug them back in again after 30 seconds) to help them along. Wiring Sonos will not resolve anything if you have two routers on your network (as described in the Meshes section). Each Sonos player that picks up the ‘Sonos only WiFi’ from the wired Sonos speaker will rebroadcast it, thus extending the range for speakers out of range of the wired one(s). 

When you wire a Sonos product, you go from a configuration like this:

Sonos using your WiFi​​​​

to one like this:

Sonos using Sonosnet


WiFi Noise / WiFi interference

Sometimes it’s just not a network configuration issue. All WiFi devices (not just Sonos) like to have at least 1 meter / 3 feet of space from all other WiFi devices (and devices that are not on your WiFi but may use similar frequencies). In my experience, one of the most common solutions to a ‘WiFi problem’ has been to physically move a speaker/Boost/Bridge farther away from the router it’s wired to. A common misconception is that the closer the device is to the WiFi broadcasting unit the better - this is not the case. Sometimes a speaker lived very close the router but wasn’t wired - these devices were often kept centimetres apart from each other. We have a helpful guide on reducing wireless interference. Close by glass or metal surfaces can reflect WiFi back at a device and also create interference. 

Interference is, I would say, the biggest cause of problems, like dropped rooms, or music interruptions, for Sonos users.



It may be that you cannot connect to Sonos not because your Sonos system is having trouble connecting to the network, but because the device you’re running the Sonos app on is unable to communicate with the System (or parts of it).

Although this can be caused by a few things, the most likely are the following:

  • Multiple Access Points - WiFi boosters and Extenders tend not to work very well. Often, you can only connect to rooms that also connect to the same extender your phone is on, or can’t connect to them because your phone is on the main router’s WiFi. We don’t support the use of these products for the reason. Mesh systems are not affected by this. In the UK, Sky Q boxes repeat WiFi from Sky routers in this way.
  • Guest WiFi - You cannot run Sonos on a Guest WiFi, nor can the Sonos app connect to a Sonos system if the controller is connected to a Guest WiFi.
  • On iOS devices - make sure you give the Sonos app permission to access devices on the Local Network. https://support.sonos.com/s/article/3092
  • On iOS devices - make to to disable Private Address in the iOS connection options for your WiFi network.



Sometimes, no matter how much you know, the speakers themselves have to be ‘consulted’ as to what is wrong before you will find a resolution. In such situations, the only solution is to get in touch with our technical support team who can receive your Sonos system diagnostics which will tell the agent all about what your system has experienced. If you’re going to call/chat with our tech agents, please try to recreate the issue you are experiencing just before getting in touch, if you can, and try not to reboot any players - reboots clear the system logs and as a result the diagnostics contain less information. 


I hope this helps you to understand a bit of what’s going on when no steps taken seem to be working for you. As always, we’re more than happy to assist with getting your Sonos system stable, so please either get in touch with our tech support if nothing works, or write here on the community if you need more guidance.



Edit: Updated to include additional mesh options, Roam and some other details.

Edit: Updated to include iPhone Local Network and Private Addresses options as they can affect connecting to Sonos

18 replies

What about IP address conflicts? Another common cause of problems, that is easily resolved with address reservation.

Userlevel 5
Badge +9

Any chance of the option to use the 5ghz band for Sonosnet - might be able to play Flacs again without running out of bandwidth? 2.4ghz band hopeless in my urban area.

Userlevel 7
Badge +17

 @Kumar - A fair point, but not once in 2 years of technical support did I need to reserve IP addresses for Sonos devices to resolve problems. If your DHCP is in order, it’s not necessary. If your DHCP is not in order, as in if you have Dual DHCP/NAT, it probably wouldn’t help anyway.

A regular router reboot is likely to clear these issues up, and others - I recommend 6 times a year for cheaper, ISP provided routers. As I like to say, you’d know about it if you paid for a router that doesn’t need regular reboots.

To be honest, I’m a little puzzled over the current proclivity of community members to suggest static IP reservation. If it works, it works, but I never found a need. I actually have static IPs on my home network (for pihole, PC (back when I used VNC) and NAS), but not for Sonos or phones/tablets.

Thanks for this Corey.  Good information.


Regarding mesh routers, I have an Orbi and I think I have it in a slightly different setup than you’re recommending.  My modem router has the WiFi turned off, and I think al DHCP functions are turned off.  It’s then wired to the Orbi base, with WiFi and DHCP functions turned on.  I am using Sonosnet, so it likely isn’t an issue either way, but curious if this is an acceptable setup for those who aren’t using Sonosnet.


Too be clear, I have not looked at the modem/router settings in years and not 100% DHCP is turned off or if that’s even possible.  In fact, I am having issues with remote access to plex, not really related to Sonos, that hints that a double NAT might be the problem.  Probably need to dig into my settings for both devices and see what’s going on.


The simple fact is that whole ‘process’ used to reset duplicate IP addresses covers quite a few other potential issues as well. While the chances of duplicate IP addresses can be low, going through those actions indicated in many of my posts can assist many, many users, without needing access to diagnostics, or a lengthy back and forth to pinpoint exactly where their issue lies. 

Your argument seems to be ‘I’ve never had or seen an accident, so wearing a safety belt doesn’t make sense’, which seems odd to me. As long as the customer resolves whatever issue was plaguing their LAN, whether or not it actually was a duplicate IP address or not is moot.

And duplicate IPs have happened...at least on my system, years ago before I set up reserved IP addresses. Perhaps newer routers have better firmware than what I used to use, so the chances of duplicate IPs are reduced, but I will continue to offer that as a potential solution, as long as the occasional poster comes back with a ‘that resolved it, thanks!’.


Userlevel 7
Badge +21

I’ve spent a lot of time chasing system instabilities with my Sonos, starting back in 2006. Several different routers, the last one commercial grade. Different switches too. No matter the connection, router WiFi, AP WiFi, wired speaker and with a Boost and I was never able to get my setup to just work. Issues when powering individual units down and back up, Issues after power failures and the worst issues after updates.

Much DHCP v4 log reading on the last router never showed a duplicate v4 IP being issued and nothing in any of the logs showed a problem or conflict. Older lower end routers had no meaningful logging to look at. Still I had the issues and as I added Sonos gear they got worse.

Giving up on finding the issue, due to spousal input, I gave in to the suggestions here to assign static/reserved DHCP v4 IP addresses. After a system-wide reboot I have never had an issue again. Very frustrating to not be able to see why the v4 IP reservation made a difference but the result convinced me that something beyond my abilities to find was wrong.

I started recommending it to others years ago and have had several folks report back that it solved their issues too. Since it is just a couple minute task, and has no downside I see no reason not to keep recommending it.


I have seen no similar issues with IP v6 and apparently my Sonos gear is not using my DHCP_6 server to obtain addresses. It happily survives v6 PD changes with no problems too.


I realise that this is just one data point, but in my case Sonos uptime showed a marked improvement  (Apple Time Capsule as a router) after IP address reservation. On S1 now, so I don’t see frequent upgrades, thank heavens, but as I recall IP address reservation helped in making frequent upgrades in the past a pain free process.

Userlevel 7
Badge +17

Like I said, if it works it works - I have no problem with you guys suggesting to reserve IP addresses, especially if it works. It’s just that I never found the need, so I left it out of the article (or should say it’s not part of my standard “toolkit" so I didn’t really think of it).

Regarding mesh routers, I have an Orbi and I think I have it in a slightly different setup than you’re recommending.  My modem router has the WiFi turned off, and I think al DHCP functions are turned off.  It’s then wired to the Orbi base, with WiFi and DHCP functions turned on.  I am using Sonosnet, so it likely isn’t an issue either way, but curious if this is an acceptable setup for those who aren’t using Sonosnet.

Absolutely. Sometimes routers are just terrible at what they do, and if you’re stuck with it (need it to get online with your ISP) disabling WiFi and DHCP and getting another device (like a mesh) to do the job instead is the best option. For the average user, however, it’s easier (and safer?) to put the mesh into Bridge mode. 

Having Dual DHCP/NAT is a huge problem whether you’re on Sonosnet or not, and Sonosnet won’t protect you from the effects (though it may mitigate some).

Just to be clear:

  • Dual DHCP -- on the same subnet -- of course creates mayhem.
  • Double NAT per se is not a problem in the slightest, so long as the user recognises there are two subnets and acts accordingly. 

Sometimes users want the mesh routers’ security or parental control features, so may have no alternative but to double-NAT. In the case of Google’s WiFi mesh it has to run in router mode.


I have a Eero mesh network and have tried the troubleshooting steps above, putting the mesh network into bridge mode but my living room setup (beam, sub and 2x one SL) still disappears from the sonos app everyday! At least once A day I have to search for missing products or update the network on my living room surround setup so that it returns to the app. 
This has been ongoing for about a month now, nothing has changed on my network. As a worst case scenario, yesterday I factory restored the whole living room and still the living room disappears from my app. 

please help!!

Userlevel 7
Badge +17

Hi @AJL10 

I see you’ve got a thread on the subject:

We’ll assist you there.

I use UniFi®️ AP AC LR Access Points for my meshed network although most of my SONOS gear (six ONEs and one Port) are wired connected and wifi disabled. The remaining ONEs, Play5 and two Symfonisk devices are (5GHz) wifi connected. The connections are stable and we switch several times a day from radio stations between the different rooms. The only issues we have is when we start using Airplay and devices disappear or do not sync. Any suggestions?

Userlevel 7
Badge +17

Hi @el rubio 

With a UniFi system in place, you can try the following:

  • Log into the UniFi controller.
  • In the Settings tab, click Wireless Networks.
  • Click Edit next to the network SSID.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.

Please also enable IGMP Snooping (which is in the Networks settings page).

I hope this helps.

thanks @Corry P I wiil have a look at the settings and observe the impact


hi @Corry P my UniFi system was configured with your suggested settings, except for the IGMP Snooping since that needs an UniFi switch. However, I have now ‘Point to Point‘ and ‘P2P Cross Connect’ enabled in the wireless network settings and my perception is that this has improved the behaviour of the SONOS devices.

Userlevel 7
Badge +17

Hi @el rubio 

Good to hear, and thanks for sharing!

This, for me, is one of the most helpful posts/threads, on this particular topic, that I’ve seen in the community in quite a while. Great stuff @Corry P. Thanks for the time & effort in researching and pulling all this information together. It explains everything in ‘easy to follow’ terms and is very much appreciated.👍

I will certainly be referring users in the community with such WiFi mesh systems and devices, that are encountering any related Sonos issues, to read through this entire thread and to take onboard the considered advice suggested here.



Userlevel 7
Badge +17

Thanks @Ken_Griffiths 

I’m glad you find it helpful!