Symfonisk Not Connecting to Wi-Fi

  • 22 June 2022
  • 9 replies

Hi folks,


After 3 hours of battling and troubleshooting, I felt I had to come here and seek advice! 😀


I have a Sonos Beam Gen. 2 for my TV, and I just bought 2x Sonos Symfonisk Bookshelf speakers to use as surround sound speakers. However, I have spent 3 hours trying to get them to connect and register on my's what happens:

- The Sonos app recognises the speaker when it's first turned on, or if I factory reset it

- I connect to the speaker, and scan my phone as indicated, which works fine

- After connecting to the speaker, the app then tells me that it's connecting the speaker to my WiFi network. This process takes at least 3-4 minutes (which already seems suspicious), but eventually says that's it's successfully, but I may need to remove the power and reconnect it before it shows up in the "system" tab.

- No matter what I try, the Symfonisk's never ever show up in the Sonos app after I install them!


And here's what I've tried so far:


- Unplugged each speaker and plugged them back in

- Factory reset each speaker (many times)

- Removed my network from the Sonos app, re-added it and re-registered all devices (the Beam reconnected with no issues, the Symfonisk's were not recognised)

- Unplugged and restarted the router

- Connected the Symfonisk's with Ethernet. With this they were registered and connected, but disappeared as soon as I removed the ethernet cable

.... and most of the above multiple times in different orders! My router is set up with WEP2 encryption, not enterprise! 


What am I missing, I'm tearing my hair out 😀. 

Thanks for any help,

Cheers, Ori




Best answer by Orias 23 June 2022, 10:13

View original

9 replies

Userlevel 7
Badge +22

What WiFi router are you using? Anything unusual about your network topology?

Can I just check?  Your Beam gen 2 is connected to your WiFi so the network credentials are already in Sonos?  And you have tried adding the Symfonisks by going to ‘add product’ in the system settings?


What WiFi router are you using? Anything unusual about your network topology?

Just a plain old Orange Livebox. I’m in Spain (but from the UK) using an Orange Livebox with 1GB fibre line. No extenders, meshes or anything else fancy!

Can I just check?  Your Beam gen 2 is connected to your WiFi so the network credentials are already in Sonos?  And you have tried adding the Symfonisks by going to ‘add product’ in the system settings?


Exactly! The Beam 2 connects without any problems at all. I’ve had that for 6+ months, using the Sonos app with it, and it connects to the WiFi without issues. I totally removed it, and reset the whole network connection on the Sonos app earlier today. The Beam 2 reconnected without any problems at all, the Symfoniks kept saying they had connected, but never actually show up in the app! If I go to “add product” in the system settings, it just sits on the “Looking for devices” screen for 5+ minutes, but fails to find anything. This is after the initial setup where the app tells me that the speakers have been “successfully added”, but they never appear in the “system” tab.

Thanks for the replies so far!!

This is odd and I think you could easily spend more hours on it without finding a solution.  It may be best just to call Sonos Support so that they can take a look.  Which router are you using?  Do you have a mesh system or extenders, or just a single router?  There may be a setting in your router that is stopping Sonos from acting as a multi-device system, such as having client isolation enabled.

If it is practically possible, one thing you might try, as a troubleshooting experiment, is to wire the Beam by Ethernet to the router, then try to add the Symfonisks wirelessly.  

Well, I have made a little progress this morning, but first, to answer your questions:

  • My Router is an Orange Livebox 6 Fibre Router. Standard issue in Madrid for Orange Fibre
  • Just a single router, no mesh, extenders or anything like that
  • I did previously try adding them using an Ethernet cable. That worked, but as soon as I enable WiFi and disconnect the Ethernet cable, they just disappear from the Sonos app

However, this morning I have been messing around in the router, as I am 100% sure that this is where the problem lies. There is a setting called Smart WiFi which basically just means the WiFi outputs 1 x SSID and devices automatically decide if they want to connect to 2.4 or 5ghz bands. I figured that the Symfonisk’s were getting confused, or the Router was trying to get them to connect to 5ghz, which won’t work.

I disabled the Smart WiFi option, and made the router broadcast separate 2.4 and 5ghz SSID’s. I then reconnected my phone, the Sonos app and one of the speakers to the dedicated 2.4ghz channel, and after some fiddling, the speaker showed up in the app for the first time ever on WiFi. So it looks like I have to change my entire WiFi setup to broadcast separate SSID’s for each band, and then connect the speakers directly to the 2.4ghz band! Which is actually really annoying as it means reconnecting every device I have to new networks, so I’m still looking to find a way to force the speakers to connect to 2.4ghz and ignore whatever the Smart WiFi function is trying to do (as it works fine on every other device that I have, even other ones that only 2.4ghz!)


That makes sense. The difference with Sonos is there are multiple devices that need to talk to one another and to your phone

I don't understand why you need to change everything else

Can you leave the 2.4GHz SSID as the previous common name, and just add a suffix to the 5GHz band. Make sure phone only has the 2.4GHz SSID. Then you would only need to change the details on devices you specifically want on 5GHz.

Hey John,

Yeah, I guess that’s the easiest way to do it. Most of my devices actually seem to use 5Ghz, my PC for example only gets about 80mb/s on 2.4ghz, but get’s 600mb/s on 5Ghz etc etc. 

I just connected both of the Symfonisk’s via ethernet, they show up fine, and I added them as surrounds to the Beam 2, and it all works perfectly and sounds great. So the other option is just to leave them hard-wired, which isn’t a huge inconvenience in the space that I have. But I’ll mess about with the WiFi first, just to see how I get on.

Thanks for all of the help!

It's not a good idea to have only the surrounds wired. I suspect it would be fine if you wired the Beam and then unwired the surrounds.  That might work even with the single combined SSID. 

Yeah, I did want to give that a go, but unfortunately the Beam is situated very inconveniently for a cable connection, although I may just take it over to the router to at least test the theory.

The other thing I tried was to enable the 2.4ghz channel, name it exactly the same as the Smart WiFi SSID with the same password etc etc, and then get all the Symfonisk’s connected up to that. Then, once they were all connected, switch it back to Smart WiFi with all of the same SSID and Password, and just hope that somehow the Symfonisk’s retain their connection to the 2.4ghz channel …..

…. unfortunately, that didn’t work. As soon as I switched back to Smart WiFi, the Symfonisk’s disappeared from the Sonos app again!