Question

Sub (Gen 2) stopped working, shows flashing red light

  • 16 January 2021
  • 1 reply
  • 36 views

My sub was working fine (as part of a room along with an Arc and a Connect:Amp for the rears) but then it started showing a flashing red light. I therefore removed it from my system (or maybe it removed itself) and tried to add it back.

When I try to add it back the setup goes fine initially but fails at the finalizing connection stage with the error “There was a problem setting up your sub” . I have retired this several times even connecting it using ethernet to my router (a google WIFI puck) but to no avail.

 

I have also tried doing a factory reset on the sub but it doesn’t seem to work as it goes straight to flashing red after the flashing white start-up light despite me holding down the join button. 

Can anyone suggest how I should proceed to get it back working again?


1 reply

The LED status light information is shown HERE.

From your description it sounds like a possible hardware issue - but I would perhaps just contact Sonos Support direct via this LINK and see what they say. 
 

 

Reply