streaming and existing Sonos setup becomes unresponsive after sound swap with roam

  • 26 April 2021
  • 5 replies
  • 61 views

Userlevel 3
Badge +1

i have a sonos roam and an existing surround setup with Arc+2 sonos ones.

 

i try the swap feature which seems really good. however i struggle with switching from “swap” to “group”.

either way after using or attempting to use the swap/group feature my existing sonos setup becomes almost useless. Sonos is unable to handle any music commands from alexa. Alexa takes the command but i get a “device is offline” from alexa, or alexa accepts the commands but doesn’t do anything. and if i play the music manually, alexa is still unable to pause skip track change volume etc.

 

everytime i play with the swap feature everything gets messed up.

 

anyone having similar issues?


5 replies

Userlevel 5
Badge +14

Hi @Reefy, thanks for sharing this with the Sonos Community!

Not something that I’ve come across myself - are there any steps that you usually take to get things working again? If so, what gets Alexa back in control?

It may be worth resetting the Sonos Skill within the Alexa app (More > Skills & Games > Sonos > Disable Skill > Enable to Use)

If this doesn’t help, then it could be due to how the network is set up - mind sharing the make/model of router, as well as if there are any wireless extenders, access points, or network switches involved?

Userlevel 3
Badge +1

Hi @Reefy, thanks for sharing this with the Sonos Community!

Not something that I’ve come across myself - are there any steps that you usually take to get things working again? If so, what gets Alexa back in control?

It may be worth resetting the Sonos Skill within the Alexa app (More > Skills & Games > Sonos > Disable Skill > Enable to Use)

If this doesn’t help, then it could be due to how the network is set up - mind sharing the make/model of router, as well as if there are any wireless extenders, access points, or network switches involved?

Hi @Xander P 

the only thing that gets it back working again is to unplug the power from the Arc. Disabling  Alexa and re-enabling  doesn’t fix It. Because Alexa still responds basic commands such as weather. But unable to control music. 
 

im using an old Apple time capsule as my router. No switches or extenders involved. 

Userlevel 5
Badge +14

Understood, thanks for that @Reefy

Is the Apple Time Capsule connected directly to a Modem, or does it connect to a different router? Would it be possible to submit a quick diagnostic after experiencing the issue, but before rebooting the Arc?

If you note the confirmation number in your reply I’ll be happy to take a quick look :)

Userlevel 3
Badge +1

Understood, thanks for that @Reefy

Is the Apple Time Capsule connected directly to a Modem, or does it connect to a different router? Would it be possible to submit a quick diagnostic after experiencing the issue, but before rebooting the Arc?

If you note the confirmation number in your reply I’ll be happy to take a quick look :)

Hi @Xander P 

the issue is happening again. Diagnostic number 249069377  

right now the arc is telling me that Alexa skill is bit enabled  but it is

alexa was working fine before I started playing with the swap/group feature. Which by the way I was not able to group my roam with the rest of the Sonos.

 

 

Userlevel 5
Badge +14

Thanks for that @Reefy, looks like the Time Capsule itself is acting as an extender/access point.

Would it be possible to test connected to the main router, rather than via the Time Capsule?

As I noticed the main router is using a different wireless SSID, you’ll first need to add that network to the Sonos settings - you can do this by going to Settings > System > Network > Manage Networks > Update Networks.

Once that’s done, if you disconnect the Ethernet cable from the Arc, and power off the Time Capsule, both the Arc and Roam should connect to the main routers WiFi.

Once connected, I’d recommend disabling and then re-enabling the Sonos Skill in the Alexa App (More > Skills & Games > Sonos > Disable Skill > Enable to Use)

Let us know how you get on in this setup :)

Reply