sonos was unable to add music folder authorization failed mac

  • 6 April 2021
  • 1 reply
  • 18 views

Hey found the fix to this issue and wanted to share it here.

First enable Sonos from System Preferences, Security & Privacy, Privacy, Accessibility (check Sonos)

Turn the Firewall off.
Route: System Preferences, Security & Privacy, Firewall (turn it off if it’s on)

Uncheck File sharing

Route: System Preferences, Sharing, uncheck File Sharing if it is checked.

Then, if Sonos is installed, uninstall it from within the app.

Route: Click on Sonos, Uninstall 

then install the newest version from Sonos website and try adding your Music Library

Sonos, Preferences, Music Library, click on +, Another folder or a drive connected to my computer,

search the location, Next, Add admin pass and voilà.

 

Spent like the whole day following articles and googling until this method worked. Now I am listening to my iTunes music.

 

Cheers

Jaime

 

 


1 reply

Userlevel 6
Badge +14

Hi Jaime,

 

Thanks for sharing your solution! Hopefully it helps someone out in a similar situation :slight_smile:

 

As a brief technical explanation as to why your method worked, Sonos has 2 ways of establishing a connection with your music folder; HTTPS and SMB. By disabling File Sharing under System preferences you’re basically forcing the system to use the HTTPS method over the older, less reliable SMB connection. HTTPS is always the preferred method for establishing a music library share, but we do fall back to SMB if there are any issues with HTTPS. Toggling that option off means that the system has no choice but to attempt to use HTTPS and sometimes that’s all the system needs to get going :smile:

Reply