Answered

SOnos systems feels it's falling apart - random drop out, can't group speakers....

  • 20 January 2022
  • 14 replies
  • 141 views

Userlevel 2
Badge +1

It’s as if my Sonos system has got a cold or something.

it’s been working fine for some time; Sonos Boost hardwired to router, about 65Mbps internet speed, Sonos devices (mostly Play:1) in the same places in the house.

Now we are getting:

  • Random drop outs on speakers - just stops playing for a few seconds then continues. 
  • Grouping speakers sometimes results in one of the speakers not playing; when I take it out of the group it plays as a single speaker, then back into the group and it’s OK.
  • Some mornings the alarm (radio) doesn’t start or stops far too soon.

I’ve changed the Sonos channel (speaker next to me stopped as I type this….and restarted after about 10 seconds) from 11 to 6 (although 11 looks the least busy according to a WiFi app on my phone).

I’ve re-booted the router (completely turned it off) but with WeMo and Hive I don’t want to keep doing this or else they get upset.

I use the S1 app as I’ve got a couple of ZP80’s on the network. I often use Alexa to start / stop speakers although that is increasingly fraught as well.

Any ideas? 

Thanks,

icon

Best answer by UKTreoFan 23 January 2022, 12:13

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

Userlevel 7

Have you tried unplugging your speakers from power for a couple of minutes before you reboot your router?

Classic symptoms of IP conflicts.  Reboot router, then reboot Sonos and controller devices.  Setting reserved IP addresses in the router settings will cure it for good.

Userlevel 2
Badge +1

@GuitarSuperstar no, not thought of that but @jgatie has an idea. Not sure how I can get IP conflicts as it’s DHCP from the router but Ok, I’ll try the suggestion except not a fan of reserved IP addresses so will just reboot the router and then the Sonos devices (which is in effect the same as @GuitarSuperstar suggests).

Many thanks, I’ll update once I’ve done this, probably ‘tomorrow’. 

@GuitarSuperstar no, not thought of that but @jgatie has an idea. Not sure how I can get IP conflicts as it’s DHCP from the router but Ok, I’ll try the suggestion except not a fan of reserved IP addresses so will just reboot the router and then the Sonos devices (which is in effect the same as @GuitarSuperstar suggests).

Many thanks, I’ll update once I’ve done this, probably ‘tomorrow’. 

 

IP conflicts result when you reboot a router. The router’s IP table is lost on reboot, and the router starts handing out IP addresses that are already in use.  Unfortunately, most things don’t care about conflicts, but Sonos is so interactive they can wreak havoc.  It’s especially true after a Sonos update because each device is rebooted and requests an IP.  Rebooting the router can be a quick fix, but as soon as an IP lease is up, it starts all over again.

Reserving IP addresses cures it for good because no other device will ever get the reserved IP. 

When a router is reset there is no general notice sent out, forcing the clients to renew their IP address. Clients wired directly to the router might take the hint (if power to the network ports is interrupted) and renew, but wireless clients will not know that there has been a reboot. Some routers use a hashing scheme to generate IP addresses and often generate the same IP address without reservations, but the hash table is so small that one cannot depend on this to prevent duplicates. In my opinion reservations are the best defense. I reserve all regular clients, there is no point reserving an address for an occasional visitor.

Userlevel 7
Badge +21

I reserve addresses for all my Sonos, stops the address related glitches that drove me nuts.

I also reserve addresses and assign DNS names for my local servers and printers. Having them at a constant name and IP address makes connecting to them much less frustrating.

Consider something as simple as looking at your internal Sonos web server. I simply bookmark 

http://172.16.1.115:1400/support/review as SonosBM-64-CR Network Matrix  

so I can click and go. Much more hassle to open the router’s DHCP page, search for the Sonos’ MAC address and then the assigned IP address, then type all that link into the browser.

Userlevel 2
Badge +1

Thanks all for the information.

I turned off all the Sonos speakers (well bar a ZP80 in the Garage I couldn’t be bothered to go out to), re-booted the router and then re-started the Sonos devices one by one.

Broadly things seem a bit better but still had a speaker randomly stop (no sound) when part of a group today. So it’s better but not resolved.

I also get issues connecting the speakers to radio stations, specifically on TuneIn. I get ‘cannot connect to service (I think that’s the error message) and ‘Unable to play radio station’ which it then happily plays after poking stop/start on the app a few times.

I note the comments about reserving IP addresses…..

So, if you didn’t do one speaker, it’s entirely possible that it is the source/cause of the duplicate IP address. Unfortunately that process really is a ‘all or nothing’ process. 

That being said, you may be being plagued by more that one issue, since your TuneIn issue sounds much more like some potential wifi interference . Worth reading through the linked FAQ, and applying what remedies may apply. 

At the end of the day, you might benefit from submitting a system diagnostic within 10 minutes of experiencing this problem, and calling Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

 

UKTrioFan,

If there is a duplicate IP address, rebooting this or that can be similar to a hand full of marbles plus one situation. You can push that extra marble back into the pack, but eventually a marble will pop out. You must force all of the units to fetch a new IP address -- even units that might currently be inactive.

Yes, savvy network geeks may know different ways of dealing with duplicate IP addresses, but this is not your skillset and acquiring the skillset will require more time and effort than simply powering down and restarting everything on a small network, even if it’s annoying to walk to the garage.

Userlevel 2
Badge +1

Thanks @Airgetlam I also think there is more than one issue going on at the moment. 

I had considered WiFi interference and indeed have a DECT phone on my desk next to my Sonos One speaker…..but they have both been here for some 2 years in the same place without issues up to now. And in the house I have every device type listed apart from the baby monitor. So for example my Sonos Beam is, unsurprisingly, directly in front of the TV that in turn connects to the internet via WiFi. Thus I cannot really move them further apart without the sound from the Beam becoming too ‘detached’ from the TV (if you see what I mean).

I also note @buzz comments regarding not rebooting one device; that particular device is currently turned off.

What I have done is to reconfigure my connections to the router. I have all hardwired devices (ahem: Netgear Arlo hub, Hive Hub, NAS, UPS…..) connected via a (unsmart) hub. But I’ve realised that all the ports on the back of my BT SmartHub2 router are Gigabit so I’ve connected the Boost directly into one of the router ports and not via the separate hub. The Sonos speakers seem much more responsive at the moment, by which I mean something happens as soon as I do something on the app / desktop app rather then there being a delay. So perhaps this, along with all the rebooting, has helped?

Thanks again for all the suggestions, appreciated. I’ll update again after a day or so, see if the connection to TuneIn for some reason has also improved…….or not.

The unfortunate thing about WiFi networks is that they aren’t static. There’s all sorts of external influence that you frequently don’t have control over, that can change. Issues I’ve had to deal with personally were a bad microwave leaking RF as well as new neighbors setting up a router that stomped all over the frequency my Sonos was using, but there are dozens more potential and changing issues, including the potential of RF from that DECT phone. Wiring another one of your Sonos devices makes good sense, and it’ll hope it helps you over time. 

Userlevel 2
Badge +1

Thanks @Airgetlam when I look at the 5 strongest WiFi signals in my house only 2 are from my equipment and the next 3 are all neighbour’s BT routers!

Having moved the hardwire link from the Boost to it’s own port on the back of the router everything seems really good now. All speakers working ‘properly’ and, quite noticeably, the system is responding far more quickly to taps on the app.

So in classic IT problem management mode I’ve made a few changes, seem to have sorted the problem but ultimately still don’t definitively know the root cause (but IP conflicts I think remain favourite).

Thanks for everyone’s help, much appreciated. I can’t see a ‘close this thread’ button but happy for it to be closed.

(until the next time, of course :grin: )

Before we ‘close’ this thread, I did want to say how much I like your ‘handle’. While I do like my iPhone a lot, there was something special about my Treo . Not sure which model number it was, certainly before they were purchased by Palm, and before the iPhone was released. Great device. :)

Userlevel 2
Badge +1

Ah @Airgetlam I was a huge fan of Palm and over the years bought just about every device they made. I think I could even still write in Graffiti.

And here is my Treo, well used and loved, couldn’t possibly throw it away.