Question

Sonos S2 app frequently loses speakers

  • 9 January 2021
  • 7 replies
  • 108 views

  • Contributor I
  • 6 replies

I am running the S2 App on an iphone. I have a Beam and two Play1s connected as a surround sound system and a Play One in my office. None are wired, so I am using a wireless setup. I find that several times a day my app loses connection to the system, then it pops back up again. During this loss, the speakers still playy music  (manually using volume up/down or pause play on the speaker also works) They also respond to Alexa OK when hte App loses them, So it looks like the speakers are connected OK to the router. It is an app connection issueto the sysyem. So I have removed and re-installed the S2 app. I have removed and setup the sonos system as new, I have turned off my router (left for 5 mins with no poweer) and ensured that I am using Channel 11 on the router. Still no joy. I culd wire my Beam to the router as they are close. IS that worth trying, or does anyone else have any other ideas?

Oh, and I have spent some time with Sonos support but it didnt help. I’m entirely sure he understood the issue and thought I was losing the total speaker functionality, rather than the app connection

Thanks


7 replies

Things to try:

  • disable WiFi Assist
  • disable Private Address for the network SSID

Thanks ratty.

 

Wifi assist is already off, but Private address was on, so I have turned that off now. so I will see if that helps. 

unfortunately neither of those ideas has worked. In fact I used the S2 app on the iPad and had the same issue. I tried to manually control the Play one while the apps were unconnected to the system and I could still stream music and control the tracks (forward/back) and control the volume. so again I am pretty confident that the speakers are connected Ok to the router.  I now can’t even reconnect to my system, it just says my system can’t be found. I have  downloaded the S2 app to my mac and i can control it with that while the iOS apps were not working but that isnt ideal. It does sound like some issue with the S2 app to me

 

I am experiencing the same problem. 5.1 setup with a Beam, 2 Ones and a Sub and a amp power two towers separately on the other side of the room. A paired set of ones upstairs. The all continue to disappear and almost always do not return with having to reset them. The. 5.1 works without the app as Pw72 described, but that this because of the soundbar connected and fed from the firecube. On the other hand the amp and upstairs set do not have a manual controller. This never happened on the old app. Please fix the app.

it isnt an ideal solution, but I plugged my Beam directly to my router and set SonosNet channel to 11 and the app does seem more stable since then (not 100% but much better).  My beam is close to the router so it isn’t a hassle for me, but hardly a good solution for a wireless system

Badge

Check all your network equipment.  I had a similar issue & turns out my Netgear switch was on their incompatible hardware list.  Once I replaced it I’ve had zero problems.

https://support.sonos.com/s/article/41?language=en_US

Thanks for the suggestions Pw72 & Landon. I have a suspicion it involves my router. I have replaced my network with a much more sophisticated system. With all these privacy issues arising, feel like I am looking over my shoulders all the time. I Use to have an Orbi AC3000 with two APs, well I still have it but now they are just APs. I setup a rack a ran ethernet every where without understanding how Sonos worked completely. I thought, ethernet is always better, so connect it everywhere & ligthen up the wifi traffic. Now, I understand it requires to have only one device in a group connected direct and the others use Sonos’ own 5MHz network. Now, all Sonos are up and working but will not take any commands outside of the app. By the way, I woke up the next day and all the sonos were listed on the app. Works great, just not from Alexa or other outside apps sources.

I do not have any of the listed incompatible devices connected to the system at the moment. I do have a couple 1g GS108 Netgear switches that will be going on at two office endpoints. Thanks for sharing Landon, I will be looking for any issues arising from it. I am now using a Unifi UDM-Pro router and firewall with Unifi’s US-24 & US-8-15W switches. I have a couple 1gig TP-Link switches with APs and other devices hanging off of them. The Unifi 8 port switch is where the 5.1 is hanging. From what I have read there are some issues and a few somewhat complicated work arounds to configure the UDM-Pro for Sonos to receive outside comands. For me not knowing firewall configurations this will be a youtube & Google search event even though wifi speeds are at ~500gbs.

I will say, just having the one ethernet direct to the soundbar has made a noticeable sound quality difference. I cannot wait to get synced back up with the Alexa’s again. This will be a beer and networking weekend event, Cheers and thanks for responding!

Reply