SONOS ROAM doesn't work

  • 26 November 2021
  • 4 replies
  • 43 views

I bought my sonos roam 3 weeks ago and have struggled with it left right and centre. As far as I can tell there are 4 main problems

 

The first problem I found was that the audio would spontaneously drop out while listening to video and sometimes any audio that isn't played through the sonos app. 

 

The second problem is that the bluetooth just doesn't work (excluding 2 days of it functioning last week)

 

The third is that the sometimes the buttons just don’t do what they say they should do in the manual. Sometimes the power button doesn't work, the bluetooth never connects, the volume buttons sometimes don’t and I am yet to be able to use the smart assistant. 

 

The final problem I have found is that the device can't pair with other SONOS speakers, of which I own 8. I also think that sonos needed to be clearer that this speaker would force customers to upgrade to the Sonos S2 app as I basically can't use my Play 5’s anymore because they are incompatible with the S2 app. 

 

After being a long term user of SONOS products and having lived through the early days of connectivity with sonos products and come out the other end to a wonderful whole home system I am sadly quite dissapointed with the SONOS roam and until the glitches are cleared up I would steer clear. 

 

All of this said, the sonos technical team were wonderful and were able to help me get the sonos roam working on one occasion, but sadly all of the previous problems have returned. 


Has anyone else had similar problems and found a solution?

If not then it might be time to send this back to the supplier. 

 


4 replies

I don’t think your problems are unique, but I don’t think they are typical either.  Apart from mediocre battery performance on standby (which has been improved) I haven’t had problems with my Roam.

What sort of router do you have?  Any access points or extenders?  Does your Sonos system have a component wired to your router or are you fully WiFi?

Yep I have a fully wired sonos in the lounge and have a virgin media high bandwidth router. Doesn’t matter where I am in the house either. 

Yep I have a fully wired sonos in the lounge and have a virgin media high bandwidth router. Doesn’t matter where I am in the house either. 

I would perhaps check that your SonosNet channel is set at least 5 channels away from your VM 2.4Ghz WiFi channel. 
 

You may perhaps also find this short YT video helpful, with the Roams power-button operation.. although some new features have since been introduced by Sonos in regards to powering off the device automatically via software options in the Roams ‘room’ settings.

 

Yep I have a fully wired sonos in the lounge and have a virgin media high bandwidth router. Doesn’t matter where I am in the house either. 

This is nothing to do with bandwidth.  I suspect (but I cannot of course be sure) that this is a result of Virgin’s so-called ‘intelligent WiFi’ or ‘smart WiFi’ settings.

I assume you have two channels, 2.4 and 5?  If so, do these have separate broadcast names (SSIDs) or are they under a single SSID?

If you can log into your hub, click advanced settings, then in the Wireless section you should find an option to disable smart WiFi.  I suggest disabling it and seeing how things go.  You probably ought to reboot the router and the Roam, at least, then see if that improves things.

No promises.

Reply