Sonos plays music when I start the TV

  • 6 November 2021
  • 6 replies
  • 65 views

Pretty much every time I start the TV, my sonos Move starts to play the last song from Spotify! 

 

I have a Samsung TV connected via HDMI to a Sonos Beam. 

 

How can I fix this so that no music starts just because I start the TV? When I start the TV no music is playing. 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

I wonder if this might be an IP addressing issue. A power cycle of your router and all Sonos devices would be worth trying. It would do no harm to reserve IP addresses in your router's DHCP settings.

Aha! Interesting! I'll try that as well! What is the reason behind the IP reservation idea? 

It ensures that you don't get IP address conflicts on your Sonos devices in future. (Not that I am certain that is your issue, but it can't do any harm.)

That is pretty weird.  Is your Move currently in Bluetooth or WiFi mode?  How do you play Spotify through the Move?  Using the Sonos app, Spotify Connect or by Bluetooth?

Userlevel 7

I agree with @John B …that’s weird??? To correct the issue IMO you have three options:

1. Submitt a diagnostic to Sonos via the app within 10 minutes of the next occurrence and post the reference ID in your next post. Sonos tech support may be able to provide a reason as to why the issue occurs. 

2. Elaborate more (as suggested) on how you play Spotify to the Move. 

3. Factory reset the Move. Of course you’ll never know the reason why the occurrence… assuming there is one. Also, the Move will loose the memory of any previously connected Bluetooth devices.

Thanks for your replies! I normally play music to the Move (and the other Sonos speakers I have) via Spotify in WiFi-mode. Often I start it from the Spotify app and then group up the speakers in the Sonos app.

 

So for example, let's say that I'm listening on music and then stop the music by pressing the play/pause button on the move. After a while I want to watch TV and start it. What then happens is that the beam connected to the TV starts to play the TV sound, of course, but the move also starts the last played song! It is like it was sent a "play" action.

 

Im also not sure it is with the move specifically. Sometimes this happens to one of my Sonos One as well if that one has been part of a previous music listening session. 

Basically if feels like a play-action is being triggered when the beam goes into TV-mode!

 

I'll try the diagnostic next time it happenes, thanks for the tip! 

Aha! Interesting! I'll try that as well! What is the reason behind the IP reservation idea?