Answered

Sonos Play:1 speakers disappeared and won't reconnect

  • 24 January 2022
  • 10 replies
  • 169 views

Hi team,

We have three Sonos speakers - a Sonos Beam (gen1), and two Sonos Play:1s.

A few weeks ago the Sonos Play:1 speakers disappeared from our system, and I cannot get them to reconnect.

When we try to factory reset them they show the error “Your play:1 has been added, but may not appear in the system tab. If so, unplug the power cord and plug it back in to finish setup of the system”.

I have tried:

  1. Factory Reset (shows the error every time. after a restart won’t connect, and need to factory reset again)
  2. Changing our WIFI to separate 2.4ghz and 5ghz bands, and connecting all the sonos products to just the 2.4ghz band (doesn’t work, above error)
  3. Plugging in via ethernet (this works, but only whilst plugged in, and we can’t have our speakers there)

I am at my wits end now, I can’t think of what’s gone wrong but for now these speakers might as well be broken.

This error just keeps happening again and again:

This is the error we keep getting
  1.  
icon

Best answer by Airgetlam 25 January 2022, 08:04

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Are these PLAY:1s being used as surround speakers for the Beam?

Has the radio been turned off on the Beam? That setting should be (I have an Arc, not a Beam) in Settings/System/(Room Name)/Beam: Disable or Enable Wifi.

It should be turned “on”, or Enable Wifi should be checked. If it is checked, I’m suggest trying, at least, disabling it, waiting a minute, then re-enabling it. 

No - they arent being used as surround speakers for the beam.

They were being used as separate left and right channel speakers.

I have tried reenabling and disabling the wifi and that hasnt helped.

I think something is clearly going on at the wifi connection step, potentially during the handshake process.

Have no idea how to troubleshoot this though as the Sonos speakers are frustratingly obtuse in terms of providing you with actual technical information about what is going wrong.

To say the screenshotted message isnt helpful is an understatement.

Ok, if they’re not being used as surround speakers, then they aren’t trying to connect to the signal generated by the Beam, or using proxied IP addresses. Which suggests some sort of router issue, especially as it’s a ‘new’ issue. It’s possible that your router received some sort of update that is causing issues with the connection.

What sort of network is it? Mesh, or standard?

What is the make and model of the router?

It’s not clear from your original post, but what happens if you connect one speaker with an Ethernet cable, do all three devices show up? Or is it only one device, the one that’s wired? 

Have you tried submitting a diagnostic from your controller and contacted Sonos support, and if so, what did they say?

I agree that Sonos, much like a ton of other pieces of software I use, isn’t really informative with the error messages.

I am having the same exact issue. Single Sonos Play 1. Was working last week now doesn’t connect   Haven’t changed router or modem. Have done a factory reset multiple times and hangs at the Wi-Fi connection. Receive the same error as above and then when trying to connect again says it cannot be found. Any help would be appreciated

Often, background changes in the firmware / software running on the router can cause issues. You haven’t mentioned what router you’re using, or if in fact you’ve rebooted the router. Or, if you’ve submitted a diagnostic to Sonos, as I suggested in the post directly before yours. 

I'm having the same issue, 2 X Play:1 speakers and 1 Sonos One speaker, the One speaker is fine, the 2 Play:1's have dropped off and I can't get them back on. 

I've tried rebooting the router, factory resetting the speakers and reinstalling the app. 

All 3 on WiFi, when I run an ip scan they all have ip addresses allocated and are visible on the router interface and showing as connected.  

When I connect them via network cable they work fine and I can add them in the app. 

Pull out the cable and they drop off and can't be added. Same error as original poster "it has been added but may not appear in system tab". 

Router is an ASUS AX 3000 and hasn't been updated recently, I've checked the firmware version. 

This is clearly an issue with the app, not sure why if a basic IP scan can see then on the WiFi the app can't add them in! 

It's as if Sonos are intentially bricking older speakers so people buy new ones! 

What did Sonos say when you submitted your diagnostic, and called them?

I’m using an Asus AX3000 router.  Looked inline, and in order to run a diagnostic I need to do it through the app. If the speaker doesn’t appear how do I run a diagnostic?  Do I hard wire it to the router and see if it appears?

That would indeed be an issue. If the device didn’t show up when you temporarily wired it directly to the router with an Ethernet cable, I’d have gone directly to the ‘calling them’ part. 

Same issue with my system. Router honor, no firmware updates, old devices (play 1, play 3) notre recognized for 10 days. Sonos one works just fine. Frustating...