Answered

Sonos One SL disconnecting from WiFi

  • 29 December 2021
  • 4 replies
  • 106 views

Hi,

I recieved a Sonos One SL for Christmas and would be very happy with it, however I seem to have an issue with it where it keeps disconnecting from my WiFi. It will only disconnect when it starts to play a song, and 9 times out of 10 it will disconnect before the song is over. If I don’t play any song the speaker will stay connected to the WiFi without any issue.

I have tried removing my WiFi from the list and re-adding it, however the issue still persists. The speaker is located very close to the router, and I have tested it at various distances but this seems to have no effect. If the speaker is plugged into the router via ethernet cable then I don’t run into any issues.

I have checked that my router settings are set to be compatable with the speaker, and so far as I can tell they are (standard is set to 802.11 b/g/n, and the security mode is WPA+WPA2 PSK).

I have submitted support diagnostics if you need them, the confirmation number is 1165836081.

Thanks in advance!

icon

Best answer by UKMedia 29 December 2021, 19:11

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +20

Please see my article here: Tips & Tricks - Resolving random issues impacting Sonos devices.. | Sonos Community

Userlevel 7
Badge +22

What router are you using?

hi @Hewy404 from which music source are you playing the songs? is it streaming from a smart phone or music streaming from the internet?

 

Apologies for the late reply, I had a little too much red wine last night and I was in no state to be troubleshooting and testing!

I’ve follow your steps here and it seems to have worked perfectly! I powered down every device and rebooted them one at a time, router first, and now I’m able to play as many songs as I like without any disconnects. I’ll continue to test it throughout the day but if I don’t post here again it’s safe to assume no issues have sprung back up. Thanks for you help here!

And for posterity:

What router are you using?

It’s a Technicolor DGA4231

 

hi @Hewy404 from which music source are you playing the songs? is it streaming from a smart phone or music streaming from the internet?

 

The music source is from Spotify on my phone, which is linked to the Sonos app also on my phone

 

Thanks for your help everyone!