Question

sonos not showing up in spotify connect

  • 4 August 2019
  • 12 replies
  • 19396 views

  • Contributor I
  • 2 replies
for the past few days I have been unable to play Spotify through Sonos directly from the Spotify app on my iPhone via Spotify connect. This used to work fine previously. It works fine when my partner uses her account on her iPhone, and works fine on my account via Spotify on my MacBook. I’ve tried all the recommended rebooting of router, Sonos speakers, iPhone etc. Have tried removing and reading Spotify account in Sonos app. Still no sign of my Sonos system on Spotify connect! Please help Sonos team, this is driving me nuts. Can still play Spotify via Sonos app, but this lacks serious functionality and so is not an acceptable solution.
Diagnostics report 1555445404
thank you in advance.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

I tried uninstalling Spotify from my phone and reinstalling it. This seems to have solved that problem. Thanks!
Userlevel 7
Badge +26
Hi Dr K, from the diagnostic, it looks like Spotify Connect is set up fine on the system and the cloud servers are connected to it. There isn't anything standing out to me that'd indicate this not working. Since it's just your iPhone, it could be with that phone's network connection, or the Spotify app on the phone itself. Have you tried uninstalling that app and installing it again?

If you're still having trouble and you haven't done so yet, I'd recommend following Ken's advice and contacting the support team live.
Badge
With the latest updates to iOS 13 and Spotify app, this problem no longer happens frequently. However when it does and I don't see my speakers in the Spotify app marked with "Spotify Connect", I found this workaround: go to the Sonos app and select that speaker and play a few seconds of some song or podcast etc. Then going back to the Spotify app, you will see that speaker appear in the list.
So. I spent an evening at my friends place on the other side of the city using her network and my Spotify account I could see her Sonos devices and play on them. When I got back home all my sonos devices reappeared in the list alongside hers! Now I can blast Dead Kennedys onto her system from my place and scare the bejeesus out of her love it 😊
Posttenebras,

I think you have to be on the same WiFi network to play to your friends speakers. My Spotify App on iOS says this ...

Any possibility of a reply Sonos tech team?
Any possibility of a reply Sonos tech team?
This is mostly a user forum albeit Sonos Staff do pass-by here from time to time. Maybe contact customer support via this Link instead Although this is perhaps something that Spotify Support may need to resolve, as it’s their App that you are using.

I don’t believe that’s a bug but a setting in Spotify.

 


Back to the topic. I’ve been experiencing the same issue for quite a few months already, my playbar is connected via Ethernet cable to my modem-router but still it doesn’t show up in my devices in the Spotify app, I have to restart everything (modem + playbar) every day to workaround it, but it doesn’t last much until it’s gone again.


Not in my case. different networks. Spotify is clearly buggy. But this is a fun bug.
posttenebras,

It definitely does not apply in my case. As soon as I disconnect my mobile or tablet from the WiFi, all the Spotify devices in the speaker list just disappear completely and certainly cannot be played to. Perhaps it’s just a 'refresh' problem with your mobile device or its App. I’ve tried this both with iOS 12.4.2 and 13.1.2. my Spotify app refreshes immediately as I toggle the WiFi off/on and the devices disappear and reappear.

I am assuming you are out out of range of your friends WiFi signal?

I think you have an issue moreso with your mobile display.

Perhaps try closing your App fully, by sliding it off screen and reopen it.
Had this problem and deleting the Spotify app from the iPhone and reinstalling seemed to fix it so far. Thanks
Did with mine, but after a day all disappeared again. Now even that fix won't help anymore 😞
Badge
Had this problem and deleting the Spotify app from the iPhone and reinstalling seemed to fix it so far. Thanks