Answered

Sonos Move disappeared from app, while it is playing a playlist

  • 15 February 2021
  • 3 replies
  • 44 views

I have a Sonos S2 system running latest updates over a wired and wireless Unifi network. Speakers keep dropping from system. This morning I got 8 back up by wiring 2 to my LAN. The Sonos Move was difficult. I had to put it on a remote (wired) access point in the garden, far enough away from the other Sonos devices. I did a factory reset and re-added it to my network. All seemed find again. I put on a playlist and carried it back in the house.

 

Now my Sonos Move is playing the playlist without any disruption, but the device is lost from the app.

Sonos move is 30cm away from nearest access point and signal is great.

I’m baffled and lost. Help.

 

icon

Best answer by Corry P 5 March 2021, 14:00

Hi @Rschot 

Welcome to the Sonos Community!

As you replied to yourself, this topic was never flagged as one needing a reply, so apologies for the delay in response.

Are you still having this issue? If so, please try the following steps in your UniFi controller app:

  • Log into the UniFi controller
  • Click the Settings tab on the left sidebar
  • Click Wireless Networks under the Settings page
  • Click Edit next to the network SSID
    image.png
  • Verify Guest Policy and disable it if enabled.
  • image.png
  • Click on the Save button at the bottom of the page.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • Screenshot 2020-03-11 at 13.03.04.png
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.
  • Screenshot 2020-03-11 at 13.14.56.png
  • Once completed, allow up to a minute for the AP to provision (apply the settings) and restore online connection, then proceed to the connection or setup of the Sonos system.

I hope this helps. If not, I recommend you get in touch with our technical support team - they will analyse your Sonos unit’s logs and give you some specific advice.

View original

3 replies

Sonos Move “automagically” back in system again after a few hours. No clear indication why. All I can think of is that I was optimizing my wlan network.

I implemented a new Unifi UDM-Pro router Sunday and all seemed to work perfect. The network controller provisioned all the access points and I thought it was set to auto configure the transmit power and channel. Only, it set all the AP’s to maximum power. Having a high density network (9 AP’s in my house and garden) and a lot of clients blasting during the day, this perhaps cause massive interference, to which Sonos seems particularly sensitive.

By throttling back the transmit power to medium (14dBm in 2.4GHz and 17dBm in 5GHz frequencies) interference dropped, while performance was still acceptable throughout the house. Perhaps there is a little extra optimization to be done, still.

And it gets weirder…

All speakers but the Sonos Move have disappeared from the Unifi network. Even the two that I have hard-wired to the network. In a network scan I can find them, but they do not appear as clients in my Unify management console. The app does recognize them all though and all seem to work fine. Where are they? I thought that maybe 6 of them would be offloaded on Sonos’ own wlan network, but that does not explain why the two wired Sonos speakers are not visible. And why the Move prefers my home wlan over the Sonos wlan.

I get freaked out when I don’t understand what’s going on on my network. It’s a matter of control and security.

Userlevel 5
Badge +14

Hi @Rschot 

Welcome to the Sonos Community!

As you replied to yourself, this topic was never flagged as one needing a reply, so apologies for the delay in response.

Are you still having this issue? If so, please try the following steps in your UniFi controller app:

  • Log into the UniFi controller
  • Click the Settings tab on the left sidebar
  • Click Wireless Networks under the Settings page
  • Click Edit next to the network SSID
    image.png
  • Verify Guest Policy and disable it if enabled.
  • image.png
  • Click on the Save button at the bottom of the page.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • Screenshot 2020-03-11 at 13.03.04.png
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.
  • Screenshot 2020-03-11 at 13.14.56.png
  • Once completed, allow up to a minute for the AP to provision (apply the settings) and restore online connection, then proceed to the connection or setup of the Sonos system.

I hope this helps. If not, I recommend you get in touch with our technical support team - they will analyse your Sonos unit’s logs and give you some specific advice.

Reply