Answered

Sonos is playing but no sound from any source


Badge

Sonos is playing, but none of my components is playing any sound. This includes my various speakers and my Port.  Tried regrouping, made sure system was up to date, everything.  Nothing works. Also tried different sources - my library, stations. In all cases, Sonos claims it is playing, but no sound.

And Sonos support is almost non-existent. I have been waiting for almost half an hour for a live agent on chat.

What happened to Sonos? Why has it become so unreliable?

icon

Best answer by Xander P 12 April 2021, 15:36

Hi @HarvE, sorry to hear you’re having such trouble getting through to an agent on chat, it does look like it’s been a bit busy today.

Is there any difference in the status LED between the speakers which do play, and the speakers that don’t? I had a quick peek at a recent diagnostic from your system and a few of the devices were showing as being muted - if this is the case then they should have a green status LED.

Edit: Saw the most recent response after posting.

Glad to hear you’ve got the issue sorted out, however you certainly shouldn’t be having problems like this regularly, and it may still be worth getting in touch with the Support Team to take a closer look, and try to identify the underlying cause.

View original

32 replies

Hi. It hasn't become unreliable. There will be an explanation that is specific to your network and system. 

Please can you confirm that when the speakers are ungrouped and you try to play to them individually, none produces sound?

The speakers are not muted?

 

Badge

Yes, the speakers are not muted. Yes, I ungrouped them and tried individually. An update: it plays on two of the components - Move and One. It still does not play on any other component, grouped or ungrouped.

Regarding Sonos unreliability - I am a long time Sonos owner, and I can only tell you about my experience, which is increasing frequency of anomalous behaviors over time, and the decrease in the quality of support. I waited for 30 minutes for a live agent on chat and gave up.

Badge

And regarding my network - I have an eero Pro 6 home network, and none of the other devices attached have any problems ever. 

And regarding my network - I have an eero Pro 6 home network, and none of the other devices attached have any problems ever. 

And how many of your otber devices belong to systems that require constant communication between numerous devices? I am not suggesting that there is anything faulty with your network, just that there may be something in the way that Sonos and your network interact that is creating a problem. 

Is the Eero a mesh system?

Do you have a Sonos device wired to your network or is everything on WiFi?

Badge

Eero is a mesh system. My entire Sonos system is on it, and it works well until it randomly does not.

I am now waiting for 30 minutes on chat for a live agent for the second time

 

Badge

BTW I have also set up a separate Sonos network using a Boost, but that was also unreliable.

It isn't random. The solution to your problem will probably be to wire a Sonos device to your network so as to trigger SonosNet.  That is usually the most robust way to run Sonos with a mesh.

I could have helped you to resolve this issue but I shall now leave you in the capable hands of Sonos Support. 

Badge

What capable hands? I am waiting for the third time for a live agent on chat.

Badge

And I have tried a SonosNet before, and still had problems - in fact, even more. This led me to upgrade my home Wi-Fi to a Eero Pro 6 mesh and put Sonos on that instead 

Good luck.

BTW I have also set up a separate Sonos network using a Boost, but that was also unreliable.

 

Removing the WiFi details from the system did not help? On iOS or Android: From the Settings tab, tap System > Network > Networks. Select the WiFi network you'd like to remove, and tap Remove. Subsequently wait about 10 min, then go to 'Settings → System → About my Sonos System' and see if WM:0 is being displayed next to each unit (the Move will remain at WM:1).

 

If 'Auto channel' is enabled in your router/Eero mesh, then disable it and set a specific channel, either 1, 6 or 11. Change also the SonosNet channel ('More --> Settings --> Advanced Settings --> SonosNet Channel') to either 1, 6 or 11. That means when e.g. SonosNet is set to channel 6, put your router on channel 1 (or vice versa). See also Reducing wireless interference.

Badge

No, sorry, I do not have a separate SonosNet  now. I did in the past, but it was so problematic I upgraded my home WiFi to eero pro 6 and put Sonos on that instead. It has been better, but still random problems like this 

Badge

My fourth attempt to chat with a live agent has failed. I remember the glory days of Sonos when you could contact support on Twitter and get a response within 10 minutes.

Badge

Attempt #5 to get through to a live agent on the Sonos “24/7” chat has also failed.  Back to one of my original questions - what happened to Sonos?

Badge

I was able to fix it for now, without any help from Sonos “support.” Here’s how:

For each component not playing:

  1. unplug from power, wait.
  2. plug back into power. Wait until it rejoins.
  3. Add it to group that is playing. It will play audio for a second or two, then go silent.
  4. Ungroup it again, then add it back to the group again.

So, an ad-hoc fix for now. Just want to point out that when I went to bed last night it was working fine. Nothing else has changed on my network.

Sonos is the only device on my home Wi-Fi network that behaves like this. Everything else, from computer to Roku to Peloton, behaves consistently. 
 

And again, five unsuccessful attempts to get through to live support.


 

Userlevel 5
Badge +14

Hi @HarvE, sorry to hear you’re having such trouble getting through to an agent on chat, it does look like it’s been a bit busy today.

Is there any difference in the status LED between the speakers which do play, and the speakers that don’t? I had a quick peek at a recent diagnostic from your system and a few of the devices were showing as being muted - if this is the case then they should have a green status LED.

Edit: Saw the most recent response after posting.

Glad to hear you’ve got the issue sorted out, however you certainly shouldn’t be having problems like this regularly, and it may still be worth getting in touch with the Support Team to take a closer look, and try to identify the underlying cause.

 

Sonos is the only device on my home Wi-Fi network that behaves like this. Everything else, from computer to Roku to Peloton, behaves consistently. 
 


 

But Sonos isn’t a device, it is a number of devices that have to communicate with each other and with controllers.  Your observation that Roku or Peleton works could not be more irrelevant.

Put this multi-device aspect together with a multi-AP mesh network and there is potential for trouble.  If set up optimally it will be fine, but since you just insist it is a fault with Sonos, and won’t take advice, you WILL have problems again soon.

Userlevel 6
Badge +17

Hi @HarvE 

Welcome to the Sonos Community!

I’m sorry to hear that you’ve had such trouble getting in touch with our technical support team - all I can suggest is trying at a different time of the day.

It seems likely that at least part of your Sonos system’s issue is that some of your Sonos products - those that are not able to connect to 5 GHz - are being steered towards that frequency by your Eero mesh (band steering). This results in a Deauthorisation error, which I see happening on quite a few of your rooms. As you cannot separate the bands on a Eero mesh, I therefore recommend you hard-wire a Sonos product to the main Eero hub (or to a switch connected to the hub) via ethernet. This will let Sonos create it’s own WiFi that the speakers will be “happier” with. As you seem to have a Boost on your account which is not showing up in your diagnostics, I recommend you either reconnect this or check to see that it still has power. If the Boost is non-functional, please wire a speaker/player instead. Any Sonos device wired to your network should ideally be kept at least 3 feet away from your router or mesh nodes. You could ethernet-wire to one of your other Eero nodes, but the main one is highly recommended. As you have a sizable system, you may get better results if you ethernet-wire more than one device (ideally at opposite ends of your home/system).

If you added your Eero mesh to an existing network (as opposed to replacing the router), you will probably have a DHCP conflict, whereby random devices will end up on a second network (router or Eero) and not talk to each other. If this is the case, you can find instructions to put your mesh into Bridge mode here: https://support.eero.com/hc/en-us/articles/208276903-How-do-I-bridge-my-eeros-. Please reboot your router after doing this. This can fix many strange issues if it is indeed the problem.

 

Edit: I see two of us were working on this at the same time! Ah well. We both made good points.

Badge

I am sorry my frustrations came through so strongly. But, the reason why you see a Boost in my account is that I tried this in the past, and no matter what I tried there was some type of interference that created skips and lags in different components. I upgraded my Eero to Pro 6 and migrated to that, and no more skips, but these events instead. It is frustrating. But apologies for losing mycool; I do miss the Twitter account. That was great.  

Userlevel 6
Badge +17

@HarvE 

Due to the deauthorisations, I recommend you go back to the Boost and do what you can to minimise the skipping. Keeping the Boost 1m (3 feet) from and WiFi Access Points is a good start. If you typically use large groups, a second wired unit would definitely help, even if wired to a mesh node.

The dual DHCP issue is definitely worth checking in either case as that’s more to do with network management than WiFi reception.

The SonosNet does provide a stable connection, when wireless channels are appropriately setbecause you are experiencing wireless interference and you ought to do something about that. Further, how many devices do you group together at the same time?

Badge

Large groups - the largest group is 6 rooms, one of which is a stereo pair.

When I used Boost in the past, we could never solve the music skipping problem due to interference. That’s why I migrated Sonos to eero in the first place.

Your best hope for a stable system is to try the Boost again in this new situation, and then if necessary to work with Sonos Support  (if you can get through) and/or the Sonos staff and users on this forum, if there are issues. 

It is of course your right not to try this but an unstable setup is the only alternative. 

Userlevel 6
Badge +17

Large groups - the largest group is 6 rooms, one of which is a stereo pair.

When I used Boost in the past, we could never solve the music skipping problem due to interference. That’s why I migrated Sonos to eero in the first place.

Hi @HarvE 

6 Rooms is a fairly large group - we’d recommend 2 devices hard-wired for a group that size. The choice of speaker that’s put in charge is also very important. If you had wired speakers, one of those would be best, or one closest to the Boost (once it’s connected).

As Eero mesh (and other meshes) don’t allow separation of bands, the only way to really fix the deauthorisation issue is to bypass Eero and use SonosNet instead - I, or Sonos Support, can certainly help with issues that occur then easier than we can fix deauthorisations.

I understand that this is probably very frustrating to hear as it’s the reason you got Eero, but the mesh will still help other devices and home coverage. Although it’s not ideal from our technical perspective, now that you have a mesh you may find that the best place to locate your boost isn’t by the router but wired to one of your mesh nodes, elsewhere. There are certainly more options now, with the mesh.

 

 

Badge

Someone on Reddit pointed me to an article at eero that says the same thing: use SonosNet for systems with more than three zones: 

Eero article

But you suggest plugging the Boost into a non-gateway Eero mesh node, right? In the article above, Eero says NOT to do that (yes, they capitalize NOT). 
 

Despite my venting yesterday (again, sorry), I am open to suggestions. I also have a callback with a Sonos support supervisor tomorrow.

Reply