Question

Sonos Boost exacerbated speaker dropout issues


Badge +1

I have a fairly modest Sonos setup: two Five’s in a pair with a Sub in the living room, and two One’s in a pair in the bedroom. I started experiencing dropout issues when I added the Sub. What will happen is the right Five (it’s always the right) and the Sub will start playing at the beginning of a song and almost immediately drop out. They eventually come back after about ten seconds. The left side never drops out. This would only happen when playing from a service such as Qobuz or Amazon HD. I spoke with tech support and we came to the conclusion that a Boost would help remedy the issue. I received my Boost today, plugged it in, and now the issue happens much more frequently, and on every service (Spotify specifically, where it was not happening before). My network matrix shows all green, except for the Boost itself. What is most frustrating is that, as I stated previously, none of these issues were present before I purchased the Sub. This has made using Sonos almost a chore, and caused me to seriously second guess my decision to buy into the ecosystem. 

 

There is roughly a five foot hop from the Boost to the left Five, and the two One’s are in an adjacent room. I have no other networking issues in the house aside from my Sonos system. 

 

Airplay 2 works fine. There are zero issues when streaming from an iOS or MacOS device. 


23 replies

Userlevel 6
Badge +17

Hi @quadband 

Welcome to the Sonos Community!

First, please stay aware of the Money Back Guarantee period of the Boost - if we don’t get things working better before that period is up, please get yourself a refund.

What I suspect is happening is that there is third-party interference near either the left speaker, or both the right speaker and the Sub. Another possibility is that all 3, or any 2, of these units in your living room are too close to each other - they all need at least 1m space from each other and other WiFi-enabled devices, as do all WiFi devices, Sonos or not. Qobuz and Amazon HD are likely playing FLAC audio at a much higher bitrate than AirPlay 2, which is why only they are affected.

Please read our Reducing Wireless Interference page for help on identifying possible sources on interference. Please keep in mind sources that may be on the other side of a wall that a speaker is up against.

If this doesn’t help, I recommend you get back in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports about the situation.

If you’re able to fix your playback issue by moving speakers or interfering devices, I recommend you return the Boost to get your money back (but first test on WiFi fully, of course).

I hope this helps.

 

Edit: edited for technical accuracy

In a stereo pair, the left speaker is in charge. It is fetching the music stream from the source, and telling the right speaker and the Sub what to play, over dedicated, speaker-to-speaker, 5GHz WiFi links.

Is direct routing now taking advantage of 5GHz for non-HT bonds and groups, i.e. ‘out-of-band’ from SonosNet’s 2.4GHz? That would surely require two radios, as opposed to a single dual-band radio.

(This is distinct from the case where all in the bond/group happen to be on 5GHz WiFi.)

Userlevel 6
Badge +17

@quadband & @ratty 

Apologies - I was incorrect. I got Home Theatre and stereo pairing mixed up.

Reducing wireless interference is still the likely fix, however, though it may be best to get in touch with our technical support team, who have tools at their disposal that will allow them to identify the location of the interference.

Before doing so, however, I recommend a reboot of the 3 speakers, the boost and the router. Switch the router on first. When it’s online switch on the Boost, and when the Boost gets a solid white light, switch on the speakers. Test for a good 20 minutes before calling us so there is plenty of performance logging on the speakers.

I’ll edit my post above to be more technically accurate.

 

Edit: Edited here too

The Boost is directly involved in getting the stream to all the units involved. 

Surely it’s as you originally sketched out, but simply at 2.4GHz not 5GHz. Direct routing should take care of the stream transmission peer-to-peer from the L unit to the R and the Sub.

 

Userlevel 6
Badge +17

Thanks @ratty 

I seem to having a bad day, plus I think I panicked a bit last time! You are correct. The Left speaker feeds the right speaker and the Sub, but over 2.4 GHz direct routing.

Badge +1

I appreciate the responses. My place is certainly radio dense; mostly 5Ghz. I’ve separated my 2.4 channels as far as I can and seem to be getting somewhat better results. Setting my WAP’s 2.4 to use channel 1 and the Boost to channel 11 seems to have eliminated speaker dropouts. The preliminary results are good, even while playing actual masters (big fat wav files) from a NAS. 

 

Does the system support multiple Boosts? I have a couple other places I intend to stick speakers and I’m not certain a single unit will provide coverage in my environment. 

Yes, you can wire multiple BOOSTs. Or, for that matter, wire other Sonos speakers. They all would reinforce the SonosNet network. But they all would reinforce the SonosNet network anyway, once you’ve wired the first BOOST, as that is the way the SonosNet network functions, each device becomes a receiver and broadcaster of the signal.

Badge +1

Welp, so much for it working fine. The behavior is still exhibiting itself despite the speakers all having green connections to one another in the matrix. If 2.4 interference were the cause then the left speaker should also cut out, and the other speakers would cut out more than the single time they do at the beginning of a song. I want to reiterate that the left speaker never cuts out or hesitates. It only occurs when I am selecting a new song within a playlist.
 

This appears to me to be a throughput/bandwidth problem between the nodes as I am assuming that they use some sort of naive buffering strategy that then associates chunks to a time domain hash map. 
 

I’ve submitted a diagnostic: 174365274

Userlevel 6
Badge +17

Hi @quadband 

There is some noise near your Boost that I would like to minimise. It’s likely that the Boost and router are too close to each other, but it could also possibly be another source. Please read our guide on Reducing Wireless Interference and isolate the Boost from any possible sources, by at least 1m.

There’s also some multicast flooding on the network. Please switch your router off for at least 30 seconds to refresh things.

Finally, given that your Living Room speakers are closer to the Boost than the Bedroom speakers, I recommend you put that room in charge of the group by selecting it first in the app when grouping. Thanks.

 

Badge +1

Hi @quadband 

There is some noise near your Boost that I would like to minimise. It’s likely that the Boost and router are too close to each other, but it could also possibly be another source. Please read our guide on Reducing Wireless Interference and isolate the Boost from any possible sources, by at least 1m.

There’s also some multicast flooding on the network. Please switch your router off for at least 30 seconds to refresh things.

Finally, given that your Living Room speakers are closer to the Boost than the Bedroom speakers, I recommend you put that room in charge of the group by selecting it first in the app when grouping. Thanks.

 

The Boost is indeed currently sitting right under an AP node (though hardwired back to a switch in my office.) I will see about moving it. I didn’t figure that to be an issue as everything else in the matrix is green, and my AP’s employ beam forming.
 

The multicast flooding wasn’t something I was aware of, but I bet my boots it’s the WiFi bulbs on the network. I will track the source down. I can probably even segregate those off (or throw them in the lake as I’ve been threatening to do.)

Again, the thing that confuses me most about the issue is it’s never all of the speakers. Just the children of that left living room speaker. I will move stuff around, clear the air, and report back. Thanks for your help. 

The Boost is indeed currently sitting right under an AP node (though hardwired back to a switch in my office.) I will see about moving it. I didn’t figure that to be an issue as everything else in the matrix is green, and my AP’s employ beam forming.

https://en.wikipedia.org/wiki/Near%E2%80%93far_problem

 

Badge +1

The Boost is indeed currently sitting right under an AP node (though hardwired back to a switch in my office.) I will see about moving it. I didn’t figure that to be an issue as everything else in the matrix is green, and my AP’s employ beam forming.

https://en.wikipedia.org/wiki/Near%E2%80%93far_problem

 

Uncertain how this is relevant unless all you read was the bit about it sitting underneath. The Boost is within a deep lobe null of the AP as well as having 9 channels of separation on the 2.4 band. Unless the Boost is overly susceptible to harmonics the AP is unlikely to be causing enough interference to overload its front end. I suspect the issue has more to do with my multicast situation, which I will solve. 

Userlevel 6
Badge +17

Hi @quadband 

The floor is not a good location for anything that’s trying to transmit throughout your home. A level higher than most furniture would be better (so the signal is blocked by less mass). Some surface types (metal or glass, usually) can also make the Boost catch reflections of it’s own transmissions, which can interfere with further transmissions - but these need to be very close to have this affect.

Due to the inverse square law, however, extreme proximity to other WiFi sources is never good, regardless of the difference in exact frequencies used. An increase in physical separation between your router and Boost may be what’s needed, especially if your router is a more powerfully-transmitting one.

Badge +1

Hi @quadband 

The floor is not a good location for anything that’s trying to transmit throughout your home. A level higher than most furniture would be better (so the signal is blocked by less mass). Some surface types (metal or glass, usually) can also make the Boost catch reflections of it’s own transmissions, which can interfere with further transmissions - but these need to be very close to have this affect.

Due to the inverse square law, however, extreme proximity to other WiFi sources is never good, regardless of the difference in exact frequencies used. An increase in physical separation between your router and Boost may be what’s needed, especially if your router is a more powerfully-transmitting one.

Here is the current setup; forgive the clutter: 

Userlevel 6
Badge +17

Hi @quadband 

Thanks for the picture - the Boost and WiFi Access Point are far too close to each other. They need to be at least 1m (3 feet) apart. The Boost was quite clear in reporting the noise levels in the diagnostics.

Having the Boost wired directly to the main router would be our preference, even if it’s further away from the speakers - it’s best to simplify the connections when there are issues. 

I hope this helps.

 

Edit: moving the Boost will have the added benefit of increased speed/reliability for other devices on your WiFi, as the AP is being interfered with just as much as the Boost.

Badge +1

Hi @quadband 

Thanks for the picture - the Boost and WiFi Access Point are far too close to each other. They need to be at least 1m (3 feet) apart. The Boost was quite clear in reporting the noise levels in the diagnostics.

Having the Boost wired directly to the main router would be our preference, even if it’s further away from the speakers - it’s best to simplify the connections when there are issues. 

I hope this helps.

 

Edit: moving the Boost will have the added benefit of increased speed/reliability for other devices on your WiFi, as the AP is being interfered with just as much as the Boost.

The Boost is wired back to the main resi-household switch. The AP is using a dedicated 5Ghz wireless backhaul and has 2.4 turned off and is only running 5Ghz. I’m betting the interference is coming from the Lutron and Philips hubs in proximity. 
 

In the interest of solving the root issue I plan on disabling the AP and the IoT hubs and testing to see if it improves reliability of the Sub and right Five. My gut tells me no, but if that turns out to be the case I will break out the Sawzall and drill. I intend to slay the multicast beast this week. 
 

You had mentioned grouping the speakers in a certain order; for context, does the master speaker in a group handle all the decoding and then forward the result on?

Userlevel 6
Badge +17

Hi @quadband 

That sounds like a good plan for troubleshooting.

The first member of a group, called the Group Coordinator, is responsible for fetching the stream, buffering for it’s own playback, and distributing it along with timing cues. Each player will buffer, decode the stream, and play at the agreed-upon millisecond.

As the Group Coordinator must communicate on the network more than others, it’s best for this speaker/room to be the one with the most reliable connection.

 

Edit: As the Boost only transmits on 2.4 GHz, having the AP only transmitting on 5 GHz would certainly suggest they won’t interfere with each other, so it may indeed be due to the other hubs you mentioned. With such extreme proximity, however, it’s difficult to say without the steps you’re about to try.

Badge +1

As a quick follow up to this post:

I removed the AP node and all hubs; simply powered them off. It made no difference. Reiterating my previous point, the left speaker never hesitates in playback. It’s connection doesn’t appear to be bad.

My takeaway from this is that the node to node bandwidth is insufficient to reliably handle Qobuz or Amazon HD. It’s unfortunate, because it means for whole home audio I am unable to utilize all of my playlists. I appreciate your assistance in helping me to try and figure the problem out.

 

edit: a word

Userlevel 6
Badge +17

Hi @quadband 

Your Fives certainly shouldn’t have any problem communicating with each other.

Could you please remove the Sub from the Living Room (in the Sonos app, not real life)? Once done, please test playback until you are happy there’s no playback issues.

If you no longer get playback issues, and are now convinced the Sub was causing the issue, then please bond the Sub back to the Living Room and try the Sub in different physical locations in the Living Room.

If you were able to get faultless playback without the Sub, but are now unable to with the Sub in any location, please remove the Sub from the Living Room in the app, then bond it to the Bedroom to test it in that room instead (you will probably need to move the Sub to the Bedroom too). 

If it seems the issue follows the Sub, please remove the Sub from the Bedroom in the app, then factory reset the Sub, and set it up in the Living Room again for more testing.

Please let us know how you get on.

 

 

Badge +1

@Corry P Not being one to let an issue go, I borrowed an SDR from a buddy that is capable of S band RX and the results are interesting. I will follow up with the fruits of my fiddling, shortly. 

Badge +1

@Corry P In what I can only describe as “death by a thousand paper cuts” the Zigbee traffic in my house was obliterating certain WiFi channels. Initial reconfiguration has yielded a 13dB improvement in the noise floor (as indicated by the Boost in the matrix) and 3 points better OFDM ANI levels. I am confident I can improve this further. Despite green connections between Sonos nodes, the Boost was absolutely drowning. No more dropouts with Qobuz. 🙃

“Zigbee won’t interfere with WiFi” is a big fat lie, and apparently the Philips Hue hub isn’t smart enough to move out of the way of anything else on its own. Unplugging the hub causes the bulbs to imitate the popular seagull scene from Finding Nemo. I have *so many* Hue bulbs. 

I will follow up with the conclusion after I make my final environment changes. Preliminary conclusion: “Check your Zigbee channels. Change them, probably.”

Userlevel 6
Badge +17

Hi @quadband 

I’m glad you found a solution, and thank you for sharing your findings!

I have to admit, I actually sniggered when I read the bit about the seagulls.

Mine

 

“Zigbee won’t interfere with WiFi” is a big fat lie

Indeed.

https://www.metageek.com/training/resources/zigbee-wifi-coexistence.html

Reply