Sonos Beam - Sound from TV apps not working

  • 18 March 2021
  • 3 replies
  • 41 views

Userlevel 1
Badge

I’ve got a Philips 55PUS6703/12 tv and I’ve just taken receipt of a Sonos Beam. 
 

On my Philips TV I set the sound output to ‘Multichannel’ which resulted in my sound output on my aerial channels being Dolby 2.0, which was all good. 
 

But upon using Netflix (TV app), Amazon (TV app) or Disney (cast from iphone) I am getting no sound whatsoever. 
 

On Netflix the sound is showing as Dolby 5.1 (English), I have to change it ‘Dolby 5.1’ and it then works. Output showing on the Sonos App is ‘Dolby 5.1’. This is a bit of a pain if I have to do this every time. 
 

On Prime I have no ability to change the sound. So in order to get sound I have to change the TV sound setting from ‘Multi channel’ to ‘Stereo’. 
 

This is a complete pain and I’m wondering if the Beam is even compatible with my TV. I don’t want to have to change sound settings depending on what I’m watching. 
 

At the moment I’ve set the TV sound option to ‘Stereo’ so everything is working. But I’m now missing out on Dolby 2.0/5.1. 
 

Any help would or guidance would be appreciated. 


3 replies

Userlevel 7
Badge +17

Are "Multichannnel” and "Stereo” the only choices for sound on the Philips? No “Dolby Digital", for example? 

Userlevel 1
Badge

Are "Multichannnel” and "Stereo” the only choices for sound on the Philips? No “Dolby Digital", for example? 

The options are:

Stereo (uncompressed)

multichannel

multichannel (bypass)

Dolby digital plus

 

Multichannel (bypass) isn’t making a difference. And Dolby digital plus isn’t supported by Beam. 
 

Appreciate the response. 

Userlevel 1
Badge

Bizarrely the sound is now working properly. I’ve not done anything differed to what I was trying yesterday. Setting of ‘multichannel’ seems to be working now. 

Reply