Question

Sonos App Not Connecting to Sonos Beam

  • 9 April 2021
  • 1 reply
  • 20 views

Sonos App (iOS) is not able to connect Sonos Beam to network.

 

Right around the time of the most recent App update (13.0.4 on 4/6), suddenly my Sonos Beam dropped off my list of devices accessible via Airplay, and it was no longer showing up in my Spotify list of eligible speakers. Attempted a factory reset and to say the least...there were a lot of reconnection attempts required, where it wouldn’t pick up the network. During a single connection window, managed to get it set back up with Alexa.

Not long after, however, the Sonos app promptly disconnected again, and has been that way since (past two days). The app complains all devices are disconnected, is completely unable to detect the Beam unless I attempt a new device setup through bluetooth, the Beam itself never returned to the list of eligible Airplay devices, and any attempts in the app to reconnect the device to the WiFi say the network is inaccessible. However, all the Alexa-enabled features of the device are working just fine (so, the device itself is able to connect to the network just fine, but network issues are specific to the Sonos App).

It also doesn’t show up by default as a eligible speaker through Spotify, but if I command it through Alexa--either through voice or through the Alexa app--it plays Spotify music just fine. Bit of a niche detail, but whatever.

 

I’ve already tried factory resetting this plenty of times and feel like I’m wasting my time, wondering if there’s a fix I should instead be waiting for.

 

Attempts Made:

  • Factory Reset
  • Router Reset
  • Made sure the Phone is only connected to the same 2.4GHz network.

1 reply

Userlevel 5
Badge +14

Hi @bdmoore43 

Welcome to the Sonos Community!

Thank you for mentioning that your phone is on iOS! There are a couple of new settings on iPhones that can directly affect their ability to connect to Sonos:

  1. Local Network permissions on iOS 14+. This option can be found in the iPhone’s main settings, under Sonos.
  2. Private Address on iOS 14+. It’s not clear to me why this causes an issue, or if it’s confirmed that it does at all, but there’s a thread about it here: 

     

Please let us know how you get on.

Reply