Sonos and T-Mobile Home, service drops in and out

  • 25 June 2021
  • 5 replies

I recently switched to TMobile home internet service, so far so good, streaming TV, internet, home automation, etc.

I am in an area that has one other option (XFinity) and their service on my street is crap.

My 4 - Sonos Ones which have worked fine for years suddenly drop in an out. Mid-song they will just go silent and then start up a minute later on the next song. It happens often.

I have looked at the 2.4 vs 5ghz issue, not sure if that is a thing. 

Is anyone else experiencing this issue?



Best answer by GuitarSuperstar 25 June 2021, 16:39

Try unplugging the speakers from power for a couple of minutes and reboot the router.

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

Try unplugging the speakers from power for a couple of minutes and reboot the router.

First and foremost thanks for the tip.

Strangely it worked for about an hour, but is now a bit worse. It plays into a song or two then goes silent then starts up a little way into the next song a minute or two later. Again, I have 4 of the Play speakers and they all go silent, I always play them all at the same time. And again this is using the new TMobile Home Internet Gateway can.

In the Sonos system requirements (see below link) it does say that the router needs to be a High speed wired internet connection such as cable, fiber, or DSL and that LTE routers are not supported.

Is this a 4G or 5G connection? Have you tried just perhaps playing to one speaker only? I’m just wondering if the mobile connection is perhaps part of your issue here.


Moved from a city center in Calif to a pretty small costal town in Maine.

The local wired internet (XFinity) promised 200Mbps but was more like 5 one day 150 the next and so on.

The wireless option by TMobile has been  70-80 without much variation beyond that.

Oddly the SONOS was not doing this when I was wired to the fluctuating fixed internet

Maybe try the following…

  • Wire one device to the router to switch the devices to use their internal SonosNet signal. Keep that device (and other wifi devices) well away from the router - I suggest 3 to 4 feet away.
  • Set the router’s 2.4Ghz band to use fixed channel 6
  • Set the channel-width to 20MHz only
  • Set the SonosNet channel to 1 or 11 in the Sonos App
  • Remove the routers WiFi credentials in Settings/System/Network/Manage Network” - these are not needed when using SonosNet.

See if that fixes things for you, but this doesn’t guarantee things will work, particularly if your T-mobile signal to the router is not stable.