Answered

Sonos Amp and Line In Autoplay Not Working

  • 13 January 2022
  • 12 replies
  • 176 views

Userlevel 1
Badge

Hello - I am having an issue with my Sonos amp where autoplay doesn’t kick in with my turntable. The autoplay of hdmi is working wonderfully, however, it’s going the other way to line in that is having trouble. I viewed this thread and understand that hdmi will always win:  

 

 

Here is my setup:

-an spdif switch plugged in to the the hdmi of the amp using the Sonos spdif to hdmi dongle. The spdif switch has an on/off switch. 
-phono preamp with on/off switch. 
 

Steps to recreate:

-turn off spdif switch. 
-turn on phono preamp 

-start record.

 

 

in the use case above the autoplay does not start. I am forced to go into my Sonos amp and through a series of clicks start the line in. 
 

The only thing I can think of is that even when off the spdif switch is still sending some sort of a signal. 
 

Would love to get some input on this perplexing issue. 
 

thanks in advance. 
 

icon

Best answer by Macollin1 14 January 2022, 23:23

View original

12 replies

Userlevel 7

If you disconnect the switch from the Amp does the Line-In Autoplay work? If so, then the switch is probably causing the issue.

You might also try unplugging the Amp from power for a couple of minutes to reboot it.

My thoughts to resolve the issue is to use a voice assistant with your Sonos devices, like an echo-dot. Then switch off T`V Autoplay in the Amp room settings, so that it does not ‘compete’ against the line-in Autoplay feature… that way the line-in will Autoplay whenever the TT plays audio.

Then use Alexa and the Sonos Skill to switch to TV Audio by saying…

‘Alexa, switch to TV mode on [Amp Room Name]’

At least that saves reaching for a mobile device and navigating through the App to achieve the switching of the audio… and there’s no need to use the optical splitter/switch.

Userlevel 1
Badge

Thank you both for your quick replies. 
 

I tried unplugging the switch from the amp and I wasn’t getting a consistent switchback to the turntable through autoplay when I would go from listening to Apple Music and switching the preamp back on. Not sure why that doesn’t work every time. 
 

As for the Alexa suggestion, I really liked the idea a lot. I was able to get it to work the first time. So, success auto playing the turntable when I switched the preamp on. And then I asked Alexa to turn on tv mode and it switched over. I then turned the preamp on again and played a record and auto play did not kick back over to in line. I tried this multiple times and it always worked the first time but would not switch back after the Alexa command.

I also pulled the plug in the back of the amp and repeated both suggestions and was met with the same results. 

Thanks again  I’ll keep experimenting and report back  

 

Edit: I was just reading on another post regarding autoplay that it may take a minute or two before auto play works again  I was not factoring that in and certainly rapid fire autoplay isn’t my use case  so I will tinker with this more waiting for longer breaks in between  

 

Userlevel 1
Badge

Update: unfortunately waiting it out didn’t do much for me. I tried waiting any where from 1 minute to 20 minutes and no luck getting it back to the turntable through auto play. I double checked that auto play is off for the tv and it is on for the line in. The only time it seemed to work was first thing this morning. So after the Sonos sat all night. Maybe 20 minutes just isn’t long enough???

Update: unfortunately waiting it out didn’t do much for me. I tried waiting any where from 1 minute to 20 minutes and no luck getting it back to the turntable through auto play. I double checked that auto play is off for the tv and it is on for the line in. The only time it seemed to work was first thing this morning. So after the Sonos sat all night. Maybe 20 minutes just isn’t long enough???

Have you tried taking out the optical switch altogether to see if that makes any difference.. although I don’t really see why it would, but worth a try. Also what is the current line-In source level?

Userlevel 1
Badge

Yes. I have tried unhooking the spdif switch with similar results. 
 

my input level is set to 10 (high). 
 

Thank you!

Strange, I would have expected the switching between the two inputs to work with the TV Autoplay switched off, as there isn't anything to ‘compete’ with the line-in Autoplay feature - It maybe worth contacting Sonos Support Staff and see what they say. Here is their contact LINK where you can chat online to Staff.

Userlevel 1
Badge

Thank you Ken. I agree. My next step will be to contact support. 
 

All the best. 

Userlevel 1
Badge

Ok, here is a quick update. I talked to support a number of times and we seemed to have narrowed it down to auto play being wonky when going from TV → line in. It seems to cooperate when going from music source (Apple Music) → line in. We did discover that it has to sit on the music source for 30 seconds or so. It does not work if you try and have autoplay work the second you turn the music source back on. 

I will be talking to someone at Sonos tomorrow about the TV → line in issue.  

 

Userlevel 7

Hello Everyone

I have a Pro-Ject Turntable (TT) hooked-up to a Sonos Amp with Sonos Sub and 3rd party speakers using an outboard pre-amp. That connection works flawlessly with Line-in and AutoPlay. 

It just so happened that the TT setup is next to my Arc connected to a LG. I decided to temporarily switch the HDMI from the Arc to the Sonos Amp (TT setup). I activated the TV AutoPlay in the menu then turned on the TV. Audio was heard with the expected 3-5 sec delay.

Upon turning the TV off I tried to play TT audio...No Joy.  :disappointed_relieved:

The solution (as verified by Sonos Tech Support) is to: Open the Sonos App > Click on the Music Note icon > Browse to Line-in > Select My Turntable (Room). It works everytime.

Of course (as a best practice) you want to stop the audio signal from the TV (turn it off) before you engage the TT Line-in. The bonus is there is no need to disengage the TV AutoPlay.

I hope this helps!

Edit: If your setup is permanent to Sonos Amp (i.e. Turntable Line-In and TV HDMI) you can play TV audio at anytime. Just remember to follow the solution mentioned above to go back to TT audio.

Also if using a pre-amp there is still an active signal to the Amp unless you turn it off; or it goes into sleep/standby mode as mine does (after 20 minutes).

Userlevel 1
Badge

Hi Aj -

Thanks for the response and advice. My end goal is to be able to take advantage of the autoplay for line-in, since the Sonos App solution you point out works, but frankly is a lot of clicks and it assumes I have my phone on me at all times. I am trying to automate, or at least become less dependent on my phone to switch inputs.

I would love for the autoplay to work consistently, OR to be able to use the buttons on the Sonos amp to switch inputs, OR even have direct access to TV or Line In with my Harmony Hub remote. I know this isn’t everyone’s use case, but I can dream :)

 

Thanks again for the input.

Matt

Userlevel 1
Badge

Hello all -

I think I have solved my problem with a fairly acceptable workaround. This use case is specifically for those with a Harmony hub, so hopefully this helps someone down the road:

  • Turn on autoplay for both the TV and Line in in settings on the Sonos app
  • Add the turntable as a favorite in the Sonos app
  • Create an activity in Harmony for listening to music using Sonos and have it start with the turntable favorite
  • Start playing the record (it’s important to note that when the favorite is selected by Harmony Sonos will flip from TV audio to a screen that reads “No Music Selected”. This will then flip over to Line in as soon as the music starts on the record - I know it’s a little quirky).
  • Then go back to your watch TV activity and the TV turning on will kick the audio back to the TV

 

I have been able to successfully recreate this every time. 

 

Thanks again for everyone’s help with this.

Reply