Sonos 2 App Not Working with ROAM

  • 5 June 2022
  • 2 replies

Hello All,


I have done some research on this issue, without a definitive solution that I can find. I have two Sonos One (Gen 1) and one Sonos 5 (Gen 1) and I have been relatively happy with these for years (minus the 5 that drops from my list of devices often and I have to “discover” it again, but different issue). This week I was given a Sonos Roam and immediately my frustration went through the roof. I am a fairly technical individual so I figured I would get the New Sonos app and use the original app to control the speakers that can’t upgrade (that still works, no problem) and use the new app to control only the Roam. However, the new app insists on finding the Gen 1 devices every time, and then locks the program with the screen that states these products are not compatible with the New App and open the Gen 1 app. This happens every single time.


Why can the new app not just ignore the old equipment and run the new ROAM all on it’s own, without discovering the old equipment. No matter how many times I have tried, it always discovers the old equipment. Why can I not tell it to ignore the Gen 1 equipment?


I finally unplugged all of the Gen 1 equipment, and that let me setup the ROAM. However the new app does not let me connect Apple Music, Pandora or any other music app, as it says there is an update, but no matter how many times I say complete the update, it doesn’t do it. So all i can listen to is music on my phone (which I don’t have music saved to my phone) or the default music services built into Sonos. In addition, as soon as I plug in my old system, the gen 2 app wants to discover them again and gives me that popup to use the old app to control the old equipment that I can’t get past. 


So I tried another option, turn off wi-fi and connect only through Blue Tooth. The new app tells me that the ROAM and App have to be on the same wi-fi connection. This is a ROAM system, I should be able to play music in the middle of the desert without wi-fi and using only my 4G connection (or am I missing something here?). Is it true, that if I am out hiking I can’t take this speaker and play music through blue tooth?


I am extremely frustrated by what I think should be a very simple setup. Old app, control old equipment. new app, ignore old equipment and play on new equipment. What am I missing that makes these extremely simple tasks so absolutely frustrating. I have seen numerous posts on this, but I didn’t find any real solutions (unplug old equipment….great unless you actually want to use the $700 in speakers you have around the house, then it is wait….let me plug it all back in first). 


I appreciate any advice or assistance with this issue or is this an unfixable scenario? 


Best answer by Ken_Griffiths 5 June 2022, 22:38

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Update: So I did find out I can play music through the ROAM by opening Pandora and just as a normal bluetooth speaker. I guess that solves part of my problem. However, I would still like to control through the app and wi-fi when around the house.


So just a quick recap and some thoughts/suggestions .. you discovered you could not install to S1, so you downloaded the S2 App and it found your old S1 HH. You then powered off all your S1 products, but…

"Did you reset your Sonos S2 App at this point? Or even uninstall/reinstall it in order to create a brand new Sonos HH - if not then I think that might have ‘possibly’ been your mistake".

Here are my thoughts/suggestion to perhaps fix the issue (hopefully)…

Leave your S1 devices powered off. Whatever you do, do not add, or upgrade, them to S2 at this point, that’s referring to those speakers that are S2 compatible. (It’s not clear if you may have done this already, but let’s see …)

Reset your Sonos S2 App and Factory reset your Roam and just setup that speaker on its own by choosing to "create a new Sonos System" and let it check for any updates.

When that’s all sorted then power on your S1 devices (maybe just start with your Play:5 (gen1)  to begin with) and see if the S1 App works okay with that device.. then power on your other S1 devices and hopefully all should then be well, but that’s providing you have not inadvertently upgraded your old Play: 1 etc. to the S2 system, in which case you will need to report back here, as there might be a need to downgrade it back to S1 or update it to S2, whichever you prefer to do🤔?

Once everything is sorted, you should then be able to have your music services, like Apple Music installed to both your S1/S2 Apps. I suspect at some point you made one or two minor mistakes during your earlier steps, perhaps out of frustration and the above Roam/App ‘reset’ should ‘hopefully’ fix things for you.