Answered

Roam drop out on wifi and bluetooth

  • 2 June 2021
  • 7 replies
  • 182 views

My roam plays for 30-60 seconds then goes silent. It shows in the app as playing and the rest of the group continues to work fine.
 

It happens on Bluetooth and wifi and comes back to life again after a reboot (15 second press of the back button) but then goes silent again. 
 

I have spent two hours over two evenings with the online support who insisted it was a wifi issue and said they couldn’t help as I didnt have an Ethernet cable long enough to plug my router into the playbar 🤦🏻‍♂️ They have fobbed me off and said I need to call the helpline. They dismissed that it was a speaker fault even though the roam has the fault on Bluetooth and wifi and the rest of the system works fine. 
 

Has anyone else had the same??

icon

Best answer by Corry P 8 June 2021, 10:40

Hi @Jonbru 

So you were affected. OK, that issue has been resolved now, so you should be good to go wireless again, should you wish to.

That fix would not have helped matters on the Roam, however, so I’m now wondering if you ever got the fixed update for your router. Could you please log in to your router at http://192.168.1.254 and click on the Status section to check your router’s firmware version. If you don’t have v0.26.04.04227 or higher, please contact BT and ask them to push the update to your device. Thanks.

If the version is OK, please let me know here.

View original

7 replies

I’ve not had the same issues, the two Roam’s here are working okay on all connections.

However…

If your Sonos Roam has been setup on your routers (separate) 5Ghz WiFi band, perhaps switch it over to the available 2.4Ghz band and set it to use a non-overlapping WiFi channel, either 1, 6 or 11 and use a channel-width of 20MHz. You can switch a devices network connections via the Sonos App in "Settings/System/Network/Manage Networks/Update Networks”.

A Bluetooth signal also uses the 2.4Ghz wireless band, so I suggest trying all three channels (as suggested) on your router and see which one works best with your Roams Bluetooth connection too.
 

Your mobile controller will most probably still be able to use either the 2.4Ghz or 5Ghz band for it’s network connection.

Anyhow I hope that suggestion solves your issue, without having to resort to reducing wireless interference, as was being suggested, by setting up a SonosNet wired connection to your Playbar. In any event that only moves ‘other’ Sonos devices out the way, as the Roam does not use the SonosNet signal.

Userlevel 7
Badge +17

Hi @Jonbru 

Welcome to the Sonos Community!

Without using Bluetooth or grouping-in other speakers, will the Roam play without issue from a streaming service?

If that works, please try recreating the group but select the Living Room first, so it’s the leader of the group (Group Coordinator), include the Roam, and test.

If this works, I recommend not putting Kitchen in charge of the group (it may not be the fault of the Roam that the Roam is cutting out, but a limit of how many rooms the Kitchen unit can transmit to, given it’s current location).

I hope this helps.

Userlevel 7
Badge +17

However, as the Roam cuts out on Bluetooth (which could be unrelated), please try a reboot of the Roam - hold it’s power button for 12 seconds.

Hi Connor, 

 

I’ve tried that a few times but the same happens soon after. Even removed it and factory reset and added it to the system again 🤷🏼‍♂️

Userlevel 7
Badge +17

Hi @Jonbru 

OK, thanks for trying.

I can’t help but notice that you have a BT Smart Hub 2. Were you affected by the recent firmware issue that this device had? If so, was it resolved? Or is this the first you have heard of it?

How does the Roam behave when not part of a group?

The fix for the smart hub was to plug one of the surround speakers into the router. I didn’t realise there was such a widespread issue. 
 

The roam has the same issue stand along as when it’s in a group (on both wifi and Bluetooth) 

Userlevel 7
Badge +17

Hi @Jonbru 

So you were affected. OK, that issue has been resolved now, so you should be good to go wireless again, should you wish to.

That fix would not have helped matters on the Roam, however, so I’m now wondering if you ever got the fixed update for your router. Could you please log in to your router at http://192.168.1.254 and click on the Status section to check your router’s firmware version. If you don’t have v0.26.04.04227 or higher, please contact BT and ask them to push the update to your device. Thanks.

If the version is OK, please let me know here.

Reply