Answered

Problem with WiFi Setup - same SSID for 2.4Ghz/5GHz frequencies

  • 23 November 2021
  • 15 replies
  • 295 views

I have the following situation/problem:

 

My SONOS setup: I have a few SONOS devices (4 IKEA Symfonisk Bookshelf speaker, one Five, one One SL and one Roam). My problems are with the devices that can connect to the 5GHz WiFi frequency.

 

My WiFi setup: I have a big house, in order to have WiFi everywhere I use a Netgear Nighthawk MR60 mesh setup with one router and two satellites. One “feature” of this system is that the 2.4Ghz and the 5Ghz frequencies have the same SSID, which can’t be changed. Also, the 5Ghz frequency can’t be disabled. There is no AP isolation that I could change.

 

My problem: Since the 2.4Ghz and the 5Ghz frequencies have the same SSID I can’t manually assign a specific device to one or the other frequency. As soon as a SONOS device switches to the 5GHz frequency , it disappears from the SONOS app and can’t be reached. For the IKEA IKEA Symfonisk Bookshelf speakers this isn’t an issue since they only connect to the 2.4Ghz frequency. The Five and the One SL can be forced to connect to the 2.4GHz with some “clever” placement so the signal of the 2.4Ghz frequency is stronger. The Roam on the other hand is moved around the house quite frequently and connects to whatever signal is strongest. As stated above, once a device is on the 5GHz frequency, the SONOS app can’t reach it. Sometimes the device still show up but whenever I want to play something on it, it states that it can’t be reach, and sometimes the device disappears completely. But apart from that, the device works as intended. Through the Spotify app it can be reached and selected as a speaker, AirPlay 2 also works without any problems. Through the IKEA Home Smart App I can activate Scenes which include playback of a certain source, and it also works 

 

What I already tried: I tinkered with a lot of the settings for the router. I’ve tried (after reading a lot of articles here, on Reddit, and on the Netgear forum) changing settings for UPnP, DLNA, RIP version and direction. Nothing had a lasting effect.

 

What I ruled out: It doesn’t matter if the device is connected to a satellite or to the router - the problem is dependent on whether the device is connected to the 2.4GHz or the 5GHz frequency.

EDIT: Getting a SONOS Boost or connecting one speaker through Ethernet wouldn’t solve the problem since the Roam won’t connect to a SonosNet.

 

What I haven’t figured out completely: I am not 100% sure if it matters on what frequency the device with the SONOS app is. I have had situations where I knew my phone (iPhone) was on the 5GHz frequency and the SONOS app wasn’t able to connect to the Roam (which was on the 5GHz frequency at that time), while in other situations I knew it was on the 2.4GHz frequency and the SONOS app was nonetheless able to connect to the Roam (which was on the 5GHz frequency at that time).

 

I am at a loss. Apart from this issue, I am very happy with the SONOS setup and also with the Netgear MR60 system. If I could, I would rename or deactivate the 5GHz frequency, but I can’t. Does anyone have a solution or an idea I could try? Worst case scenario is that I need a new mesh system, but for that I would need the confirmation that the 2GHz/5GHz issue is strictly linked to the Netgear MR60 system and not a wider issue. Or get a router that can rename the 5GHz frequency.

 

Already in advance, thank you all for your input

icon

Best answer by ratty 23 November 2021, 14:08

View original

15 replies

Userlevel 7

Hi

I’m at the airport.  But here’s a quick answer to one of your queries. Setting up the SonosNet either with a Boost or wiring a speaker to your main router would work. The Roam would just connect to your WiFi. I have the same setup in my home. Boost for all other Sonos with Roam connecting to WiFi. 

Thank you for your reply. I have considered that, but from what I see it wouldn’t change the issues I have with the Roam (as you said). If it’s the only solution available I am certainly willing to go that route, but I do use the roam frequently and it’s where the problem is most pronounced sadly. 

Userlevel 7
Badge +20

Thinking logically. the only way that I can think of achieving this is by forcing a 2.4 connection by reducing the number of mesh devices and so weaken the wi-fi strength - not ideal I know! :nerd: The obvious issue being that even if this did work by relying upon the greater range of 2.4 vs 5, is that moving the Roam closer to a mesh node would negate this approach.  I had lots of similar issues with Goggle Wi-fi mesh, along with the inability to fix a specific wi-fi channel, and got rid of them in the end.

 

Thank you for your reply - you’re absolutely right that it would help some but is far from ideal, since there are (obviously) other devices on the network… 

The advice under your post seems much more attractive ;-)

Inherently there’s no problem whatsoever with Sonos devices on any WiFi band (or SonosNet) being seen by a controller on any band.

If players are going missing it would be worth noting what the controller is connected to at the time, and the same for the players. A pattern may emerge.

The blocking of SSDP discovery multicasts/broadcasts is a not uncommon problem with certain network kit, particularly between WiFi bands.

I have the same issue.  The two roam I have connect to the 5 Ghz network and are invisible on the app.  It is indeed a frustrating problem making the two Roams I have useless as part of the system.   When I turn them off they appear on the app as offline.   So the system know they are connected but they do not show on the app.  I am considering returning them as they are not fit for purpose.

I have the same issue.  The two roam I have connect to the 5 Ghz network and are invisible on the app.  It is indeed a frustrating problem making the two Roams I have useless as part of the system.   When I turn them off they appear on the app as offline.   So the system know they are connected but they do not show on the app.  I am considering returning them as they are not fit for purpose.

If the Roams can’t be discovered by the controller when they’re on the 5GHz band it’s the router that’s not fit for purpose. The Roams themselves aren't at fault.

 

I have the same issue.  The two roam I have connect to the 5 Ghz network and are invisible on the app.  It is indeed a frustrating problem making the two Roams I have useless as part of the system.   When I turn them off they appear on the app as offline.   So the system know they are connected but they do not show on the app.  I am considering returning them as they are not fit for purpose.

If the Roams can’t be discovered by the controller when they’re on the 5GHz band it’s the router that’s not fit for purpose. The Roams themselves aren't at fault.

Indeed.  Designing a mesh system that doesn’t allow the two bands to have separate SSIDs AND blocks multicast broadcasts between bands takes a special kind of incompetence. 

This is getting a bit desperate, but could one wire a cheapish access point off each of the mesh nodes, with different SSID from the mesh, DHCP off, 5GHz band disabled.  Run Sonos in SonosNet mode, remove the mesh WiFi details from Sonos and add the AP SSID.

I think you might have to force the controller to connect to 2.4GHz, and that may be impossible

I really don’t know if that could work.  But I am confident that @ratty will know!

The desperate arrangement could well work, and the extra AP ought to be able to operate on either band.

As far as the mesh is concerned all the Sonos devices and controllers would be on the wired segment:

  1. either over SonosNet and through the wired Sonos component
  2. or over WiFi and through the wired AP

Thanks for commenting, @ratty .

I not sure why you say the router is the issue, the router could see the Roams in the list of devices, the roams are therefore connected to the network.   It the app that does not display them even though it seems the app knows they are online.  When I turn the roams off- they then appear in the app as offline and when I turn them back on they disappear from the app.   I spent 4 hours tinkering with them yesterday, factory resetting them three times and add them to the system and turning the router off and on as directed.  Each time they would connect to the 5 ghz band.  I moved them closer to the router and further away.  Used the support screen to discover missing devices - all to no avail.   

 

Today I turned on the system, did a search for missing devices and hey presto both Roams appear and can be connected to the system and stayed stable all day.   The roams are now on the 2.4hgz band with the rest of the system and I did NOTHING else other than ran the FIND MISSING PRODUCTS under the support tab.   I did that twice yesterday and it did nothing to solve the issue.  My phone and ipad are still on the 5 ghz band and can control all the components.    A complete mystery what and how they changed bands but I am a happy camper

I not sure why you say the router is the issue

Because it doesn’t appear to forward discovery traffic reliably between the different network segments. This requires subnet-wide multicast/broadcast coverage.

The devices can be sitting happily on the network, visible to the router, but if the discovery packets from the controller don’t get through it won’t be able to locate them.

I invested in a sophisticated mesh network router to avoid these types of issues,  What I don’t understand is why when I turned the roams off, they went ‘offline’.   That suggested some message was making through to the app from the router.   I also don’t understand why they swapped bands when I rediscovered them the 4th time.   I also did some investigation in to my router and it has the capability name each band separately.  So if this happens again, I will renamed the bands separately to re attach the roams back to the 2.4 ghz band.  For now, they have stayed overnight on the 2.4 ghz band and work seamlessly.  Thanks for your advice and patience

I invested in a sophisticated mesh network router to avoid these types of issues, 

Sophisticated (expensive) or not, meshes are primarily designed to get fast internet into all corners of the house, rather than providing seamless intra-network connectivity. 

 

What I don’t understand is why when I turned the roams off, they went ‘offline’.   That suggested some message was making through to the app from the router.   

That was because the players maintain a unicast (1-to-1) connection to the controller after discovery. Discovery requires multicast and/or broadcast.

 

I also don’t understand why they swapped bands when I rediscovered them the 4th time.  

When they boot, the Roams would choose what they think is the best WiFi connection. This could change depending on local conditions. 

 

I also did some investigation in to my router and it has the capability name each band separately.  So if this happens again, I will renamed the bands separately to re attach the roams back to the 2.4 ghz band. 

This would be a good strategy. Naming the bands differently offers more control. 

Reply