Answered

Problem with Sonos Play1 and Ubiquiti UAP/ Switch

  • 7 January 2020
  • 7 replies
  • 1670 views

Hi,

 

I am having huge issues connecting with my iOS Sonos Controller to my Sonos Play1 speakers after recently installing a new Ubiquiti Unifi Access Point. I have spent days not trying to get the Sonos Play1 speakers to connect.

 

I have attempted the following.

  1. Changed RSTP to STP for the UAP port
  2. Enable Multicast Enhancement (Disabled and Enabled No difference)
  3. Combine Name/SSID (Disabled and Enabled No difference)

  4. Enable Multicast and Broadcast Filtering (Excluded MAC address for Sonos Play1 devices)

  5. Enable IGMP Snooping (Enabled/Disabled No Difference)

  6. STP with Priority 4096

 

Despite trying all of this I have not been able to connect to the Sonos Play1 without physically attaching a cable directly to a Play1 device. I am aware that I can use the SonosNet if I hard wire a device but I want to run the devices in Standard Mode over WiFi.

 

Why doesn’t this work?

 

All clients are on the same network/vlan as the Sonos devices and I still can’t connect?

 

Please help...

 

 

 

icon

Best answer by myatix 8 January 2020, 10:02

Hi Again,

I have been troubleshooting this issue further and have found the following:

  1. If you enable “Multicast and Broadcast Filtering” you must create an exclusion for all Sonos devices and any device used to connect to the Sonos device. (EG: iPhone, iPad etc) (Settings>WIFI>Multicast and Broadcast Filtering)
  2. You must “Enable IGMP Snooping” at the network level. (Settings>Network>Enable IGMP Snooping)
  3. If you are using stacked switches or using a Spanning Tree Protocol then you will need to change from RSTP to STP and set the priority to 4096.

I hope this helps others with any issues encountered while setting up a Ubiquiti network.

 

View original

7 replies

Userlevel 7
Badge +21

Try turning off AirTime Fairness in the AP.

I decided I wanted to use all the Ubiquity WiFi goodies and moved my Sonos stuff to wired / Boost mode so there are no restrictions on my home WiFi setup. You may need to tweak STP settings if you have smart switches and wire more than one Sonos. I wired all the easy ones here and stability went up.

Hi Stanley,

Thanks for the reply! :)

I have read numerous posts including a few recent posts about getting Sonos speakers to work on enterprise level equipment. As far as I can see this is a big issue with a large number of users. What I don’t understand is why Sonos doesn’t come out with some official guidance on this. It also seems like it isn’t just Ubiquiti hardware but also Cisco.

Have spent a fair bit of money on Sonos and a high end network setup you would expect Sonos to step into the ring.

AirTime Fairness is a Unifi Security Gateway feature and not a AP feature as far as I am aware on the Ubiquiti Unifi setup. I don’t have a USG so this is not a solution for me.

The main point here is that if Denon and Bluesound all work with enterprise level managed switches why doesn’t Sonos.

My network consist of a single AP and 1 Unifi 16 port PoE Switch, nothing complex at all so it should work.

Any other tips other than using SonosNet (Hardwiring the speakers) would be appreciated.

Thanks for any advice. :)

 

Hi Again,

I have been troubleshooting this issue further and have found the following:

  1. If you enable “Multicast and Broadcast Filtering” you must create an exclusion for all Sonos devices and any device used to connect to the Sonos device. (EG: iPhone, iPad etc) (Settings>WIFI>Multicast and Broadcast Filtering)
  2. You must “Enable IGMP Snooping” at the network level. (Settings>Network>Enable IGMP Snooping)
  3. If you are using stacked switches or using a Spanning Tree Protocol then you will need to change from RSTP to STP and set the priority to 4096.

I hope this helps others with any issues encountered while setting up a Ubiquiti network.

 

Userlevel 7
Badge +21

I was sure I’d had to disable Airtime Fairness on my Ubiquity AP to get it to work with Sonos, it was even in my setup notes. Um, old notes apparently as I see nothing about it since about 2017. Back then the UAP-AC-Lite/LR/Pro supported Airtime Fairness. I sure can’t find it in the CloudKey Controller today.

https://satheesh.net/2017/02/05/how-to-enable-airtime-fairness-on-ubiquiti-unifi-aps/

It is still in their Dec. 2019 “Unify Network” Android app under the AP device’s settings menu.

 

Userlevel 7
Badge +21

Had some spare time and went looking for the Airtime Fairness settings in Ubiquity Unifi APs on a Cloud Controller. They have been moved off to the “you probably don’t want to do this” section of the setup. For happy Sonos you want this to remain disabled.

https://172.16.1.30:8443/manage/site/default/v2/settings/network/advanced

 

 

Moved to a new house. Worked prior to move on unifi. Factory reset sonos play 1. will not connect to Telus wifi hub nor will it connect to my unifi 3ap system which it did before. Tried the settings still will not connect. Fails after you type the password for your wifi. any help would be great

 

Userlevel 3
Badge +10

Hi @Jgood.

Welcome, thank you for reaching out to Sonos Community.

Have you already tried to hardwire the Play:1 directly to the modem since you already tried factory data reset?

Once you manage to add the product again, you need to set up the speaker wirelessly again Go to Settings » System » Network » Wireless Setup.

Let us know if it works. If you need help with any other information, please be sure to let us know.

Reply