Answered

“Not available” message adjusting volume on Samsung TV after using Sonos app to setup my new Spectrum remote

  • 31 March 2022
  • 7 replies
  • 132 views

Hello - I am having the issue above after setting up a new Spectrum remote UR5U-8780L with my Sonos Playbar.  

I used the Sonos app to setup remote control, and everything is working great. However, when I adjust the volume +/- or mute using the Spectrum remote, the volume adjusts but I also get the message “not available” from the Samsung TV.  I want to get rid of that message.  

This post from a few years ago describes the issue perfectly and provides a link to FAQ to fix, but the link no longer works - can the correct FAQ link please be provided?
”Hello, The message is popping up because the TV is still receiving the IR signal from your remote to adjust the volume, but the speakers are disabled so it's giving an error message of sorts. There are ways to bypass this on-screen message by using a cable/satellite TV remote or a third-party TV remote programmed to adjust just the PLAYBAR's volume but not the televisions. I'd suggest taking a look at the following FAQs to see if you have an available remote you can prhttps://sonos.custhelp.com/app/answers/detail/a_id/2083”

Thanks!
Catherine 

icon

Best answer by Ken_Griffiths 31 March 2022, 19:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

I’m not entirely sure, but perhaps see if this Support page may assist you…

https://support.sonos.com/s/article/2413

@Cnhnyc
The post from Ryan E you are referring to, I believe, was suggesting to use/train the old Playbar with a separate 3rd-party ‘remote’ that is unrelated to the TV itself and then the messages would not appear on screen, but it would adjust the volume of the Playbar.

So if you do have another IR ‘remote’ to hand, then perhaps try that instead to adjust volume and then use the Spectrum TV ‘remote’ for every other function.

I’m not entirely sure, but perhaps see if this Support page may assist you…

https://support.sonos.com/s/article/2413

Thanks for the link, @Ken_Griffiths , but that article doesn’t apply - I’m trying to correct the programming on the UR5U-8780L universal remote I got from my cable provider, Spectrum. The article you posted is for programming a Samsung remote.

I need a way to make the Spectrum UR5U-8780L *not* send volume control signals to the Samsung TV.  It is doing everything else right, including adjusting/muting the Sonos Playbar volume.  The problem is, it is *simultaneously* sending the volume commands to the Samsung TV, causing it to show the “Not available” error message as the Samsung TV is set to use “External Speakers” (in this case, the Sonos Playbar)

I’m not entirely sure, but perhaps see if this Support page may assist you…

https://support.sonos.com/s/article/2413

Thanks for the link, @Ken_Griffiths , but that article doesn’t apply - I’m trying to correct the programming on the UR5U-8780L universal remote I got from my cable provider, Spectrum. The article you posted is for programming a Samsung remote.

I need a way to make the Spectrum UR5U-8780L *not* send volume control signals to the Samsung TV.  It is doing everything else right, including adjusting/muting the Sonos Playbar volume.  The problem is, it is *simultaneously* sending the volume commands to the Samsung TV, causing it to show the “Not available” error message as the Samsung TV is set to use “External Speakers” (in this case, the Sonos Playbar)

The post from Ryan E, as briefly mentioned, is suggesting to use a non-TV remote (one that is not programmed to control the TV) and setup that as an entirely separate remote to just control the volume of the Playbar only (and not the TV volume) - alternatively you could perhaps speak to the Samsung support desk to see if there is any other way to switch off the messages on their TV, perhaps via an Engineers menu option etc.

There is another solution that’s a little more palatable: run the Sonos “Remote Control Setup” in System setting in the Sonos app, and then make your cable remote learn the 3 digit code for another  (“incorrect”) manufacturer’s TV model. Only downside is that now you can’t turn your TV on/off with the Spectrum cable remote.  That’s at least a little better - i turn the TV on/off much less than I adjust/mute the volume.

I’m also in touch w Samsung to see if I can brute force suppress the “not available” message.  I’m at an old firmware level, so I’m going to upgrade that first and see if it presents such an option.

I think the bug lies with Sonos.  When it learns the TV remote and enables it to control Sonos, it should “turn off” the attempts to control the volume with the TV speakers and only use the Sonos play bar (known to the TV as “external speakers”).  

I’ll keep plugging away! 

 

I think the bug lies with Sonos.  When it learns the TV remote and enables it to control Sonos, it should “turn off” the attempts to control the volume with the TV speakers and only use the Sonos play bar (known to the TV as “extern7al speakers”).  

I’ll keep plugging away! 

I don't see how this could be a Sonos bug.  It's an IR 'line of sight' remote. How could it send a code just to the Playbar and not the TV? 

It is up to the TV to do something sensible when asked to change volume on speakers that have been disabled.  Your TV does something stupid instead (as does mine)..

I have found a solution to the message coming up on my Panasonic TV. I just ignore it and don't let it bother me.

Other options are using the Sonos App or voice control.

@Cnhnyc,

I’m just a Sonos user like yourself and just trying to help, but I do agree with @John B.

I read through some of the various threads here on your issue and it appears Samsung choose to display the OSD message on some models of their TV when the internal TV speakers are disabled - it’s not something Sonos are in a position to fix, but it’s a either a case of using a different ‘remote’ to control the Playbar volume, live with the OSD message, or as I suggested, perhaps see if Samsung Support can offer some other solution for your particular model of TV. 

Anyhow, hope you’re able to find a satisfactory resolution to the issue.