Answered

No audio eARC Hisense U8g Sonos Arc

  • 30 May 2022
  • 4 replies
  • 447 views

Have a brand new U8g and nothing else but Sonos Arc attached via HDMI eARC. S2 App shows checkmark for HDMI ARC connection, but the audio test fails. Both U8g and Sonos Arc firmwares are updated. 
Optical works, but I want sound with ATMOS via eARC.

Also the U8g menu items for selecting ARC output are grayed out in the tv settings. Can only select tv speaker as output. It seems there may be bad CEC communication as I noticed if I disable CEC on U8g that the ARC output option can be selected, but it goes right back to grayed out after changing menus.
Any ideas would be appreciated. 
Would a CEC Less adapter force the tv to be able to use ARC for audio out? 

icon

Best answer by controlav 30 May 2022, 17:16

View original

4 replies

Userlevel 7

Are you using any external media devices? If not, have you tried disabling eARC on the TV?

Are you using the Sonos-supplied HDMI cable to connect the Arc to the TV?

Userlevel 7
Badge +22

Based on https://www.rtings.com/tv/reviews/hisense/u8g :

Connect the Arc to HDMI 3, it is the only eARC port.

“ The setting Digital Audio Out has to be set to 'Pass Through' for it to work. “

Make sure the TV firmware is up to date.

Thank you so much for the tips. Controlav’s tip did it.

I had tried everything else you mentioned except port 3,

Once I plugged it into the eARC port it worked. I now get Atmos displayed in the S2 app when playing compatible content. U8g audio out now shows eARC as well.

Thanks again.

Here’s a few things I’ve noticed.

1-If the Apple TV 4K goes to sleep eARC connection is lost. So I disabled sleep function on ATV.
2- One way to solve sound dropout was go to the back of tv while everything was on and unplug and replug the ATV HDMI cable.

3-I got tired of that! So I found that by going to the Hisense U8G sound menus I could toggle the eARC enable to off. Then wait for the DD logo to appear, then re-enable the eARC feature. This re-established the eARC connection. For now though, with ATV sleep disabled the sound is stable. I can switch between ATMOS and non ATMOS content no problem.l

Reply