Answered

Music streamed on Playbar keeps on cutting out

  • 2 August 2022
  • 1 reply
  • 36 views

I recently acquired a Playbar and have added it to my Sonos setup (1x Move, 2x Symfonisk bookshelves, 1x Symfonisk lamp)

After installation I noticed that its sound was often cutting out when listening to music streamed over the WiFi (whether from my router or in a wired network).

After several hours of problem-solving I realized this is happening only when the optical cable is plugged in at both ends (source + Playbar) - even if no data should be flowing in the cable (the source is off).

If I unplug the optical cable at the source end and leave it plugged in the Playbar, the sound is never cut.

“TV Autoplay” is disabled in the App.

Cuts come randomly (so far at intervals ranging from 40s to 4 mins) and always last about 11 seconds before music resumes. No other Sonos product is interrupted.

This is pretty annoying. I wouldn’t like to have to unplug/plug the optical cable each time I switch the audio source. And even if the source were sending data through the optical cable, I should be able to keep on playing what’s streaming from Spotify over the network without interruption…

Any idea what’s going there and how to fix it? Thanks

EDIT: This seems to be a similar issue to the one reported in the thread below. However my source is a Pioneer DJM-900NXS mixer, not a Sony TV…
 

 

icon

Best answer by Ken_Griffiths 3 August 2022, 00:08

View original

1 reply

@BlueSun,
As you have already tried to troubleshoot the issue for several hours and have presumably power-cycled your devices (Router/Playbar etc.) and tried the Playbar both connected over wireless and wired ethernet. It is the case that it’s not entirely clear why the optical audio connection is having any bearing at all on the streaming music source playing either over WiFi or Ethernet to the Playbar.

I don’t personally think the thread you linked to in your post is related to your reported issue, as that looks like it was mainly to do with the Sony IP Control protocol, which has been mentioned in the community here before and I’m struggling to see the connection between that and your Pioneer mixer at the present moment.

However, as your troubleshooting has led you to be somewhat certain it is related to the optical connection, then I think it’s perhaps best to take a few Sonos system diagnostic reports. Obtain diagnostics with the optical connected to your ‘mixer’ and suffering the audio interruptions and others with the optical cable disconnected and playing the same streaming source without the interruptions.

I would also obtain the diagnostic reports whilst the Playbar is connected to the LAN over WiFi and whilst it’s connected over Ethernet aswell.

Make a note of all the diagnostic references gathered and then contact Sonos Support via this LINK to see if the Staff can see anything obvious in the gathered data and see what the Staff can suggest.

Reply