Answered

Music Stops with new router

  • 30 November 2020
  • 11 replies
  • 182 views

Hi all,

I recently purchase a new router D-Link DIR-X1560 with WiFi 6 function. I set it up smoothly, and all the speaks (2x ONE and SYMFONISK) can be found and given IP address from the router setting App.

When I tired to play music through spotify, music often stopped for a few minutes played, and Sonos app often shown “Unable to connected to Sonos”. 

I am wondering this is due to the router can automatically switches between 2.4 and 5 GHz. I turned off this function and separated 2.4 and 5 GHz as different SSID/Pw, but it doesn't seem working. 

I am wondering is any extra setting for router that I can solve this problem, eg, DHCP, Vlan Bridge, etc.?

 

Thanks, 

 

icon

Best answer by ClausN 1 December 2020, 12:18

I agree with @UKMedia that this could be caused by interference. Did you also try channel 1 and 11, not only 6?

Music stopping is not caused by the phone losing wifi connection, as the phone only acts as a remote, but rather the speaker losing wifi connection.

Refreshing your system might prove to be helpful: power off all Sonos, restart router and wait for it to come back before powering up Sonos. If this helps, I recommend setting fixed IP addresses for Sonos in the routers DHCP table.

I’m not familiar with wifi 6 technology, there could be other trials to consider.

If everything else fails submit a diagnostic within 10 minutes after the music stops and post the number here for a Sonos representative to look into it, or call Sonos Support to discuss the diagnostic.

View original

11 replies

Userlevel 7
Badge +20

I wonder if you’re getting wi-fi interference from your new router, take a look at these steps.

Maybe interference is not the case here. I have tried to set the router to 2.4 GHz at Channel 6, but it still have the same problem. Music stopped playing and Sonos app on my iPhone showed cannot find any speakers.

Userlevel 7
Badge +20

When this happens, can you check if your phone is still connected to your wi-fi.

I agree with @UKMedia that this could be caused by interference. Did you also try channel 1 and 11, not only 6?

Music stopping is not caused by the phone losing wifi connection, as the phone only acts as a remote, but rather the speaker losing wifi connection.

Refreshing your system might prove to be helpful: power off all Sonos, restart router and wait for it to come back before powering up Sonos. If this helps, I recommend setting fixed IP addresses for Sonos in the routers DHCP table.

I’m not familiar with wifi 6 technology, there could be other trials to consider.

If everything else fails submit a diagnostic within 10 minutes after the music stops and post the number here for a Sonos representative to look into it, or call Sonos Support to discuss the diagnostic.

Strangely, My older router DIR-655 (also from D-link) till last week did not seem to have this problem. 

I have tried switch in between channel 1, 6 and 11, and even set 2.4GHz to setting to 20MHz only to emulate the old router. I also played around of WPA standard and 802.11 mode. None of this above worked. I am wondering is it because of wifi environment is very crowded from my neighbour apartments?

Here is how inSSIDer shows and it seems very busy around...
Seem like channel 1 and 11 are very occupied. Which channel would you suggest that I can use? ("404 Page Not Found" is mine)

Userlevel 7
Badge +20

It would be useful to submit a diagnostic and post the number in this thread.

Did you refresh as advised in my first post?

Userlevel 7
Badge +20

To further explain the advice from @ClausN , please see my post here.

I have tried what you both suggested. It is not working.

As here, all the devices are assigned to specific IP, and I reboot router and all the devices connected to wifi

 

*Moderator Note: Please censor personal information when posting pictures.*

 

I sent many diagnostic, but never got replied. 

Number: 756338602 and 1046702765

Hi there,

I have the exact same problem like you.  I have a Symfonisk and a DIR X1560.  The Symfonisk works perfect my old router but stop work with the DIR X1560.  Contact Sonos and Dlink support many times for help but no solution so far.  

Reply