Answered

Music Library not connecting after updating from windows 10 to 11

  • 28 November 2021
  • 5 replies
  • 200 views

Prior to upgrading windows 10 to 11 Sonos connected to music library on pc, after upgrade would not connect, removed music library connection, ensured SMB sharing modules enable, shared music library folders with “sonos wifi” all without any error, when I tried to connect to music library via desktop app I receive an error “error adding music (big red X) sonos was unable to add the music folder, reason: the computer (pc name) is not responding”. I checked to make sure sonos.exe was allowed in the firewall rules.

I started a chat with support and once I explained the problem they pulled the connection, anyone have any suggestions, it would be appreciated.

icon

Best answer by Ironmaiden 28 November 2021, 04:02

View original

5 replies

Userlevel 5
Badge +9

Do you have the Sonos desktop app installed on your PC?  If not, install it and add your music library there from the desktop app.  It will make all the firewall changes needed. Then the phone app will find it.  That’s what did it for me on my Windows 11 install.  Also no need to share folders with the name “Sonos wifi”.  Just share the folders in windows.  No need to create a name or separate user.   Then let the desktop app do the rest.  

Hi Thanks for the reply, I am using the desktop app, so I downloaded the latest version and did a reinstall, shared the music folder with everyone and still got the same error, so I disabled my firewall (Bitdefender Total Security) and was able to add the music folder, so it looks like the offender is the Bitdefender Firewall, I have exception rules in the firewall for sonos.exe and sonosdesktopcontroller.exe, yet when I turn the firewall back I cant see the music folder from the sonos app, I will have to work my way through this to find out what tweaking is needed to the firewall rules.

Userlevel 7
Badge +22

Not related to your issue, but do not change the Windows defaults for SMB settings. Allowing insecure SMB is not required when sharing directly from a Windows device: it is only required on NAS devices.

I finally found the cause of the problem, in Bitdefender Total Security I had to change the “Network Adapters” setting from “Dynamic Network” to “Home Office Network”.

Thanks Ironmaiden!  You saved me hours on the phone with tech support to figure out another tech glitch.  Bitdefender is great but I had to search for where the settings were in Internet Security to flip it to Home.  Problem solved!

I’m in my early 60s and although terrific sound the setup and unique are just far too complex for the average user.  I honestly can’t recommend Sonos anymore, especially since they offshored tech support.  Sad.

Reply