Music library index fails on new NAS

  • 14 June 2022
  • 5 replies

For years my Sonos setup has been pulling music from a QNAP NAS device. The QNAP recently wore out and I replaced it with a Synology device. Sonos is having some trouble with it.

I go to the Sonos controller settings, type in the path to the shared NAS folder, and Sonos begins indexing. It seems to be indexing for five or ten minutes, and then it errors out saying the folder is no longer available (screenshot below.) It’s done that four times now.

Near as I can tell the NAS device is doing just fine. I can, for example, reliably browse to the shared folder in the Windows File Explorer. But Sonos keeps deciding the connection has dropped. What’s causing that?


---- DETAILS -----

I am running the Sonos controller version 14.8 on Windows 10

Sonos OS: S2

My main Sonos device is a Connect (hardware version; series ID D100)

The music files are located on a Synology DS220+ NAS device.

The NAS is sharing, I believe, with SMB. It supports SMB 2 and 3.

And this is the specific error I keep getting:




Best answer by Airgetlam 14 June 2022, 17:38

View original

5 replies

I can't immediately tell whether that's a Connect gen 1 or gen 2. Note that Sonos S1 can only support SMBv1. 

But, as you state you’re running S2, and it is starting the processing of the library, and then eventually failing, I’d be looking initially at network disruption issues.

For instance, a simple duplicate IP address issue might manifest in exactly the symptoms your describing, as the Sonos device gets bumped off of the network while communicating with the Synology.

Perhaps a diagnostic, submitted after that failure point, followed by a call to Sonos support would have additional data in it to suggest why the failure has occurred. I’m frequently skeptical of the error codes shown. While they’re often spot on, they’re also occasionally more generic than I’d like. 

But, as you state you’re running S2, 

Oops, missed that. Thanks Bruce. 



> network disruption issues

Could be. It’s on a small home network where Sonos had no trouble with the QNAP previous device, so it feels more like a device problem to me. I’ve set the Synology device to use static IPs and there are only about ten devices on the network, so I think IP collision is unlikely. But I’m not expert. I will take your advice to reproduce, submit a diagnostic, and contact Sonos support. Thank you.


Just to add, as I had the same issue and opened a call with Sonos support. They mentioned that is must be a permission issue on my network. I removed the linked NAS drive and though hit this issue but could not connect back to Sonos. As I had a VPN locally running on the laptop I switched that off. Now I was able to add the connection, but still when I started the indexing I got this error. I created a second folder and started indexing and hat worked on a smaller set of data. So Sonos recommended to use this new folder instead. I was not convinced that the error is really stating the actual issue as the connection was there and no permission issue at all. 
I have now followed their approach and synced my whole system and it took 3 days. I did it in small chunks of 10-20 folders at a time and then started the indexing for each chunk. On many occasions I got this error and saw that the files were not in Sonos. When I just restarted the indexing over and over it eventually worked and I could see the files in Sonos. So obviously this error message is clearly not stating the actual problem.
Speaking back with Sonos support I mentioned my findings and the eventually agreed. They would need to improve their software and either show a list of files which is about to get indexed and / or show the actual issue as to why it is raising this error. 
To me the developer did not a good job in specifying the error and also to show some additional diagnostics when the error appears. Sonos support said that there is no further details on the submitted diagnostics and they cannot switch on any further “debugging” settings to show more details.