Most of devices missing

  • 10 December 2020
  • 4 replies
  • 97 views

Userlevel 1
Badge +5

Most of my devices (6 of 😎 are gone from my system and l can't get them back.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +21

If using iOS, try my app (see profile). It will find all Sonos devices on your network, both S1 and S2, and can even detect factory-reset and recycle-bricked devices (if wired). That might help the diagnosis.

Userlevel 1
Badge +5

We are going to need some more information to be able to help! 

1/ Has anything changed in your network?

2/ Do you have any sonos device connected via an ethernet cable?

3/ What version of the app do you have - S1 or S2?

4/ What devices have disappeared and which are visible?

Thanks for responding. I appreciate the help and advice you can offer.

My network has not changed in over a year (except for devices going missing). I've only had the Beam going for the past for five months until this morning. Today my surrounds and sub returned (I noticed the app was updated to allow 2 subs).

The Boost is connected via Ethernet.

I'm running S2 (version 12.2.2).

Boost and Beam have shown up consistently. As of today the the surrounds (Play 1) and Sub are showing. Four Ports arre missing.

A quick fix may be to refresh your system as described in this great article, in fact written by @UKMedia:

Reboot your network in this order:

  • Router
  • Any wired Network devices or switches;
  • Any other wired devices;
  • All other Wi-Fi devices (Turning Wi-Fi off and on again on each device would also work)

If the reboot solves the problem you can minimise the risk of it occuring again by reserving IP addresses, as also described in the article.

Userlevel 7
Badge +20

We are going to need some more information to be able to help! 

1/ Has anything changed in your network?

2/ Do you have any sonos device connected via an ethernet cable?

3/ What version of the app do you have - S1 or S2?

4/ What devices have disappeared and which are visible?