Question

Mixcloud connection lost

  • 18 October 2020
  • 5 replies
  • 49 views

Mixcloud connection keeps getting lost or is unable to connect. Not a new problem but getting worse.

Diagnostics: 904598337


5 replies

I have the same issue. I don't know when it started because I haven't listened to mixcloud in a while on Sonos, but I do know that yesterday and today I cannot get mixcloud to play at all  via Sonos. I keep getting a message "the connection to mixcloud is lost". 

Userlevel 3
Badge +8

​Hi folks, 

@dckluth , welcome to the Sonos community, and thank you for submitting the diagnostic.

Upon checking the diagnostic, there’s a network-related issue in your Sonos system. This usually caused by network communication, either between Sonos devices and your router or between Sonos and the internet.

@jpdudley, thank you for reaching back to us.

We greatly appreciate you being a part of the Sonos family. It is our pleasure. Let me ask to ask a few questions and will give some suggestions on what you can follow.

Have you tried to remove and re-dd the music service in the Sonos app?
Do you experience the same if you play music directly from the Mixcloud app? How about from the Mixcloud website?

If the issue persists, the streaming connection between Sonos and Mixcloud is unstable. My suggestion would be to try to change the Sonosnet Channel from 11 to 6 and 1. Make sure that you play music to one room only. After those options and still the same, disconnect all the Sonos devices and router from the power, wait for 5-10 seconds then reconnect the router back to power. Once the internet is back, connect all the Sonos to power then observe.

if you’re still getting the same issue, please submit a diagnostic report of your system and reply to us with the confirmation number. 

We and the community are always here to help.

Hi,

I a also having the same problem and it has been going on for a couple of months now. It will be ok for a couple of days hen it reverts to not playing. One it looses connection on one mix, it then can’t play any other in the list saying they are either not decoded properly or just lost connection. This can happen when it has just been playing that exact mix!

 

I have removed and added the service numerous times & re-authorised the account several times. Everything is fine if I play from the Mixcloud app or the website. I am only playing in one room. Do I need to try and reset the Sonosnet Channel as described above?

Many thanks

A-M 

I’ve been getting the same issue more and more frequently lately. It also started a few months ago and has been getting progressively worse. I haven’t tried re-authorizing yet, but I have disconnected everything from power and reconnected it. It doesn’t happen with any other streaming service, so I’m convinced is a Sonos/Mixcloud thing instead of an internet/wifi thing.

 

It happened just minutes ago. I was listening to a Mixcloud podcast on all speakers. I pause due to receiving a phone call. After the call I try to resume and get the “Unable to play ‘<podcast name>’ - the connection to Mixcloud was lost” message. Now nothing from Mixcloud will play.

 

Diagnostic report: 878210720

Userlevel 6
Badge +13

Apparently Sonos have listed Mixcloud as not working at the moment..

Just been messing about with my router but it's a Mixcloud/ Sonos issue..

Reply