Answered

Macbook Migration

  • 27 October 2021
  • 10 replies
  • 82 views

I’ve just migrated my files to a new MacBook M1. Sonos can see all the titles in my music library, but won’t play them because it says the server can’t be found. I don’t get it?

icon

Best answer by Corry P 4 November 2021, 10:43

View original

10 replies

Userlevel 7

On your MacBook, under System Preferences > Sharing, have you added your Music folder to the “Shared Folders”?

Hi, thanks for the help.

Yes, file sharing for SonosDMS (Read-only) is in place. Tried allowing Read/Write but then when I try to re-add the Music Folder, Sonos adds another Read-Only, then deletes the Read/Write entry

I’ve also deleted and recreated the Sonos folder in the Shared user profile

Rebooted

Tried deleting and re-adding My Music Folder  in the Sonos Music Library Settings

Tried adding my Music folder by navigating to the filepath. Still says it can’t locate <MyComputerName> If the Sonos app can navigate to the file path, why can’t it see the file path when I ask it to play?

It is driving me nuts

Userlevel 7
Badge +22

Tried adding my Music folder by navigating to the filepath. Still says it can’t locate <MyComputerName> If the Sonos app can navigate to the file path, why can’t it see the file path when I ask it to play?

It is driving me nuts

There are two very different code paths here: when in the Mac app, it can see your files because they are right there, on the same machine. When you play a file though, it is the speaker that reads the file, over the network, and that is broken for you. The Mac app does NOT participate at all in music playback, its just a remote control.

Thanks, that’s cleared up one frustration.

Do you have a suggestion as to how I can let my speaker see the source, please?

Userlevel 7
Badge +22

Thanks, that’s cleared up one frustration.

Do you have a suggestion as to how I can let my speaker see the source, please?

I don’t use my Mac for this, but if it was a PC I would say uninstall the Sonos app, disable any anti-virus/security nonsense, then re-install it. Then go and Add your directory to the Music Library in the Sonos app.

Thanks for the advice, but it IS a Mac.

I have already deleted and re-installed. I don’t wish to disable any of my antivirus/security “nonsense”. I just want this stupid piece of software to work like this is 2021, not the 1990’s. 

Userlevel 7
Badge +22

Hang on a second: you are running some “security” software? Now you tell us?? Sonos needs unfeterred access to the local network so your Mac can communicate with the speakers, and, more importantly, so your speakers can communicate with your Mac. Your “security” software is blocking this, because it is not very smart. You need to either disable it, or configure it to allow unfettered network access between your Mac and your Sonos devices. Think about it: how can a speaker read a music file from your Mac if your “security” software is blocking all inter-device networking, which is what most of them do.

Userlevel 7

Each to this own...but as a user of Windows and MacOS I find the need for 3rd party security software on a Mac a bit of over kill. Mac’s reset themselves and check for OS intrusions every time they boot. Then again you may be of the school of thought to never shut down your computer just let go to sleep. At most you might run a Malwarebytes scan on a weekly/monthly basis. BTW get the free version of Malwarebytes. 

Also, turn on the MacOS Firewall in Systems Preferences > Security & Privacy. While you’re in there make sure under Allow apps downloaded from > App Store and identified developers is selected.

Userlevel 7
Badge +17

Hi @MY HAIRY BUM 

Welcome to the Sonos Community!

If you are still having this problem, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

Right out of the blue, about 2 weeks ago, the issue fixed itself. And then right out of the blue today it forgot how to see my computer again.:rage:

 

Reply