I occasionally get a loud buzzing over the audio from Beam connected with HDMI



Show first post

114 replies

Userlevel 5
Badge +16

Hello @mgeis 

Thank you for reaching out with your diagnostic number and welcome to the Sonos Community.

I do see that your Sonos set-up does seem to be one speaker short of a 5.0 surround system. 

Can you check to see that both of your rear surround speakers are powered on and within 10-15 feet maximum of your Beam?

Does this audio issue persist if you switch your connection from HDMI/ARC to Optical?

 

Hello to you too @rixcc 

Since you have an LG tv, can you check to see if you have a “Quick Start+” option in your settings?

To disable Quick Start+ setting on the TV:
Settings -> All Settings -> General -> Quick Start+ (toggle to off)  

If you see this setting and can disable it, does this audio issue persist?

 

 

Userlevel 5
Badge +16

Hello @Vosabhoy,

I’m looking your system diagnostics back over. Your situation is a little bit different since you are using the optical adapter rather than the HDMI/ARC connection. 

Have you checked connection on the optical adapter itself to make sure that it is firmly plugged in on both ends and that the HDMI cable is firmly in the back of your Beam?

Does anything change if you move back over to the HDMI/ARC port rather than the optical connection? 

As I have suggested above, look for the “Quick Start” setting in your LG TV and be aware if your TV has any “Stand-By” or “Sleep Mode” settings that could be signaling to the Sonos Beam. 

Badge

Hi, I have disconnected the optical cable adaptor and the beam is connected via the HDMI - ARC. 

Hello @Jean C. 

I have disabled the Quick Start+ feature, but the problem persists.

So far, what has actually made the buzzing go away was to turn OFF eARC. Sound is still HDMI ARC, but there is an option to enable/disable ‘eARC’.

With eARC disabled, everything still seems to work fine. I’m just worried that I’m not getting the best possible sound quality. I am not sure it is making a difference in my case (please enlighten me), but I did read that eARC is basically an improved ARC that supports higher bandwidth.

Userlevel 5
Badge +16

Hello @Vosabhoy,

Thank you for the additional information. Your Beam is still reading as using the optical connection in your diagnostic reports. 

If your Beam is connecting via HDMI/ARC, can you check these settings in your Sonos app:

Settings → System → TV Room → Home Theater set-up.

This may force the Beam to recognize the HDMI/ARC connection formally.  

   

Userlevel 5
Badge +16

@rixcc, Thank you for the additional information.

eARC is only necessary if you have an Arc and were trying to support Atmos.

For Dolby Digital or stereo sound on your Beam, the HDMI/ARC is just right.

Badge

Checked settings...further diagnostic 1624290399. 

Userlevel 5
Badge +16

Thanks @Vosabhoy, I can see that your system is reading the HDMI-ARC connection now.

I’m re-reading to see if I suggested disabling any Quick Start+ options on your LG TV and I mentioned it to @rixcc but it should also be relevant to you since you have an LG also.

Some LG TV's have a "Quick Start+" features that has been observed and confirmed by LG that when enabled can cause unexpected audio for third party home theater devices. 
To disable Quick Start+ setting on the TV:
Settings -> All Settings -> General -> Quick Start+ (toggle to off)  

Let me know if you have already done this and if it has made any difference in your audio behavior. 

If you could also reboot your Beam and surround speakers by un-powering them briefly, this will also help.  

  

Badge

Hi,

Ive turned quick start off and rebooted all speakers.

We’ve just started having the same problem as well. 

It seems to start out of nowhere, both times mid song. 

The beam has two play 1 as surrounds and is connected via HDMI to an LG tv, which had an update around a week ago. 

It has happened twice now, starting both times when streaming youtube to the tv from our phones. We’ve tested music via deezer and playing sound from the TV normally and that works fine, but streaming from either youtube or netflix causes loud buzzing. 

The only solution Ive found so far is to turn everything off at the plug, after which it returns to normal. 

I did a diagnostic, but only after Id powered it off and on again if it helps at all. 

1891020492

Userlevel 5
Badge +16

Hello @montrano,

Have you disabled the Quick Start+ settings as I have recommended earlier in this thread? 

 

@Vosabhoy,

The most recent diagnostic I have from you is still showing that you system has been up for 10+ days without restarting. Can you submit a current report along with the current status of your issue? 

Badge

I restarted my beam and two sonus ones today.

Userlevel 5
Badge +16

@Vosabhoy, Can you follow up with a new diagnostic report so I can see if there is any changes in your system? 

Badge

Diagnostic 1485429350

Userlevel 5
Badge +16

Ah, thank you @Vosabhoy.

You had said that the only options available for the HDMI/ARC out were PCM or Auto, correct? 

If it is still set to “Auto” does  changing it to PCM make any difference? 

Do you notice any audio issues while your home theater source is playing or only when it is off?

Can you double (triple) check that the HDMI connection itself isn’t loose on either end. 

If you begin playback on a music source, does this audio disturbance persist while playing other sources?

I know this feel like 1,000 questions. I’m trying to pin down why disabling the Quick Start+ didn’t work as it should in your system. 

Badge

Hi, the HDMI cable is secure. PCM source sound quality is not as good as auto. I was playing music through the speakers and all seems well so far.

Badge

Problem arose again tonight watching television channel. Had to pull the power cable on the beam then reconnect. Convinced it's a problem with the recent update.

Userlevel 5
Badge +16

When you are watching TV, is this coming from a smart app on your TV or from an external streaming device like a Roku or cable box or game system?

Are you able to look at the audio format settings of any app, service or device to make sure that it is in a format supported by the Beam. 

If your TV audio format is set back to “Auto” make sure that any sources aren’t passing an incompatible audio signal.   

 

Badge

The long and short is that I didn't have any issues before the latest Sonus update. What are Sonus going to do to do about this fault????

Userlevel 5
Badge +16

Hello @montrano, Thank you for the new reports. 

The audio format from your TV is reading as “silence” in the data, can you double check to see what audio format the TV itself is set to output?

@Vosabhoy, as soon as we can pin down why this is happening, it can be fixed. right now the issue seems to be limited to certain TV manufacturers and systems. believe me, I appreciate the fact that it was working before. Did your TV receive any kind of firmware update around the same time that the Sonos system upgraded?    

Badge

No update for my LG tv recently.

Hi,

same problem here - couple years old Samsung TV and Beam connected with ARC - got first humming problem this morning, got 2nd time after couple of hours.

Some details that might help:

Humming is only on right channel while left channel is playing what seams to be correct sound.

When noise started second time tried changing output settings on TV - originally had Dolby Digital and when changed to PCM the hum frequrncy/pitch changed and when switched back to Dolby Digital pitch went back. Toggled this setting couple of times and it was constant behaviour like this.

Hum appeared only when there was sound coming from TV - no hum while in TV menus, only when Plex playback was active in my case. 

Played some audio from Sonos app - no problems, switched back to TV - hum came back.

Reconnected HDMI - silence when discinnected, hum when cinnected back.

Powercycled TV - no change.

Problem went away when powercycled Beam.

If it’s any help, but slightly off-topic, I’m having a similar issue intermittently with my PlayBase since upgrading to Sonos 2. I’m using a TOSlink connection from a Sony TV. The audio format is Dolby Digital 5.1. The set top box and TV are connected via HDMI (non-ARC).

I have the problem only when watching PBS stations. It goes away if I switch to a non-PBS channel but returns when I switch back to PBS. It goes away on the PBS channels as well if I put the TV and STB to sleep then wake them up.

Could it have something to do with the way British TV programs are re-encoded for broadcast in the USA?

It's set to auto sound everywhere.

Like the post above, it's only on YouTube and Netflix so far, it will play music and TV fine, but if you go back into those services it will buzz again until powered off. 

Also YouTube and Netflix have a different buzz.

If there's anything else I can test to help, let me know

I have had the exact same issue 3 times since the S2 update, though I'm yet to grab a diagnostic of it happening.

I have a Beam connected via HDMI Arc to an LG TV. In all 3 cases it's happened when using the Prime Video app on the TV itself (although even this doesn't happen every time).

Turning the TV off stops the buzzing, but as soon as the TV is switched back on again the buzzing returns, even when just viewing a menu. Similarly, unplugging the TV from the mains and plugging it back in again, as soon as the TV is switched on the buzzing returns.

Disconnecting and reconnecting the HDMI leads from both ends doesn't fix it. As soon as the HDMI is reconnected the buzzing restarts.

As others have mentioned, if I switch the TV off and then get the Beam to stream some music, it sounds fine. Turn the TV back on again, and the buzzing returns.

The only thing that fixes it is pulling the mains on the Beam.

I have a Sky box and a PS4 plugged into the TV via HDMI too, and have tried disconnecting these in case the TV is trying to pass nonsense from one of those (both are on standby), but again the buzzing continues.

I had no issues of this kind with the S1 firmware so can only assume that the S2 firmware is causing the issue.

Reply