Answered

Failure adding sonos one sl as surround to beam using unifi network

  • 26 September 2021
  • 8 replies
  • 84 views

Hi,

 

I am trying to add 2x Sonos one sl speakers as surround boxes to Beam. Network router Is unifi router (one LAN network, one ssid). All connected wireless to same SSID. As regular boxes added to the same chamber both boxes function well. But if I want to add them as surround to the beam, I get an error message stating they can not connect. diagnostic number 841887912.

icon

Best answer by Corry P 28 September 2021, 09:53

View original

8 replies

Userlevel 7

Try this:

  • Log into the UniFi controller.
  • In the Settings tab, click Wireless Networks.
  • Click Edit next to the network SSID.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.

Hi GuiterSuperstar,

Thanks for the suggestions.

Both settings were already in the by you indicated state.

Unfortunately I’ll have to investigate further.

 

While you wait for a Sonos rep to respond to your diagnostic, it might be worth a simple reboot to your router. The One SLs connect, as surround speakers, to a 5Ghz signal generated by your Beam, moving from your own wifi signal to the Beams “channel”. They still get IP addresses from your router, though, just “through” the Beam in this case. So it might also be worth double checking for any potential sources of wifi interference of some type, particularly near the 5Ghz channel, although not exclusively there. 

Oh, that raises another potential concern. Make sure you haven’t turned off the poorly labeled “wifi” on your Beam. It’s actually all radios, including the one that communicates to the surround speakers. 

Userlevel 7
Badge +18

Hi,

I am trying to add 2x Sonos one sl speakers as surround boxes to Beam. As regular boxes added to the same chamber both boxes function well. But if I want to add them as surround to the beam, I get an error message stating they can not connect.


Are they still assigned as a Room (I assume that’s what you mean by chamber)? If so you’ll need to break that association first, before you can use them as surrounds. 

Userlevel 7
Badge +17

Hi @Horizon 

Welcome to the Sonos Community!

I believe the problem may stem from the fact that your UniFi system is using multiple channels. Because Sonos speakers communicate directly with each other using the same channel that the WiFi is on, if they disagree about what channel is. Please set your UniFi system to only use channel 1.

If this doesn’t help, I recommend you connect either the Beam or one of the other speakers that are not going to be surrounds to the router with ethernet. Wait a minute or 2, then try again.

However, if you still have problems linking your surrounds to your Beam, I recommend you get in touch with our technical support team for some real-time troubleshooting.

I hope this helps.

Using ethernet cable to connect beam solves the problem.

 

Userlevel 7
Badge +17

Yes, because all Sonos devices get off your wifi and on to Sonosnet…..

Reply