Answered

Echo when Beam is connected to panasonic TV

  • 12 March 2021
  • 5 replies
  • 54 views

I have connected my new beam to my 49” Panasonic TV via the optic connection as there no HDMI ARC socket. Installation followed instructions from Sonos website using my phone. All went well except that sound from the TV has an echo . ( I had muted  the TV audio). TV sound is so inferior to that of TV speakers that we are considering returning the Beam. 

Any suggestions welcome.

icon

Best answer by gelair 13 March 2021, 05:21

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

So the echo is being caused by the delayed audio from your TV speakers?

Userlevel 7
Badge +18

You shouldn’t have any sound coming from the TV speakers. In the TV audio menu there should be a setting to “use external speakers” or something like that, to disable the TV’s internal speakers. Otherwise, when you use the tv remote to increase volume, the tv and the Beam volume will increase. 

Userlevel 7

Be sure you turn on VIERA Link (CEC) on your TV.

Echo disappeared when TV speakers were switched off completely. Thanks for your help.

Userlevel 7
Badge +18

No problem; now enjoy!