Connection to itunes breaking

  • 7 December 2020
  • 3 replies

I have a Play5 and have successfully linked it to iTunes on my windows 10 pc. More often than not the sonos app complains that it can't find the server. This is usually fixed by either rebooting my pc or the router but it happens a lot and is spoiling the enjoyment for me. Anyone else come across this problem?


Best answer by Rowena B. 8 December 2020, 00:10

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 5
Badge +16

Hi @steveclarke1958

Welcome to the Sonos community and thanks for reaching out to us. Looks like you're losing connection from your music library on your Windows PC that's why you're getting the error message "Can't find the server."

This happens if your Windows 10 PC is in sleep mode. When your Windows 10 PC goes into sleep mode, it turns off the display and it will temporarily disconnect from your network. In this state, if you're playing music from your computer, it will stop the music. When you wake your computer it will resume the services. However, in some instances, you need to reboot your computer or your network.

Let me share with you the troubleshooting steps you adjust the power settings on your computer.

  1. Open power options:
    • Go to Start , select Settings  > System  > Power & sleep  > Screen
    • Go to Start , select Settings  > System  > Power & sleep  > Sleep
      • If you select Never, your display will stay on until you shut it down.
      • You can also select a time frame in the dropdown.
  2. Click on Additional power settings > select Choose what the power buttons do > Power and sleep button settings
    • When I press the power button: set to Do nothing
    • When I press the sleep button: set to Do nothing
      • Save changes
  3. Once done, start music playback from your computer and observe if you will get the same error.

I'd appreciate it if you can submit a diagnostic report from your Sonos system. Just include the confirmation number in your response so that we can look up the information. 

Please keep me posted on the progress and let me know if you run into any issues for me to check.

Thanks for your response Rowena. I’ve changed the power button actions as you suggest. I’d already set screen and sleep settings to “never” as you suggest.

Further info I missed off - I have my Sonos connected to my pc via ethernet. In turn, the ethernet connection is routed through the ring main using a couple of BT adapters.

I’m at work at the moment but I’ll submit a diagnostic report when I find some time.

Kind regards


Userlevel 5
Badge +16

Hi @steveclarke1958, thanks for your response and for updating us. Please keep us posted on how it goes and we're here to answer any further questions you have.