Can't reauthorize Apple Music

  • 16 November 2021
  • 3 replies
  • 64 views

This seems like a very common problem. I have tried other threads here but so far none have resolved this issue.

As far as I can see this only seems to affect Android. My daughter uses iPhone without issues.

When I select Reauthorize I get a spinning pink progress bar then a white screen. It progress no further forwards.

I have uninstalled and reinstalled Sonos but to no avail. I have an Oppo A74 5G running Android 11, I also tried my older device running Android 8.1.0 but that now exhibits the same issue.

My Sonos system is up to date and contains 3 other speakers 2 Play:1’s and a Play:3. I’m using Sonos S2. 

Any help would be very welcome otherwise this speaker is junk.

 

Thanks


3 replies

Userlevel 7

It’s a known problem with Apple Music and Sonos using an Android device. Sonos is currently investigating the problem but has not announced a timeline for when it will be resolved.

Borrow your daughter’s iPhone or use another iOS device to re-authorize Apple Music on your Sonos account.

Thanks for your advice GuitarSuperstay.

My daughter lives elsewhere nowadays, she visited yesterday. I was thinking about junking my Sonos speakers as I thought perhaps they had finally made them obsolete, there was a threat a year or two ago. But she found she could authorise her account. 

Anyway, so just a moment ago I dusted off my old iPhone 6 from the drawer & luckily the Sonos app still runs on iOS 12. It works and reauthorised easily! So now I can once again listen to my Apple Music playlists, I’m good until Sonos stop supporting this version of iOS.

Hopefully Sonos fix this one soon, otherwise I might just pull out the old hifi and go back to using that.

You should be able to again use your Android device, having reauthorized using your iOS device. 

Reply