Beam - Not showing up as Airplay device on iphone 8 any more (shows on Mac and iPad)

  • 19 March 2021
  • 4 replies



My bean has stopped showing up on my iPhone as a possible airplay device. This appears to be the case with or without the Play:1’s connected as rear speakers.


My Mac can see the beam as an airplay device in the audio drop down and is select-able.


Oddly, my other iOS device can see it and it s running the same OS - 14.4.1


I have disabled all active VPN’s on the device but i imagine there could be something else interfering with this if its working on other deices. Ive reset both router and sonos devices a few times already to no avail.


Is this something any of you have seen or reported before?


Best answer by GuitarSuperstar 20 March 2021, 03:11

Have you rebooted your phone?

View original

4 replies

Userlevel 7

Have you rebooted your phone?

This happened to me the day you posted. My beam simply disappeared from my list of available AirPlay devices on my phone.


I’ve tried rebooting all the components of my system, and my router, rebooting my phone - no dice. 😫

I managed to get this back and working after restoring my iPhone from backup. Not ideal but out worked.


I have a feeling it could be linked to my Nord VPN app being installed and messing with network things but can't be sure. I have yet to re-install and turn it back on to see if it causes any negative issues. 

Wouldn’t be surprising if it wasn’t the Nord. The whole thing about VPNs is they’re supposed to block outside sources from the network stream between the device initiating the stream, and the device (router) receiving the stream. Any AirPlay 2 device would be considered outside of that network.