Answered

Beam not playing TV audio after playing music via Airplay2 or Chromecast


Hey all,

I’ve recently purchased a Beam and have it set up to my Samsung TV via HDMI ARC. 
 

The reason why I got the Beam was because of the integrated AirPlay2 and Chromecast features. Playing music with the tv kept OFF is fine. However, the problem arises when I decide to watch TV and the the Beam doesn’t produce any output. Even after ensuring the TV has the Beam as its output source, no sound from the TV. If I try to play music via Airplay or Chromecast at this point in time, there IS music from the sound bar and it gives me that warning in the Sonos app that it will stop audio from the TV. 
 

I’ve checked that TV auto play is ON, switched to TV in the Sonos S2 app (music notes > TV).

 

Is there a way to get this to work properly without having to power cycle both the TV and sound bar? Super annoying as it takes 5 extra minutes before I can start watching TV.

I can see that there are a few others who have experienced the same but the solutions didn’t work for me.

 

Any help would be appreciated  

 

 

 

icon

Best answer by Ken_Griffiths 23 July 2021, 15:01

Took a couple days to test all that you’ve suggested but nothing has worked. I really think it’s the TV… but even saying that, I’m not sure why it wouldn’t just work as intended given that it has the right ports, cables, settings etc. 
Frustrated, considering returning this as I’ve only had it for a week.  

The optical connection should have worked for you at the very least, but if your TV is mostly geared for DTS and DD+ codecs only, you may find you just receive stereo audio and so will need to set the TV to output PCM audio, it depends if the TV is backward compatible with Dolby Digital 5.1 and apparently a small few TV makes/models may not be, but it’s quite rare.

I would also speak with your TV manufacturers support desk and see if there is anything they can do to assist you.

View original

17 replies

Userlevel 7

Try disconnecting the Chromecast from the TV and testing the Beam.

Try disconnecting the Chromecast from the TV and testing the Beam.

Hey thanks for the reply. Just to clarify, when I referred to Chromecast I was referring to connecting to the Beam as a Chromecast.

In my scenario above there is nothing being casted to the TV via an external Google Chromecast.

 

Thanks 

 

 

Userlevel 7
Badge +17

The Beam does not have any Chromecast features, only Airplay 2 for sound. So if you expect images from your Beam (other than the screensaver) you stand to be disappointed…..

The Beam does not have any Chromecast features, only Airplay 2 for sound. So if you expect images from your Beam (other than the screensaver) you stand to be disappointed…..

You’re right. I meant AirPlay only and not Chromecast. Thanks for pointing that out. 

Hey all,

I’ve recently purchased a Beam and have it set up to my Samsung TV via HDMI ARC. 
 

The reason why I got the Beam was because of the integrated AirPlay2 and Chromecast features. Playing music with the tv kept OFF is fine. However, the problem arises when I decide to watch TV and the the Beam doesn’t produce any output. Even after ensuring the TV has the Beam as its output source, no sound from the TV. If I try to play music via Airplay or Chromecast at this point in time, there IS music from the sound bar and it gives me that warning in the Sonos app that it will stop audio from the TV. 
 

I’ve checked that TV auto play is ON, switched to TV in the Sonos S2 app (music notes > TV).

 

Is there a way to get this to work properly without having to power cycle both the TV and sound bar? Super annoying as it takes 5 extra minutes before I can start watching TV.

I can see that there are a few others who have experienced the same but the solutions didn’t work for me.

 

Any help would be appreciated  

 

Perhaps try one of these options…

Voice control to switch to TV Audio:

"Hey Google switch (or ‘set’) to TV Mode on Lounge” - where Lounge is the Sonos name of your Beam.

App Switching:

In Sonos App have the Beam Room in ‘focus’ on the ‘Now Playing’ screen and goto the Music Icon (music services) on main toolbar and scroll past the installed music services and select the ‘TV icon’.

In both cases mentioned above the TV should switch from the playing music, back to the TV audio.. (hopefully)🤞.

Hey all,

I’ve recently purchased a Beam and have it set up to my Samsung TV via HDMI ARC. 
 

The reason why I got the Beam was because of the integrated AirPlay2 and Chromecast features. Playing music with the tv kept OFF is fine. However, the problem arises when I decide to watch TV and the the Beam doesn’t produce any output. Even after ensuring the TV has the Beam as its output source, no sound from the TV. If I try to play music via Airplay or Chromecast at this point in time, there IS music from the sound bar and it gives me that warning in the Sonos app that it will stop audio from the TV. 
 

I’ve checked that TV auto play is ON, switched to TV in the Sonos S2 app (music notes > TV).

 

Is there a way to get this to work properly without having to power cycle both the TV and sound bar? Super annoying as it takes 5 extra minutes before I can start watching TV.

I can see that there are a few others who have experienced the same but the solutions didn’t work for me.

 

Any help would be appreciated  

 

Perhaps try one of these options…

Voice control to switch to TV Audio:

"Hey Google switch (or ‘set’) to TV Mode on Lounge” - where Lounge is the Sonos name of your Beam.

App Switching:

In Sonos App have the Beam Room in ‘focus’ on the ‘Now Playing’ screen and goto the Music Icon (music services) on main toolbar and scroll past the installed music services and select the ‘TV icon’.

In both cases mentioned above the TV should switch from the playing music, back to the TV audio.. (hopefully)🤞.


Hi Ken,

 

Thanks for those suggestions. Unfortunately neither of those two worked. 
 

Alexa doesn’t even turn the TV on when it’s doing this (and I turned the TV on to check) so it seems like it’s a problem with the HDMI CEC? Weird because it’s definitely connected in the HDMI ARC port… can’t be the cable because I’m using the one that came in the box.

 

Thanks 
Nick 

 

 

Userlevel 7
Badge +17

Maybe toggle Anynet+ off and on?

Maybe toggle Anynet+ off and on?

Yes have tried that also. TV tries to connect to the Anynet+ device for quite a while then eventually seems like it times out. I’ll try it again and it seems to work (ie. doesn’t time out). Then I try to change the source on the TV settings from TV speakers to the HDMI/receiver/Beam. Then there’s no sound but it says it’s using the HDMI as the output for the sound. 
 

Could it be that the TV is too old? It’s a Samsung J series TV. 

Maybe toggle Anynet+ off and on?

Yes have tried that also. TV tries to connect to the Anynet+ device for quite a while then eventually seems like it times out. I’ll try it again and it seems to work (ie. doesn’t time out). Then I try to change the source on the TV settings from TV speakers to the HDMI/receiver/Beam. Then there’s no sound but it says it’s using the HDMI as the output for the sound. 
 

Could it be that the TV is too old? It’s a Samsung J series TV. 

What codec is the digital Audio Output set to? Make sure it’s not set to either DTS, nor Dolby Digital Plus - it needs to be either PCM or Dolby Digital/Dolby Digital 5.1

Maybe toggle Anynet+ off and on?

Yes have tried that also. TV tries to connect to the Anynet+ device for quite a while then eventually seems like it times out. I’ll try it again and it seems to work (ie. doesn’t time out). Then I try to change the source on the TV settings from TV speakers to the HDMI/receiver/Beam. Then there’s no sound but it says it’s using the HDMI as the output for the sound. 
 

Could it be that the TV is too old? It’s a Samsung J series TV. 

What codec is the digital Audio Output set to? Make sure it’s not set to either DTS, nor Dolby Digital Plus - it needs to be either PCM or Dolby Digital/Dolby Digital 5.1

Hi Ken,

 

I double checked the codecs that my TV outputs and seems to be only DTS and DDP. What would the mix match in codecs do? 
 

Nick

Maybe toggle Anynet+ off and on?

Yes have tried that also. TV tries to connect to the Anynet+ device for quite a while then eventually seems like it times out. I’ll try it again and it seems to work (ie. doesn’t time out). Then I try to change the source on the TV settings from TV speakers to the HDMI/receiver/Beam. Then there’s no sound but it says it’s using the HDMI as the output for the sound. 
 

Could it be that the TV is too old? It’s a Samsung J series TV. 

What codec is the digital Audio Output set to? Make sure it’s not set to either DTS, nor Dolby Digital Plus - it needs to be either PCM or Dolby Digital/Dolby Digital 5.1

Hi Ken,

 

I double checked the codecs that my TV outputs and seems to be only DTS and DDP. What would the mix match in codecs do? 
 

Nick

Both DTS and DD+ codecs are not supported by the Sonos Beam - you should have an option to use stereo PCM - you will need to use that codec instead.

Maybe toggle Anynet+ off and on?

Yes have tried that also. TV tries to connect to the Anynet+ device for quite a while then eventually seems like it times out. I’ll try it again and it seems to work (ie. doesn’t time out). Then I try to change the source on the TV settings from TV speakers to the HDMI/receiver/Beam. Then there’s no sound but it says it’s using the HDMI as the output for the sound. 
 

Could it be that the TV is too old? It’s a Samsung J series TV. 

What codec is the digital Audio Output set to? Make sure it’s not set to either DTS, nor Dolby Digital Plus - it needs to be either PCM or Dolby Digital/Dolby Digital 5.1

Hi Ken,

 

I double checked the codecs that my TV outputs and seems to be only DTS and DDP. What would the mix match in codecs do? 
 

Nick

Both DTS and DD+ codecs are not supported by the Sonos Beam - you should have an option to use stereo PCM - you will need to use that codec instead.


 

Tried this and no change unfortunately. This is doing my head in and getting frustrated haha

 

Thanks for the suggestion though!

The PCM stereo codec should work. Have you tried the optical adapter supplied and a connection to the TV’s optical port, just to see if that works? - note the Beam must otherwise be connected to the TV’s Arc/eARC port, it cannot be connected to one of its HDMI ports, so perhaps double-check that the correct port is being used.

Check that AnyNet+ is switched on in the TV settings. Try also removing and putting back the HDMI cable between the TV/Beam too after switching the TV codec to PCM to setup the ‘handshake’ between the TV and the Beam.

The PCM stereo codec should work. Have you tried the optical adapter supplied and a connection to the TV’s optical port, just to see if that works? - note the Beam must otherwise be connected to the TV’s Arc/eARC port, it cannot be connected to one of its HDMI ports, so perhaps double-check that the correct port is being used.

Check that AnyNet+ is switched on in the TV settings. Try also removing and putting back the HDMI cable between the TV/Beam too after switching the TV codec to PCM to setup the ‘handshake’ between the TV and the Beam.

Tried what you’ve suggested. 
 

Optical does work.

Definitely plugged into the HDMI ARC port 

Anynet+ is on.

Switched to PCM and restarted both TV and Beam. It’ll work as intended. But I’ll leave for work for the day, come back and the problem persists again. HDMI appears connected (in settings) but no sound output. Sonos app also can’t see the Beam connected to the TV and tries to get me to test / set up - but it doesn’t get past the testing screen.

Tried what you’ve suggested. 
 

Optical does work.

Definitely plugged into the HDMI ARC port 

Anynet+ is on.

Switched to PCM and restarted both TV and Beam. It’ll work as intended. But I’ll leave for work for the day, come back and the problem persists again. HDMI appears connected (in settings) but no sound output. Sonos app also can’t see the Beam connected to the TV and tries to get me to test / set up - but it doesn’t get past the testing screen.

It sounds to me like another HDMI connected device has HDMI-CEC switched on and that the TV is allowing that ‘other’ device to steal the focus away from the Beam - a few things to try:

Uncable any other HDMI device connected to the TV and see if the problem goes away. If it does add each removed device back to the TV, one at a time,and test for a while to see if it is the ‘culprit’ stealing the focus. If it is, either switch off HDMI-CEC on that one device, or use a CEC-LESS adapter as shown in this LINK between the device and the TV.

The only other options to perhaps consider are to see if there is a firmware upgrade for the TV, or if not, then maybe use the optical connection from the TV instead.

Tried what you’ve suggested. 
 

Optical does work.

Definitely plugged into the HDMI ARC port 

Anynet+ is on.

Switched to PCM and restarted both TV and Beam. It’ll work as intended. But I’ll leave for work for the day, come back and the problem persists again. HDMI appears connected (in settings) but no sound output. Sonos app also can’t see the Beam connected to the TV and tries to get me to test / set up - but it doesn’t get past the testing screen.

It sounds to me like another HDMI connected device has HDMI-CEC switched on and that the TV is allowing that ‘other’ device to steal the focus away from the Beam - a few things to try:

Uncable any other HDMI device connected to the TV and see if the problem goes away. If it does add each removed device back to the TV, one at a time,and test for a while to see if it is the ‘culprit’ stealing the focus. If it is, either switch off HDMI-CEC on that one device, or use a CEC-LESS adapter as shown in this LINK between the device and the TV.

The only other options to perhaps consider are to see if there is a firmware upgrade for the TV, or if not, then maybe use the optical connection from the TV instead.

Took a couple days to test all that you’ve suggested but nothing has worked. I really think it’s the TV… but even saying that, I’m not sure why it wouldn’t just work as intended given that it has the right ports, cables, settings etc. 
Frustrated, considering returning this as I’ve only had it for a week.  

Took a couple days to test all that you’ve suggested but nothing has worked. I really think it’s the TV… but even saying that, I’m not sure why it wouldn’t just work as intended given that it has the right ports, cables, settings etc. 
Frustrated, considering returning this as I’ve only had it for a week.  

The optical connection should have worked for you at the very least, but if your TV is mostly geared for DTS and DD+ codecs only, you may find you just receive stereo audio and so will need to set the TV to output PCM audio, it depends if the TV is backward compatible with Dolby Digital 5.1 and apparently a small few TV makes/models may not be, but it’s quite rare.

I would also speak with your TV manufacturers support desk and see if there is anything they can do to assist you.

Reply