Beam disappears from App after playing through Roku TV - has to be unplugged and plugged in again every time

  • 26 November 2021
  • 13 replies
  • 76 views

I have a Sonos Beam that is connected to my Roku TV via Arc. I also have two Sonos SL speakers. Whenever I use the TV, which is setup to only play though the Beam, it works fine. When I then want to play music on all three speakers, the Beam disappears from the system in the app (the TV is powered down when I do this). If I unplug and plug in the Beam, it shows up without doing anything to reconnect it in the App System settings. 

This is super annoying to have to unplug and plug-in the Beam whenever I want to use it for music through the App with the other two speakers.


13 replies

Userlevel 7

Try unplugging all of your speakers from power for a couple of minutes and reboot your router. If this doesn’t help, if possible, wire one of your speakers directly to the router with an ethernet cable.

I’d be tempted to turn off CEC on the Roku  device, if possible. I’m suspecting it is obstructing the CEC connection with the Beam. 

Try unplugging all of your speakers from power for a couple of minutes and reboot your router. If this doesn’t help, if possible, wire one of your speakers directly to the router with an ethernet cable.

If by router you mean the wireless modem? If so that is not going to be possible because the modem in in the basement and the speakers are on a different floor. I do not have a separate router. Am I understanding correctly?

I’d be tempted to turn off CEC on the Roku  device, if possible. I’m suspecting it is obstructing the CEC connection with the Beam. 

Thanks - are you suggesting I deselect 1-touch Play and have neither option below selected? 

------

Current Devices with the following text are displayed on screen:
CEC devices found:
HDMI1: Sonos Beam*
HDMI2: Fire TC Stick

*Audio device
ARC: Active
System audio control: active

Setting Options are:

  • 1-touch Play - THIS WAS SELECTED - (described as follows: Allow other devices to automatically switch the TV to use it as the actives source/input when playback starts. For example, the start video playback on your Blu-rayt player and it will tell your TV to switch to the Blu-ray input) 
  • System standby (described as follows: When your TV goes to sleep, HDMI-connected devices will go to sleep. When an HDMI-connected device goes to sleep, your TV will go to sleep. Note, this may not work for all devices)

Try unplugging all of your speakers from power for a couple of minutes and reboot your router. If this doesn’t help, if possible, wire one of your speakers directly to the router with an ethernet cable.

If by router you mean the wireless modem? If so that is not going to be possible because the modem in in the basement and the speakers are on a different floor. I do not have a separate router. Am I understanding correctly?

Yes, but as long as the SL speakers are not ‘bonded’ to the Beam as surrounds, you could try this with one of your speakers just as a temporary measure and see if the problem goes away. If it does, then you can perhaps add a Sonos Boost to the setup instead to put in place of the wired speaker, but it’s best to (temporarily) try these things first.

When cabling the speaker to the router, do these few things:

  • Keep the wired Sonos device at least one metre away from your router.
  • Set the routers 2.4Ghz WiFi Channel to either channel 1, 6 or 11.
  • Set the SonosNet channel in the Sonos App ‘Settings/System/Network/Manage Networks’ area so that it is at least 5 channels away from your chosen router channel. 
  • Just for good measure, you could also remove your routers WiFi SSID/credentials from the Sonos App network settings if you later plan to keep a device wired, as those network settings are not required when running all on SonosNet - it may stop your speakers hopping between your router WiFi signal and the SonosNet signal. You. Can read more about these things in the links below: 

https://support.sonos.com/s/article/3235

https://support.sonos.com/s/article/3209

 

 

If none of the other suggestions work, I would certainly try turning off CEC, preferably on the Roku, and not the TV. Roku devices have previously been shown to not properly work with CEC, and cause the conditions you’re experiencing. There are CEC blocker devices available on Amazon that you put in line with the cable so as to block the malformed commands from the Roku, if you’re not able to turn it off on the Roku.

https://www.amazon.com/Lindy-HDMI-Adapter-Female-41232/dp/B00DL48KVI

Userlevel 7

@Airgetlam I believe the OP has a Roku Television, not an external Roku streaming device.

@OPlo_70 If you disconnect the Fire TV Stick, do you experience the same problem?

@Airgetlam I believe the OP has a Roku Television, not an external Roku streaming device.

@OPlo_70 If you disconnect the Fire TV Stick, do you experience the same problem?

@GuitarSuperstar you are correct. I have a Roku TV, not an external streaming device. I will try disconnecting the Fire TV Stick although this is not a prefect solution either as Roku does not have a web browsing app (please tell me if you know otherwise). This is the only use for the Fire Stick currently. Will try this and report back.

Try unplugging all of your speakers from power for a couple of minutes and reboot your router. If this doesn’t help, if possible, wire one of your speakers directly to the router with an ethernet cable.

If by router you mean the wireless modem? If so that is not going to be possible because the modem in in the basement and the speakers are on a different floor. I do not have a separate router. Am I understanding correctly?

Yes, but as long as the SL speakers are not ‘bonded’ to the Beam as surrounds, you could try this with one of your speakers just as a temporary measure and see if the problem goes away. If it does, then you can perhaps add a Sonos Boost to the setup instead to put in place of the wired speaker, but it’s best to (temporarily) try these things first.

When cabling the speaker to the router, do these few things:

  • Keep the wired Sonos device at least one metre away from your router.
  • Set the routers 2.4Ghz WiFi Channel to either channel 1, 6 or 11.
  • Set the SonosNet channel in the Sonos App ‘Settings/System/Network/Manage Networks’ area so that it is at least 5 channels away from your chosen router channel. 
  • Just for good measure, you could also remove your routers WiFi SSID/credentials from the Sonos App network settings if you later plan to keep a device wired, as those network settings are not required when running all on SonosNet - it may stop your speakers hopping between your router WiFi signal and the SonosNet signal. You. Can read more about these things in the links below: 

https://support.sonos.com/s/article/3235

https://support.sonos.com/s/article/3209

 

 

Thanks for the detailed instructions. Not even sure my AT&T Modem has these options but I will investigate. Likely will disconnecting the Fire Stick first. 

I beg your pardon, I did misread that. 

@GuitarSuperstar it was the Firestick. Sucks that I have to choose one or the other but thanks for the tip. Can always just plug the firestick in when I need it. 

Userlevel 7

@GuitarSuperstar it was the Firestick. Sucks that I have to choose one or the other but thanks for the tip. Can always just plug the firestick in when I need it. 

Have you tried turning off CEC on the Fire TV Stick? Go to Settings > Display and Audio > HDMI CEC Controls and turn it OFF.

@GuitarSuperstar it was the Firestick. Sucks that I have to choose one or the other but thanks for the tip. Can always just plug the firestick in when I need it. 

Have you tried turning off CEC on the Fire TV Stick? Go to Settings > Display and Audio > HDMI CEC Controls and turn it OFF.

Will try that next and report back. Much appreciated. 

Reply