Answered

AirPlay mutes on paired speakers

  • 19 March 2021
  • 7 replies
  • 55 views

Badge

Hoping I can get some help here… I have a pair of Sonos One SLs paired together as part of a wired Sonos setup; my Sonos Play:One is wired to my router. Everything works great… EXCEPT AirPlay to these speakers when they’re paired.

What happens is at some point, the speakers both go silent after anywhere between a minute to an hour. The streaming app on my iPhone X (usually Apple Music) indicates that it’s still streaming, I can use the controls to play/pause playback, I see the scrub bar moving, songs are still advancing through the playlist, etc. but there’s no audio! I can even pause (silent) playback using the touch controls on top of the Sonos speakers which is registered by my iPhone, although I cannot restart playback. The only way for me to get audio back is to disconnect AirPlay from the speakers then reconnect to them, but the problem eventually (and usually quickly) returns.

This ONLY happens when the speakers are paired. For testing, I unpaired them and I’ve streamed to one or both speakers without any drop outs.

Any ideas? Would a diagnostic help? I’m at my wit’s end!

 

icon

Best answer by Corry P 23 March 2021, 10:19

Hi @DerekF 

I think it best we give your system the best chance to play.

Please switch off your WiFi router and the 2 affected speakers. Once the router has been off for 30 seconds, switch it back on. It will take about 5 minutes for your WiFi to return - once it does, please switch on your pair of speakers again.

Please also reboot the phone that you are AirPlay-ing from.

Once all the devices are up-and-running, please test again. If the issues persist, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

View original

7 replies

My suspicion is some sort of bandwidth issue causing them to ‘drop’, likely due to some sort of wifi interference . Just to be sure, the pairing you’re doing is in the Sonos App, and not in the “send AirPlay 2” interface in the device?

 

Go to Settings/System/About My System. Do all the speakers show WM:0?

Badge

My suspicion is some sort of bandwidth issue causing them to ‘drop’, likely due to some sort of wifi interference . Just to be sure, the pairing you’re doing is in the Sonos App, and not in the “send AirPlay 2” interface in the device?

 

Yup, they are paired in the Sonos app. When I choose to AirPlay to them, I see the two speakers appear as a single entry under the paired name (in my case, “Dining Room”).

Badge

Go to Settings/System/About My System. Do all the speakers show WM:0?

Yes.

Userlevel 6
Badge +16

Hi @DerekF 

I think it best we give your system the best chance to play.

Please switch off your WiFi router and the 2 affected speakers. Once the router has been off for 30 seconds, switch it back on. It will take about 5 minutes for your WiFi to return - once it does, please switch on your pair of speakers again.

Please also reboot the phone that you are AirPlay-ing from.

Once all the devices are up-and-running, please test again. If the issues persist, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

Badge

Thanks, Corry I will do that! Since Sonosnet seemed to be causing me issues, I’ve since reverted to wifi for my setup. Should I switch back to Sonosnet for the test? (FWIW I’ve always used wifi up until I experienced this problem recently, when I decided to give Sonosnet a try.)

Userlevel 6
Badge +16

 @DerekF 

I should have also suggested making sure that both Sonos and your iPhone are up-to-date.

Thanks, Corry I will do that! Since Sonosnet seemed to be causing me issues, I’ve since reverted to wifi for my setup. Should I switch back to Sonosnet for the test? (FWIW I’ve always used wifi up until I experienced this problem recently, when I decided to give Sonosnet a try.)

There is no correct answer to that - use what ever works best for you. A wireless setup is often preferred by users, but some don’t have the option of adjusting certain WiFi settings. In these cases, having one wired unit can often help the whole system. If you have WiFi boosters or extenders, using SonosNet ensures that the speakers will never use them.

However, as you mentioned that you had issues on SonosNet, I now think that wireless interference may be the cause of those issues, and the AirPlay issue. I recommend you take a look at our reducing wireless interference page to identify and separate sources from near the speakers. Certainly, if your router is within 1m of either of your Sonos speakers, that will cause issues in both wired and wireless configurations. In wired mode, you may want to experiment with different WiFi channels: Settings » System » Network » Change SonosNet Channel.

 

Reply