AirPlay 2 Group – iOS Devices can no longer change group volume?

  • 29 April 2021
  • 3 replies
  • 45 views

I have a setup of one Sonos One grouped with two older Play:1s to form an AirPlay group.

Until recently when I used this AirPlay group on my Apple TV, iPhone, … I could adjust the volume on the iOS side and the volume of the group changed.
With a recent change (Sonos Update, iOS 14.5?, not sure) now only the volume of the Sonos One is changing leaving the other devices to be always out of sync / no longer controllable via Apple TV remote or Homekit automations.

Has anyone else noticed this?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

I’m using the new iOS 14.5 on an iPad and just quickly tested this, if I Airplay (via Apple Music) to a Sonos Move grouped with a Play:1 and adjust the volume, either in Apple Music, or the Sonos App, the group volume changes on both not just the ‘Move’… so the Play:1 adjusts its volume too.

FWIW I have the "include grouped rooms” option toggled ‘ON’ in "Settings/System/Airplay” in the Sonos App too.

Thanks for spending your time Ken! 

FWIW I have the "include grouped rooms” option toggled ‘ON’ in "Settings/System/Airplay” in the Sonos App too.

Interestingly I don’t see that option (app version 13.0.5 / 62188070). The only option for me is “Group Non-AirPlay Products” which of course I want to have turned on. 

Because I was already in the settings I started playing around. Besides a few other things I turned off AirPlay grouping and turned it back on later. That seems to have fixed it. Now the volume is changing for all speakers again. Fingers crossed it will stay like that ;) Thanks!

Thanks for spending your time Ken! 

FWIW I have the "include grouped rooms” option toggled ‘ON’ in "Settings/System/Airplay” in the Sonos App too.

Interestingly I don’t see that option (app version 13.0.5 / 62188070). The only option for me is “Group Non-AirPlay Products” which of course I want to have turned on. 

Because I was already in the settings I started playing around. Besides a few other things I turned off AirPlay grouping and turned it back on later. That seems to have fixed it. Now the volume is changing for all speakers again. Fingers crossed it will stay like that 😉 Thanks!

That’s okay - oh and it is “Group Non-Airplay Products” (as attached) - that will teach me to go check its exact wording. Glad you sorted it. 👍