When adding a specific Play:5 (gen2) to system, everything else is removed

I have a simple system using three Play:1 units and two Play:5 (gen2) devices.  I was using the Sonos S1 app on iOS, but after trying to resolve this issue I decided to see if the S2 app would resolve the issue.  Spoiler, it didn’t.

The system has been up and running for several years without issue.  Yesterday none of the devices were showing up on the app interface.  I called Sonos support and they helped troubleshoot for about 2 hours, but ultimately laid blame with my ISP router.  They indicated that the problem appeared to be that my router was “converting multicast into unicast”.  So I reached out to my ISP (AT&T) for support and we proceeded to troubleshoot for 5 additional hours with only a tiny bit of success.

I gave up and went to sleep and resumed troubleshooting on my own this morning.  


I was able to get some of the devices connected to my account again, but one of the Play:5 units gave me trouble.  I reset all the devices back to factory settings and started over.  But that same Play:5 still wouldn’t connect to the network with the other devices.  I could either get the other four devices set up and working, or I could get the single Play:5 set up and working, but not all of them at the same time.  It’s like they repelled each other.  This was the result if I used only WiFi or connected the Play:5 to the Ethernet.  It seemed to me that the single Play:5 was being forced to join a different network.  

Oddly, whenever I got the single Play:5 set up and working, the process would log me out of my account.  When I logged back in, I’d still only have the single Play:5 connected.

I decided to change my wifi network to separate the 2.4 GHz and 5 GHz bands.  I went through the process of erasing the network settings from the Sonos app and then going through Manage Networks to Update Networks for each of the Sonos devices.  This is where I noticed a slight difference between the single Play:5 and the other devices.  When selecting the unit that is giving me problems, the app prompted me me to “Press the button on your Play:5 to connect to it.”  When selecting the other Play:5 (the one that connects to the other Sonos devices as expected), I’m prompted to “Press the button on the Play:5 that’s playing the chime.”  The rest of the process for this device works properly.

Nothing I tried was able to get that one Play:5 to behave like the other one.  


Has anyone else had this experience or have any ideas what I can try to resolve the issue?


And just a reminder, this system has been working flawlessly for years.  We did switch ISPs from Comcast to AT&T several months ago, but the Sonos system has worked properly since then too.  

Besides a simple Netgear 8-port switch, there are no other network devices in the network besides the ISP provided HumAX Model BGW320-500.



Best answer by Corry P 22 April 2021, 10:26

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Badge +17

Hi @GSTechs, welcome to the community.


Thanks for the detailed post, there’s lots of useful information here. 

I’m glad you were able to get most of your system up and running, and we’ll try our best to get your last Play:5 online as well.

Do you happen to have a diagnostic report number from the system that just shows the Play:5 on its own? If so, I highly recommend getting back in touch with our support team so they can review this. It sounds to me like there is some communication issues happening and potentially something wrong with the Play:5 that our techs will be able to diagnose.

To address the difference in setup process - the “press the button on the chiming speaker” flow is brand new, and speakers on older firmware will not go through this setup, so it’s possible that your Play:5 is just on a version that’s a little bit older; nothing to worry about.

it’s taken me awhile to get back to troubleshooting this issue, but the status is still the same.  I can with get the single Play:5 to connected or the other four devices.  

Right now, I have the single Play:5 connected and ran a diagnostic report.  That number is 1126796806. 

I also ran a diagnostic report when the other four devices were connected.  That number is 942798725. 

Anyone have any ideas?

I haven’t had time to deal with this during the normal support hours and when I tried to chat with support a few times today, no agents were available and was told to try again later.  Very frustrating not being able to reach support for this high-end and high cost consumer AV product on a Saturday afternoon.  

While I was typing my last entry, and without doing anything to my system, when I returned to the S2 app, the system reverted back to the other four devices being connected and the single Play:5 nowhere to be found.  

I ran a new diagnostic report.  And here’s that number.  686511129


I think you may have set the Play:5 up as a separate system from the other speakers.  Your app is connecting to the first system to respond.

Factory reset the Play:5 ONLY.  Then use ‘add product’ to add it to the other system.

Here is how to reset - for the Play:5 you use the ‘Join’ physical button.

Thanks John,


I assumed that was the case too and it may very well be, but I’ve tried resetting only the single Play:5 multiple times to no avail.  I’ve pretty much tried every combination of resetting the various components with the same results.  Each time it seems like it might work and each time I’m disappointed.  It feels like I’m being pranked...

It must be immensely frustrating.

Are any of your devices wired to the network?  If not could you experimentally wire one, reboot the other devices, then factory reset and add the ‘rogue’ Play:5?

It must be immensely frustrating.

Are any of your devices wired to the network?  If not could you experimentally wire one, reboot the other devices, then factory reset and add the ‘rogue’ Play:5?

I have tried the process various ways, including a wired connection to the single Play:5, wired connection to the other Play:5, WiFi on both the 5GHz and 2.4GHz, all with the same result.  

I am not able to get the single Play:5 to appear in the same system with the other devices.  It doesn’t matter if I try to add the single Play:5 to the system with the other four devices, nor does it matter if I add the other four devices to the system with the single Play:5.  It always results the same way.  

Userlevel 7
Badge +18

Hi @GSTechs 

Your most recent diagnostic reports an IP mismatch on the Dining Room Play:5.

Please remove power from your router and all of your Sonos devices. Once your router has been off for 30 seconds or more, power it back on and wait for the internet to work over WiFi before turning your Sonos devices back on. Wait for solid white lights before passing judgement.

If issues persist (or come back after some time), you may need to setup static IPs for Sonos on your network - our technical support team would be happy to assist.

Thank you Corry,


I’ve performed that process a dozen times with the same end result.  

What is the process for setting static IPs for the Sonos products?

Hi @GSTechs 

Your most recent diagnostic reports an IP mismatch on the Dining Room Play:5.


Hi Corry - I want to understand your comment about the Dining Room Play:5 having an IP mismatch.  Do you mean that that Sonos device has the same IP as another device on my network or something else?

I’m looking at a network management app on my phone and I show the four Sonos devices pulling an IP as one would expect, but the single Sonos Play:5 shows that it is “not in network”.  

Did you review all of the last three diagnostic reports I sent?  Or just the last one?  If you didn’t review all of them, that may give you more insight into the issue.  


Userlevel 7
Badge +18

Hi @GSTechs 

Apologies - the issue is a gateway IP address mismatch. All your devices, apart from the problem Play:5, agree that the router’s local IP address is Your Play:5 thinks the router’s address is it’s public IPs address (which I won’t share), and the speaker itself also thinks that it’s local IP address is what your public IP is - like the speaker is in your router’s DMZ (demilitarised zone). All of your submitted diagnostics report this either with one speaker or another.

I can’t give you any specifics about how to fix this, as it varies from router to router and it could also just be a fault, so I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them remotely connect to your computer and have a look at the router settings for you.

Failing that, all I can suggest is a factory reset of your router or contacting your Internet Service Provider. It could be a faulty router (this seems more likely than anything else, apart from possible misconfiguration).

The speaker not having a local IP address explains why the router describes it as “not on network”. Aside from any diagnostics, right now the Dining Room is reporting it’s private IP is your public IP.